Project

General

Profile

feature request #9337

Open issues for reimplementation of termtree editors

Added by Katja Luther 11 months ago. Updated 3 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
11/30/2020
Due date:
% Done:

100%

Severity:
normal
Tags:

Description

copied from #8774

  1. Show supplemental data (IMPORTANT)(actually only for nodes)

  2. For a very short time it still seems to open it on buttom and then moves it up. This looks not nice (though not critical). This only happens when opening a termtree editor the first time, when closing and reopening the editor it opens at the right place.

  3. full support for orderRelevant(#8474), isFlat(#8476) and allowDuplicates(#8776) (IMPORTANT)

  4. tree collapses sometimes after save

  5. d&d from vocabulary editor to character editor not yet supported (maybe handled in #8554, #8238)

  6. d&d from character vocabulary editor to character term tree editor fails saying term types do not match (though they are both of type Character) - (maybe handled in #8554, #8238)

  7. d&d from other term tree editor (to character editor or maybe also to term tree editor throws exception), see #8774#note-68

  8. decide if Characters should not be possible to exist in Feature tree (but ofcourse not the other way round) - see also #8554, #8238

  9. in Character Editor allow adding the new created Character at the focus place, not only on top

  10. show term details in details view of term editor (#9287)

  11. Add symbols for flags in use for term trees in term tree editor (#9288) this is implemented for hierarchical collections

  12. Show error message when feature tree can not be shown because of dirty data (#9334)

  13. Restructure term menus(#9338)

  14. fix remaining issue in #8756 (refresh button for structure tree and property tree in Character Editor)

  15. rename FeatureTreeDtoDropAdapter to TermTreeDtoDropAdapter?

  16. Add "Open in Referencing Objects view" to term tree editor context menu (similar to #8289, there it is by far more important but still we should have it everywhere

  17. Add "Open in Vocabulary" to term tree editor context menu; this is generally needed the primary usecase is to allow to edit terms if needed, which is currently not possible in term tree editor

  18. When deleting a tree and then saving for a short time the tree reappears in the UI which is confusing (low priority)

  19. !! Corrupt data when using copy & paste (#9353)

  20. Paste requires save first. Is this really needed? Most task are now handled without save-requirement so it breaks a bit the look&feel.

  21. After creating a new term tree set the focus to the new tree and in details view in title cache field #9572

  22. New menu in term tree editor should have alternatives for flags #9643

picture567-1.png View (7.95 KB) Andreas Müller, 07/05/2021 08:55 PM


Related issues

Related to Edit - feature request #8474: Make TermCollection.orderRelevant usable for TermTrees Closed 08/16/2019
Related to Edit - feature request #8476: Implement support for TermCollection.isFlat in TaxEditor Closed 08/16/2019
Related to Edit - bug #8776: Open issues for TermCollection.allowDuplicates handling in TaxEditor Closed 08/19/2019
Related to Edit - feature request #9287: Show term details in details view of term tree editor Closed 11/09/2020
Related to Edit - feature request #9288: Add symbols for flags in use for term trees in term tree editor Closed 11/09/2020
Related to Edit - feature request #8756: Refresh button for structure tree and property tree in Character Editor Feedback 12/10/2019
Related to Edit - feature request #9338: Restructure term menus Closed 12/01/2020
Related to Edit - feature request #8289: Add "Open in RefObj view" to term editor context menu Closed 05/22/2019
Related to Edit - bug #9353: Copy & Paste creates dirty data in term trees Closed 12/09/2020
Related to Edit - feature request #8238: Allow interoperability between term trees Feedback 04/11/2019
Related to Edit - feature request #9572: After creating a new term tree set the focus to the new tree Closed 03/31/2021
Duplicated by Edit - bug #9343: Open issues for DTO based term tree & character editor Duplicate 12/03/2020
Duplicated by Edit - feature request #8554: Allow drag&drop from character into FeatureTrees Duplicate 09/19/2019
Copied from Edit - bug #8774: Reimplement term tree editors to implement the general save strategy Closed 12/17/2019
Copied to Edit - feature request #9697: Remaining issues for reimplementation of termtree editors New 07/05/2021

Associated revisions

Revision ea6ec182 (diff)
Added by Katja Luther 10 months ago

ref #9337: remove obsolete part descriptions

Revision 9bf8e8eb (diff)
Added by Katja Luther 4 months ago

ref #9337: paste does not need save

Revision 12addc56 (diff)
Added by Katja Luther 4 months ago

ref #9337, #9287: show details of term and supplemental data of term node

Revision 070a27a4 (diff)
Added by Katja Luther 4 months ago

ref #9337: open in... vocabulary

Revision 9e8ecb58 (diff)
Added by Katja Luther 4 months ago

ref #9337: allow adding characters on selected node

Revision ecf4068f (diff)
Added by Katja Luther 4 months ago

ref #9337: characterLabelProvider needs to be adapted, too

Revision 257a82c2 (diff)
Added by Katja Luther 4 months ago

ref #9337: allow d&d from character voc -> tree and add tree image

Revision 1780aa78 (diff)
Added by Katja Luther 3 months ago

ref #9337: handle termnodes for open in ...

Revision 01098f79 (diff)
Added by Katja Luther 3 months ago

ref #9337: correct focus when open in ... vocabulary

Revision 18559d5b (diff)
Added by Katja Luther 3 months ago

ref #9337: correct focus when open in ... vocabulary - continue

Revision bb0c55f9 (diff)
Added by Katja Luther 3 months ago

ref #9337: correct focus when open in ... vocabulary - code cleaning

Revision 786745d9 (diff)
Added by Katja Luther 3 months ago

ref #9337: set uuid and id not editable

Revision c168ff52 (diff)
Added by Katja Luther 3 months ago

ref #9337, #9288: add image for list

Revision e6414409 (diff)
Added by Katja Luther 3 months ago

ref #9337, #9680:remove set focus on titleCache and search for nomenclatural author and collector

Revision dae62d9a (diff)
Added by Katja Luther 3 months ago

ref #9337: add hierarchical icon to label of term tree editor

History

#1 Updated by Katja Luther 11 months ago

  • Related to bug #8774: Reimplement term tree editors to implement the general save strategy added

#2 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#3 Updated by Andreas Müller 11 months ago

#4 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#5 Updated by Katja Luther 11 months ago

  • Description updated (diff)

#6 Updated by Andreas Müller 11 months ago

  • Description updated (diff)
  • Target version changed from Unassigned CDM tickets to Release 5.19

#7 Updated by Andreas Müller 11 months ago

  • Duplicated by bug #9343: Open issues for DTO based term tree & character editor added

#8 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#9 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#10 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#11 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#12 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#13 Updated by Andreas Müller 11 months ago

#14 Updated by Andreas Müller 11 months ago

#15 Updated by Andreas Müller 11 months ago

  • Related to bug #8776: Open issues for TermCollection.allowDuplicates handling in TaxEditor added

#16 Updated by Andreas Müller 11 months ago

#17 Updated by Andreas Müller 11 months ago

  • Related to feature request #9288: Add symbols for flags in use for term trees in term tree editor added

#18 Updated by Andreas Müller 11 months ago

  • Related to bug #9334: Show error message when feature tree can not be shown because of dirty data added

#19 Updated by Andreas Müller 11 months ago

  • Related to feature request #8756: Refresh button for structure tree and property tree in Character Editor added

#20 Updated by Andreas Müller 11 months ago

#21 Updated by Andreas Müller 11 months ago

#22 Updated by Andreas Müller 11 months ago

  • Related to deleted (bug #8774: Reimplement term tree editors to implement the general save strategy)

#23 Updated by Andreas Müller 11 months ago

  • Copied from bug #8774: Reimplement term tree editors to implement the general save strategy added

#24 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#25 Updated by Andreas Müller 11 months ago

#26 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#27 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#28 Updated by Andreas Müller 10 months ago

  • Description updated (diff)

#29 Updated by Andreas Müller 10 months ago

  • Related to bug #9353: Copy & Paste creates dirty data in term trees added

#30 Updated by Andreas Müller 10 months ago

  • Description updated (diff)

#31 Updated by Katja Luther 10 months ago

  • Description updated (diff)

#32 Updated by Katja Luther 10 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

#33 Updated by Katja Luther 10 months ago

  • Description updated (diff)

#34 Updated by Katja Luther 10 months ago

  • Description updated (diff)

#35 Updated by Katja Luther 10 months ago

  1. Add "Open in Vocabulary" to term tree editor context menu; this is generally needed the primary usecase is to allow to edit terms if needed, which is currently not possible in term tree editor

Maybe can be solved with https://stackoverflow.com/questions/21122233/how-to-pass-object-parameters-in-command

#36 Updated by Katja Luther 9 months ago

#37 Updated by Andreas Müller 9 months ago

  • Description updated (diff)

#38 Updated by Katja Luther 9 months ago

  • Description updated (diff)

#39 Updated by Andreas Müller 8 months ago

  • Description updated (diff)

#40 Updated by Andreas Müller 8 months ago

#41 Updated by Andreas Müller 8 months ago

  • Description updated (diff)

#42 Updated by Katja Luther 8 months ago

  • Description updated (diff)

#43 Updated by Andreas Müller 8 months ago

  • Description updated (diff)

#44 Updated by Andreas Müller 7 months ago

  • Description updated (diff)

#45 Updated by Andreas Müller 7 months ago

#46 Updated by Andreas Müller 7 months ago

  • Target version changed from Release 5.19 to Release 5.22

#47 Updated by Katja Luther 6 months ago

  • Target version changed from Release 5.22 to Release 5.25

#48 Updated by Andreas Müller 5 months ago

  • Description updated (diff)
  • % Done changed from 0 to 20

#49 Updated by Katja Luther 4 months ago

  • Description updated (diff)

#50 Updated by Katja Luther 4 months ago

  • Description updated (diff)

#51 Updated by Katja Luther 4 months ago

  • Description updated (diff)

#52 Updated by Katja Luther 4 months ago

  • Description updated (diff)

#53 Updated by Katja Luther 4 months ago

  • Description updated (diff)

#54 Updated by Katja Luther 4 months ago

  • Description updated (diff)

#55 Updated by Katja Luther 4 months ago

  • Description updated (diff)

#56 Updated by Katja Luther 4 months ago

  • Description updated (diff)

#57 Updated by Andreas Müller 3 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 20 to 50

#58 Updated by Andreas Müller 3 months ago

I moved all issues still marked as open to a new ticket #9697.

The issues marked as fixed are for review.

#59 Updated by Andreas Müller 3 months ago

#60 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Show supplemental data

The UUID and Oject ID fields are now editable (or at least changeable), this seems to be a general issue, not only for term nodes.

Is there a technical reason why only term nodes can be shown and not term trees?

#61 Updated by Andreas Müller 3 months ago

d&d from vocabulary editor to character editor not yet supported (maybe handled in #8554, #8238)

This to me seems to be fixed. Is there a reason why it is not yet marked as fixed? If not, please remove entry in #9697 and mark here as fixed.

Of course there is still the open issue #8238 but this is special case so maybe we should link to it separately in #9697 and we also have the open issue 8. related to it

#62 Updated by Andreas Müller 3 months ago

in Character Editor allow adding the new created Character at the focus place, not only on top

This to me still seems to be open

#63 Updated by Andreas Müller 3 months ago

In the Character Editor the details view does not show data anymore. This to me seems critical as this is a place where the characters really need to be adapted (not only shown like in term tree editor) after they were created by pushing the create button.

#64 Updated by Andreas Müller 3 months ago

sub issue #8756 to me is a critical issue. If possible we should try to fix it within this milestone.

#65 Updated by Andreas Müller 3 months ago

Add "Open in Referencing Objects view" to term tree editor context menu

This does not seem to work, neither in term tree editor nor in vocabulary editor (though I thought I had seen it already). Is there a regression?
In both, term tree and vocabulary editor it only shows 2 lines with nothing in between:

#66 Updated by Andreas Müller 3 months ago

Add "Open in Vocabulary" to term tree editor context menu;

also this is not visible anymore to me

#67 Updated by Andreas Müller 3 months ago

After creating a new term tree set the focus to the new tree and in details view in title cache field

As we have a dialog now for title creation we don't need to set the focus anymore.
Or maybe better set the focus on the tree in the tree editor to immediately allow to use full menu. Currently, when first right mouse clicking on the tree, to me it only shows a more or less empty menu (only entry is disabled "paste"). I guess this is related to the entry not having the focus yet.

#68 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

In the Character Editor the details view does not show data anymore. This to me seems critical as this is a place where the characters really need to be adapted (not only shown like in term tree editor) after they were created by pushing the create button.

I can't reproduce this (tested with nightly)

#69 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

in Character Editor allow adding the new created Character at the focus place, not only on top

This to me still seems to be open

Tested with nightly and when a node is selected in character tree, the newly created node appears as a child of this node.

#70 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

Add "Open in Vocabulary" to term tree editor context menu;

also this is not visible anymore to me

you can find it in the open in ... menu, but there is still a problem with setting the focus to the term.

#71 Updated by Andreas Müller 3 months ago

Katja Luther wrote:

Andreas Müller wrote:

in Character Editor allow adding the new created Character at the focus place, not only on top

This to me still seems to be open

Tested with nightly and when a node is selected in character tree, the newly created node appears as a child of this node.

Hmm, strange, now it works for me, too. Yesterday the new term appeared on top of the list.

#72 Updated by Andreas Müller 3 months ago

Katja Luther wrote:

Andreas Müller wrote:

In the Character Editor the details view does not show data anymore. This to me seems critical as this is a place where the characters really need to be adapted (not only shown like in term tree editor) after they were created by pushing the create button.

I can't reproduce this (tested with nightly)

Also this I can't reproduce today.

#73 Updated by Andreas Müller 3 months ago

Also the "Open issue" is not reproducable anymore today. There must have been some strange problem with the build yesterday.

#74 Updated by Katja Luther 3 months ago

  • Status changed from Feedback to Resolved

Katja Luther wrote:

Andreas Müller wrote:

Add "Open in Vocabulary" to term tree editor context menu;

also this is not visible anymore to me

you can find it in the open in ... menu, but there is still a problem with setting the focus to the term.

the focus issue is solved, too.

#75 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Feedback

Are the other issues also fixed (#60, #61, #64, #67)

#76 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

Are the other issues also fixed (#60, #61, #64, #67)

#67 is fixed, #60 is fixed

#64 is a cache problem

#61 is not fully solved I think but I will check this again.

#77 Updated by Andreas Müller 3 months ago

#note-67 does not fully work for me yet. The new tree seems to get the focus but immediately looses it again. Looks like the title cache field in details view still gets the focus because when I start writing the content goes there.

What is needed is that the new tree in the tree editor gets the focus in a way that right clicking the mouse will immediately show it correct context menu without left mouse click before.

#78 Updated by Andreas Müller 3 months ago

... by the way this should be the behvior anyway and also works for tree nodes but does not seem to work for trees.

#79 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

#note-67 does not fully work for me yet. The new tree seems to get the focus but immediately looses it again. Looks like the title cache field in details view still gets the focus because when I start writing the content goes there.

What is needed is that the new tree in the tree editor gets the focus in a way that right clicking the mouse will immediately show it correct context menu without left mouse click before.

this is fixed, missed to check in the removed setfocus on titleCache

#80 Updated by Andreas Müller 3 months ago

Katja Luther wrote:

#61 is not fully solved I think but I will check this again.

You are right, this is not yet implemented.

#81 Updated by Andreas Müller 3 months ago

  • Tags set to additivity
  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

#82 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

Issues related to notes 60 and 67 work as expected now.

Issue related to 64 needs further investigation and therefore will be handled in follow up ticket #9697.

All other open issues will also be handled in follow up ticket #9697.

#83 Updated by Andreas Müller 3 months ago

  • Related to deleted (bug #9334: Show error message when feature tree can not be shown because of dirty data)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)