Project

General

Profile

bug #9353

Copy & Paste creates dirty data in term trees

Added by Katja Luther 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
12/09/2020
Due date:
% Done:

80%

Severity:
normal
Found in Version:

Description

It was missed to implement copy & paste for the dto implementation of the term tree editors, the menu items are still available but produce termnodes without terms.

picture135-1.png View (18.7 KB) Andreas Müller, 01/21/2021 06:31 PM

picture752-1.png View (16.6 KB) Andreas Müller, 01/21/2021 06:35 PM


Related issues

Related to Edit - feature request #9337: Open issues for reimplementation of termtree editors In Progress 11/30/2020

Associated revisions

Revision 27ca5153 (diff)
Added by Katja Luther 3 months ago

fix #9353: fix c&p in term trees

Revision e12ba935 (diff)
Added by Katja Luther about 1 month ago

ref #9353: fix check for duplicates when duplicates allowed

History

#1 Updated by Andreas Müller 3 months ago

#2 Updated by Katja Luther 3 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Katja Luther 3 months ago

  • Assignee changed from Katja Luther to Andreas Müller

#4 Updated by Andreas Müller about 2 months ago

There is a duplicate error message when c%p a duplicate term to a non-duplicate allowing tree.

last remote method : http://test.e-taxonomy.eu:80/cdmserver/rem_conf_am/remoting/termnode.service
last remote request client time : 2021-01-21T18:29:20.452
last remote request response header time : Thu, 21 Jan 2021 18:29:20 GMT
client error time : 2021-01-21T18:29:20.493
login : admin
editor version : 5.19.0.202101211659
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 5.18.6.0.20201124
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
java.lang.Exception: This term tree does not allow duplicate terms.
    at eu.etaxonomy.cdm.api.service.TermNodeServiceImpl.addChildNode(TermNodeServiceImpl.java:160)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:333)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:190)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)
    at org.springframework.transaction.interceptor.TransactionInterceptor$1.proceedWithInvocation(TransactionInterceptor.java:99)
    at org.springframework.transaction.interceptor.TransactionAspectSupport.invokeWithinTransaction(TransactionAspectSupport.java:283)
    at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:96)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:213)
    at com.sun.proxy.$Proxy809.addChildNode(Unknown Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:333)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:190)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)

Only 1 error message should appear

#5 Updated by Andreas Müller about 2 months ago

The error message on duplicate also appears if the tree allows duplicates:

#6 Updated by Andreas Müller about 2 months ago

Andreas Müller wrote:

There is a duplicate error message when c%p a duplicate term to a non-duplicate allowing tree.
...

I could not reproduce this later

#7 Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Paste requires save first. Is this really needed? Most task are now handled without save-requirement so it breaks a bit the look&feel.

#8 Updated by Andreas Müller about 2 months ago

In general the copy&past works now.

#9 Updated by Katja Luther about 1 month ago

  • Status changed from Feedback to Resolved

Duplicates can be copied now (for trees allowing duplicates)

The problem of two error dialogs I could not reproduce.

#10 Updated by Katja Luther about 1 month ago

  • Assignee changed from Katja Luther to Andreas Müller

#11 Updated by Andreas Müller about 1 month ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 80

Andreas Müller wrote:

Paste requires save first. Is this really needed? Most task are now handled without save-requirement so it breaks a bit the look&feel.

This seem not yet being answered. If difficult to implement please move to new ticket or include in #9337.

Ticket can be closed except for this issue.

#12 Updated by Katja Luther about 1 month ago

  • Status changed from Feedback to Closed

#13 Updated by Katja Luther about 1 month ago

Andreas Müller wrote:

Andreas Müller wrote:

Paste requires save first. Is this really needed? Most task are now handled without save-requirement so it breaks a bit the look&feel.

This seem not yet being answered. If difficult to implement please move to new ticket or include in #9337.

moved this issue to #9337.

Ticket can be closed except for this issue.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)