Project

General

Profile

feature request #8136

Implement sources for type designations in TaxEditor

Added by Andreas Müller 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
02/24/2019
Due date:
% Done:

100%

Severity:
normal

Description

For details see #8017.

Be aware that there are 2 different types of sources "lectotype" sources and general sources. "Lectotype" source is exactly 1 source which should only be available for type designations with a status returning true on isLectotype().

implemented:

  • sources in supplemental data view
  • reference for lectotypes
  • update type section when changing type to lectotype or from lectotype

picture893-1.png View (30.2 KB) Patrick Plitzner, 04/10/2019 06:12 PM

picture426-1.png View (42.8 KB) Patrick Plitzner, 04/11/2019 08:47 AM

picture499-1.png View (14.6 KB) Andreas Müller, 04/11/2019 10:43 AM


Related issues

Related to Edit - feature request #7653: [DISCUSS] Delete NameFacts => Result: no Closed 08/14/2018
Related to Edit - feature request #8137: Implement sources for type designations in data portal New 02/24/2019
Related to Edit - feature request #8135: Implement verbatim type information in TaxEditor In Progress 02/24/2019
Related to Edit - bug #8140: Update list of type designation status which allow an explicit source Resolved 02/25/2019
Related to Edit - feature request #8139: [Rule] Validate lectotype sources Resolved 02/25/2019
Related to Edit - feature request #6413: [DISCUSS] How to create type duplicates (e.g. isotypes) for a taxon name Closed 02/08/2017
Blocked by Edit - feature request #8017: TypeDesignations need sources additional to lectotypifcation sources Closed 01/24/2019

Associated revisions

Revision 341ee745 (diff)
Added by Katja Luther 3 months ago

adadpt editor to changes in TypeDesignationBase

Revision 87934a59 (diff)
Added by Katja Luther 3 months ago

ref #8136: move sources to supplemental data

Revision 89084783 (diff)
Added by Katja Luther 3 months ago

ref #8136: add reference part for lectotype

Revision 9f40979f (diff)
Added by Katja Luther 2 months ago

fix #8136: update type section when changing type to or from lectotype

Revision 6bf65877 (diff)
Added by Katja Luther about 2 months ago

ref #8136: save citation of typeDesignation

Revision 03a2b1f4 (diff)
Added by Patrick Plitzner about 2 months ago

ref #8136 Show micro citation in details view

Revision 310480f4 (diff)
Added by Katja Luther about 2 months ago

ref #8136: remove citation if changed away from lectotype

Revision b0ed30f0 (diff)
Added by Katja Luther about 2 months ago

ref #8136: add warning message when changing type away from lectotype and citation exist

Revision 09015fb4 (diff)
Added by Katja Luther about 2 months ago

ref #8136: externalization

Revision 63878e5a (diff)
Added by Katja Luther about 2 months ago

ref #8136: externalization

Revision 46d9527b (diff)
Added by Andreas Müller about 1 month ago

ref #8136 slightly changed lectotype reference removal warning

Revision a53422d5 (diff)
Added by Katja Luther about 1 month ago

ref #8136: fix handling if status is set to null

Revision c3cad351 (diff)
Added by Katja Luther about 1 month ago

ref #8136: label issues

Revision e5d18094 (diff)
Added by Katja Luther about 1 month ago

ref #8136: move not designated checkbox

Revision 9e150d47 (diff)
Added by Katja Luther about 1 month ago

ref #8136: shorter reference detail label

History

#1 Updated by Andreas Müller 3 months ago

  • Blocked by feature request #8017: TypeDesignations need sources additional to lectotypifcation sources added

#2 Updated by Andreas Müller 3 months ago

#3 Updated by Andreas Müller 3 months ago

  • Description updated (diff)

#4 Updated by Andreas Müller 3 months ago

#5 Updated by Andreas Müller 3 months ago

#6 Updated by Andreas Müller 3 months ago

  • Related to bug #8140: Update list of type designation status which allow an explicit source added

#7 Updated by Andreas Müller 3 months ago

#8 Updated by Andreas Müller 3 months ago

  • Related to feature request #6413: [DISCUSS] How to create type duplicates (e.g. isotypes) for a taxon name added

#9 Updated by Katja Luther 3 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

#10 Updated by Katja Luther 3 months ago

  • Description updated (diff)

#11 Updated by Katja Luther 3 months ago

  • Priority changed from New to Highest

#12 Updated by Katja Luther 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

#13 Updated by Katja Luther 2 months ago

  • Description updated (diff)
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 50 to 0

please review

#14 Updated by Katja Luther 2 months ago

  • Description updated (diff)

#15 Updated by Katja Luther about 2 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

#16 Updated by Patrick Plitzner about 2 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50

tested on nightly.

Changing to any *lectotype will show the reference related elements. The reference and the details are saved correctly.

Only issue: When changing from *lectotype which already has a reference to any non-lectotype, saving and then changing back to *lectotype the reference is still connected to this type designation. This may be a feature and not a bug.

#17 Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Patrick Plitzner wrote:

tested on nightly.

Changing to any *lectotype will show the reference related elements. The reference and the details are saved correctly.

Only issue: When changing from *lectotype which already has a reference to any non-lectotype, saving and then changing back to *lectotype the reference is still connected to this type designation. This may be a feature and not a bug.

No, I don't think this is a feature. We should handle these type changes consistently. Changing nomenclatural code might be a template. There, if you change the code, and an existing information is deleted this way you get a warning and you have to agree explicitly. The same should happen here.

By the way, changing the rank does not give the same warning, e.g. change species to genus the specific epithet is still stored. This to me does not seem to be correct.

#18 Updated by Katja Luther about 2 months ago

Andreas Müller wrote:

Patrick Plitzner wrote:

tested on nightly.

Changing to any *lectotype will show the reference related elements. The reference and the details are saved correctly.

Only issue: When changing from *lectotype which already has a reference to any non-lectotype, saving and then changing back to *lectotype the reference is still connected to this type designation. This may be a feature and not a bug.

No, I don't think this is a feature. We should handle these type changes consistently. Changing nomenclatural code might be a template. There, if you change the code, and an existing information is deleted this way you get a warning and you have to agree explicitly. The same should happen here.

By the way, changing the rank does not give the same warning, e.g. change species to genus the specific epithet is still stored. This to me does not seem to be correct.

But maybe this should be handled in the library? When updating a typedesignation check whether it has a reference but is not of type lectotype? At the moment maybe it is easier to implement it in the editor but in general I would think it is better to check this while saving.

#19 Updated by Andreas Müller about 2 months ago

Katja Luther wrote:

But maybe this should be handled in the library? When updating a typedesignation check whether it has a reference but is not of type lectotype? At the moment maybe it is easier to implement it in the editor but in general I would think it is better to check this while saving.

The warning needs to be implemented in UI I think. Or do you think about throwing an exception. Additionally we could add a validation rule. Hardcoding to delete the reference if it is not a "lectotype" reference to me feels a bit to strict, but not sure about it.

#20 Updated by Katja Luther about 2 months ago

Andreas Müller wrote:

Katja Luther wrote:

But maybe this should be handled in the library? When updating a typedesignation check whether it has a reference but is not of type lectotype? At the moment maybe it is easier to implement it in the editor but in general I would think it is better to check this while saving.

The warning needs to be implemented in UI I think. Or do you think about throwing an exception. Additionally we could add a validation rule. Hardcoding to delete the reference if it is not a "lectotype" reference to me feels a bit to strict, but not sure about it.

I would think this should be handled by a validation rule. But for this release the editor removes the reference.

#21 Updated by Katja Luther about 2 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Patrick Plitzner

#22 Updated by Patrick Plitzner about 2 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Tested on nightly: The reference of any *lectotype is removed when switching the designation status to any non-lectotype.

#23 Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

To be honest, simply removing the reference is not my preferred solution. Is there a reason why we can't do like with the nomCode changes with a warning that the reference will be deleted? Especially if someone accidentally changes the category this will prevent from unwanted data loss. Also users may misuse the reference for ordinary type designation sources (definetely such data exists as sources where not available in the past). Also here it might be easy that data is simply lost instead of being moved to the correct place. With a warning users have to think about the correct place for their sources.

Also I don't think this will slow down the workflow as it will not happen very often that data has a source attached but is changed to a non-lectotype category. But if it happens it is definetely worth thinking about if it is correct to simply delete the source.

#24 Updated by Andreas Müller about 2 months ago

Validation already exists by the way #8139 but needs validation framework in place to be available

#25 Updated by Katja Luther about 2 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

now there is a message asking if the user really wants to change the type away from lectotype when a citation exist.

#26 Updated by Katja Luther about 2 months ago

  • Assignee changed from Andreas Müller to Katja Luther

Katja Luther wrote:

now there is a message asking if the user really wants to change the type away from lectotype when a citation exist.

translation is missing...

#27 Updated by Katja Luther about 2 months ago

  • Assignee changed from Katja Luther to Andreas Müller

#28 Updated by Andreas Müller about 1 month ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

If Status is completely deleted the reference is not deleted but should (similar to choosing e.g. holotype) I guess.

Also "Not designated" should be moved elsewhere to keep status and it's reference close together. Mabe we can move it down after Reference Detail as it is not used often. (Note: we also need to check if "Not Designated" excludes other fields from being filled than we should show fields only if "not designated" is false. But this needs further investigation)

It would be nice to have a more specific label for reference and reference detail to make clear that it is ONLY for lectotypification. But as it is not only for "lecto" but also for e.g. "neo" I am not sure what label to use. Maybe "Status Reference"? Any other ideas.

#29 Updated by Andreas Müller about 1 month ago

  • % Done changed from 100 to 70

After choosing a specimen for the type designation it is sometimes impossible to select the type designation to show the supplemental data for the type designation. One needs to set the focus to something else (e.g. the taxon in name editor) and try to select the type designation again. Also the later does not always work but difficult to reproduce.

Does someone else have the same experience? If yes, it should be fixed because otherwise it is difficult and not intuitive to add the new sources to a type designation.

#30 Updated by Andreas Müller about 1 month ago

When having 2 type designations and the second one is not yet saved and deleting the second one both type designations are deleted but the first shouldn't.

Don't know if this is related to this ticket. If not please open a new one or attache to another ticket.

#31 Updated by Katja Luther about 1 month ago

Andreas Müller wrote:

When having 2 type designations and the second one is not yet saved and deleting the second one both type designations are deleted but the first shouldn't.

Don't know if this is related to this ticket. If not please open a new one or attache to another ticket.

This is not related to this ticket, I think. I create a new ticket. (#8225)

#32 Updated by Katja Luther about 1 month ago

Andreas Müller wrote:

If Status is completely deleted the reference is not deleted but should (similar to choosing e.g. holotype) I guess.

Also "Not designated" should be moved elsewhere to keep status and it's reference close together. Mabe we can move it down after Reference Detail as it is not used often. (Note: we also need to check if "Not Designated" excludes other fields from being filled than we should show fields only if "not designated" is false. But this needs further investigation)

It would be nice to have a more specific label for reference and reference detail to make clear that it is ONLY for lectotypification. But as it is not only for "lecto" but also for e.g. "neo" I am not sure what label to use. Maybe "Status Reference"? Any other ideas.

this is fixed.

#33 Updated by Katja Luther about 1 month ago

Andreas Müller wrote:

After choosing a specimen for the type designation it is sometimes impossible to select the type designation to show the supplemental data for the type designation. One needs to set the focus to something else (e.g. the taxon in name editor) and try to select the type designation again. Also the later does not always work but difficult to reproduce.

Does someone else have the same experience? If yes, it should be fixed because otherwise it is difficult and not intuitive to add the new sources to a type designation.

This is a little bit strange. The area where to select the typedesignation for the supplemental data view is different. when I have two typedesination one I can click near the label of the specimen and for the other I need to click behind the type status combo (this always works!)

This is because the entitySelectionElement has a selectionListener as well and when this entitySelectionElement contains an element this element is selected and shown in the supplemental data view.

Clicking somewhere behind the type combo or the 'Not deisgnated' checkbox activates the selection of the type designation. I think we have to describe this in the manual because I don't know how to change this behaviour.
But maybe someone else has a better idea?

#34 Updated by Katja Luther about 1 month ago

  • Assignee changed from Katja Luther to Patrick Plitzner

Do you have an idea how to improve the selection?

#35 Updated by Andreas Müller about 1 month ago

??

#36 Updated by Katja Luther about 1 month ago

Andreas Müller wrote:

??

this was a question for Patrick. See the description in node#33

#37 Updated by Patrick Plitzner about 1 month ago

Clicking somewhere behind the type combo or the 'Not deisgnated' checkbox activates the selection of the type designation. I think we have to describe this in the manual because I don't know how to change this behaviour.

Changing this behaviour would require adjusting the layout of all entity selection elements and may be difficult and also may add unwanted white space. This functionality in general is not very intuitive. In this case it is even easier because you have this large area below the right outer Delete icon (see cursor in image). I find it even harder to select a name in the taxon details view.

@Katja: All the other issues are fixed, right? Then we may close this ticket.

#38 Updated by Andreas Müller about 1 month ago

Katja Luther wrote:

Andreas Müller wrote:

If Status is completely deleted the reference is not deleted but should (similar to choosing e.g. holotype) I guess.

Also "Not designated" should be moved elsewhere to keep status and it's reference close together. Mabe we can move it down after Reference Detail as it is not used often. (Note: we also need to check if "Not Designated" excludes other fields from being filled than we should show fields only if "not designated" is false. But this needs further investigation)

It would be nice to have a more specific label for reference and reference detail to make clear that it is ONLY for lectotypification. But as it is not only for "lecto" but also for e.g. "neo" I am not sure what label to use. Maybe "Status Reference"? Any other ideas.

this is fixed.

Have you forgotten to push? For me it still looks like before.

#39 Updated by Andreas Müller about 1 month ago

Patrick Plitzner wrote:

Clicking somewhere behind the type combo or the 'Not deisgnated' checkbox activates the selection of the type designation. I think we have to describe this in the manual because I don't know how to change this behaviour.

Changing this behaviour would require adjusting the layout of all entity selection elements and may be difficult and also may add unwanted white space.

Why do you think so? Do you know what the reason for the behavior is? If yes please leave a note what it is. I find it strange because it often works as expected and only sometimes it doesn't. So I don't understand why it necessarily requires complete refactoring/adjusting

This functionality in general is not very intuitive. In this case it is even easier because you have this large area below the right outer Delete icon (see cursor in image). I find it even harder to select a name in the taxon details view.

For me this is not true, name selection always works, clicking behind (and ONLY behind) the record is less intuitive. And also: often it WORKS as expected, only sometimes (and currently still non-deterministic) it changes the behavior and selects the specimen instead of the complete type designation.

#40 Updated by Andreas Müller about 1 month ago

So not very nice (as selection is crucial for entering sources, but it is true that it always works in the area below the delete button) we may close this ticket and create a high priority bugfix ticket once also note-28 is really fixed.

#41 Updated by Patrick Plitzner about 1 month ago

For selection the type designation you can basically select any empty space on the left or right side (see image)

However, in my case, sometimes this did not work for the first type designation. When I clicked right of the "Specimen" label I selected the specimen (SupplementalData view updated).

When debugging this, I saw that there are always two selection change event: one for the specimen and one for the type designation. It seems like a timing issue which one is finally selected. Disabling the selection event for the specimen selection leads to deterministic behavior. The type designation is always selected then.

Should it be possible to select the specimen in this element?

#42 Updated by Andreas Müller about 1 month ago

I just realized that the same problem exists e.g. for original sources. So it seems to be a general issue for lists, not only related specifically to type designations. So we maybe should open a new ticket for this general issue and close this ticket as it works as expected except for the general bug.

#43 Updated by Katja Luther about 1 month ago

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

If Status is completely deleted the reference is not deleted but should (similar to choosing e.g. holotype) I guess.

Also "Not designated" should be moved elsewhere to keep status and it's reference close together. Mabe we can move it down after Reference Detail as it is not used often. (Note: we also need to check if "Not Designated" excludes other fields from being filled than we should show fields only if "not designated" is false. But this needs further investigation)

It would be nice to have a more specific label for reference and reference detail to make clear that it is ONLY for lectotypification. But as it is not only for "lecto" but also for e.g. "neo" I am not sure what label to use. Maybe "Status Reference"? Any other ideas.

this is fixed.

Have you forgotten to push? For me it still looks like before.

sorry, yes now, it is pushed.

#44 Updated by Andreas Müller about 1 month ago

Now lectotype references have more space for the labels then ordinary types:

This does not look very nice and is confusing. Can it be implemented such that labels always have same width independent of type status?

#45 Updated by Andreas Müller about 1 month ago

Maybe we shorten the "Status Reference Detail" to "Status Ref Detail" or back to "Reference Detail" (maybe with a small identation to show that it belongs to the above reference ) or simply to Detail with a larger identation which makes it clear that it belongs to above reference.

Or we find a better technical solution.

#46 Updated by Katja Luther about 1 month ago

  • Status changed from Feedback to Resolved

Andreas Müller wrote:

Maybe we shorten the "Status Reference Detail" to "Status Ref Detail" or back to "Reference Detail" (maybe with a small identation to show that it belongs to the above reference ) or simply to Detail with a larger identation which makes it clear that it belongs to above reference.

Or we find a better technical solution.

the status reference detail label is now "Reference Detail" again this solves the problem of the larger space for the labels. I would close this ticket and create a follow up ticket for the remaining issues.

#47 Updated by Katja Luther about 1 month ago

  • Assignee changed from Katja Luther to Andreas Müller

I can not close the ticket as long as #8017 is not closed.

#48 Updated by Andreas Müller about 1 month ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther

#49 Updated by Andreas Müller about 1 month ago

  • % Done changed from 70 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)