Project

General

Profile

feature request #6413

[DISCUSS] How to create type duplicates (e.g. isotypes) for a taxon name

Added by Patrick Plitzner almost 3 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Priority14
Category:
taxeditor
Target version:
Start date:
02/08/2017
Due date:
% Done:

100%

Severity:
normal

Description

Coming from the name editor it is currently only possible to add a new type designation in order to create a type specimen.
If the user wants to create an isotype i.e. a duplicate of the recently added type specimen it is not possible to create a "real" duplicate that shares the same FieldUnit. For this the user has to switch to the specimen editor.

How could the interface look like to directly create an isotype (or any related type) coming from the name editor?

  • the specimen wizard could be shown with all the FieldUnit data already entered (because the new DerivedUnit is already a child of the existing FieldUnit
  • a reduced wizard where the user can only select the collection is shown
  • ...

WGB:

Auch hier wäre natürlich eine Möglichkeit, mehrere Specimen gleichzeitig zu Isotypen zu erklären, ausgesprochen nützlich – alle Specimens einer Field Unit sind ja normalerweise Typen.

...

Hier wäre eine Kontextmenüfunktion Add – Specimen duplicates sehr komfortabel, in die man eine Liste von Herbarabkürzungen eintragen kann, die dann entsprechend zu Specimen gemacht werden (ggf. unter Erzeugung einer neuen Collection) (#6665)

Possible solution in the details view of name editor:

  1. First we could add a new button/extend the functionality of the +-button to create a new type designation
  2. The button will open a dialog where you can select the field unit on which the new specimen duplicate is based. If there is only one field unit then this step can be skipped and the only field unit is selected
  3. Another dialog opens where you can specify the accession number, collection and what kind of type it is(holo, lecto, etc.)
  4. As a first implementation step, it is only possible to create one specimen duplicate
  5. As a second step it should be possible to enter a list of accession numbers, collections and types to create multiple duplicates

Note on algae data: generally the common parent for duplicates must not be field units but also can be derivatives like cultures. However, for most cases the relationship between field unit and final specimen is most important so in a first step it is enough to use the field unit as the common parent. If a user wants to model this more exactly he/she should go to specimen tree editor afterwards.

Note on available status: Usually we do have status pairs, a holotype has isotypes, a neotype has isoneotypes, a lectotype has isolectotypes, etc. as possible duplicates. We should consider this when offering default status or a list of sorted status where the most probable status is shown on top

picture299-1.png View (9.75 KB) Katja Luther, 04/05/2019 10:47 AM


Related issues

Related to Edit - feature request #6665: Add "Add specimen duplicate" context menu item to specimen editor New 05/22/2017
Related to Edit - feature request #6718: Constistent TypeDesignation representation creation New 06/12/2017
Related to Edit - feature request #7460: Duplicate button for TypeDesignations in SpecimenTypeDesignationWorkingsetEditor New 06/07/2018
Related to Edit - feature request #8136: Implement sources for type designations in TaxEditor Closed 02/24/2019
Related to Edit - feature request #8135: Implement verbatim type information in TaxEditor Closed 02/24/2019
Related to Edit - bug #8222: Deleting a type designation from a name is directly persisted Closed 04/05/2019
Related to Edit - bug #8233: [Follow up] Creating type duplicates In Progress 04/10/2019

Associated revisions

Revision 99366401 (diff)
Added by Patrick Plitzner 9 months ago

ref #6413 Add service method for duplicating type specimen

Revision 0661b3e6 (diff)
Added by Patrick Plitzner 9 months ago

ref #6413 Add "Clone Type Duplicate" option to name details view

Revision 80a540f2 (diff)
Added by Patrick Plitzner 9 months ago

ref #6413 Implement type duplication in type detail section

Revision 18a3973f (diff)
Added by Patrick Plitzner 9 months ago

ref #6413 Disable non-editable text fields

Revision 46567e3a (diff)
Added by Patrick Plitzner 9 months ago

ref #6413 Throw exception for more than 1 or 0 FieldUnits

Revision 8b7b8537 (diff)
Added by Patrick Plitzner 8 months ago

ref #6413 Replace service method parameters with UUIDs

Revision 5ef12561 (diff)
Added by Patrick Plitzner 8 months ago

ref #6413 Use UUIDS for service method parameters

Revision cec74f11 (diff)
Added by Patrick Plitzner 8 months ago

ref #6413 Update toolbar when adding/deleting type designations

Revision 73a8b27a (diff)
Added by Andreas Müller 8 months ago

ref #6413 small change in German translation for type duplicate

Revision 89c37d9c (diff)
Added by Patrick Plitzner 8 months ago

ref #6413 Add service method for duplicating type specimen

Revision c21a9b9f (diff)
Added by Patrick Plitzner 8 months ago

ref #6413 Throw exception for more than 1 or 0 FieldUnits

Revision 3e404885 (diff)
Added by Patrick Plitzner 8 months ago

ref #6413 Replace service method parameters with UUIDs

History

#1 Updated by Norbert Kilian almost 3 years ago

My preferred solution: an option (with similar functionality as the "add new specimen" option for a field unit in the specimen editor) to create a duplicate of the existing type. Should open the wizard?/window as in specimen editor but with "General" reduced to the title cache field, and with the specimen details as they are, "Sources" "Identifiers" and "Options" may also stay.
Norbert

#2 Updated by Andreas Müller over 2 years ago

  • Subject changed from [DISCUSS] How to create types (isotypes) for a taxon name to [DISCUSS] How to create type duplicates (e.g. isotypes) for a taxon name

#4 Updated by Andreas Müller over 2 years ago

  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 4.7

#5 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 4.7 to Release 4.8

#8 Updated by Andreas Müller over 2 years ago

  • Description updated (diff)

#9 Updated by Andreas Müller over 2 years ago

  • Description updated (diff)

#10 Updated by Andreas Müller over 2 years ago

  • Related to feature request #6665: Add "Add specimen duplicate" context menu item to specimen editor added

#11 Updated by Andreas Müller over 2 years ago

  • Description updated (diff)

#12 Updated by Andreas Müller over 2 years ago

  • Description updated (diff)

#13 Updated by Andreas Kohlbecker over 2 years ago

#14 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 4.8 to Release 4.9

#15 Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 4.9 to Release 4.10

#16 Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 4.10 to Release 4.11

#17 Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 4.11 to Release 4.12

#18 Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 4.12 to Release 4.13

#19 Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 4.13 to Release 4.14

#20 Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 4.14 to Release 5.0

#21 Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 5.0 to Reviewed Next Major Release

#22 Updated by Andreas Müller 10 months ago

  • Priority changed from Highest to Priority14

#23 Updated by Patrick Plitzner 10 months ago

  • Related to feature request #7460: Duplicate button for TypeDesignations in SpecimenTypeDesignationWorkingsetEditor added

#24 Updated by Andreas Müller 10 months ago

#25 Updated by Andreas Müller 10 months ago

#26 Updated by Patrick Plitzner 10 months ago

  • Description updated (diff)

#27 Updated by Andreas Müller 10 months ago

  • Description updated (diff)

#28 Updated by Andreas Müller 10 months ago

  • Description updated (diff)

#29 Updated by Patrick Plitzner 10 months ago

  • Target version changed from Reviewed Next Major Release to Release 5.6

#30 Updated by Patrick Plitzner 9 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

#31 Updated by Patrick Plitzner 9 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50

The first implementation allows selection one of the already existing specimen type designation for creating the duplicate. You can specify collection, accession number and type status.

The specimen will be pre-selected if only one type designation exists.

The option to duplicate will not appear if there are no type designations yet.

This was tested on the nightly build.

#32 Updated by Andreas Müller 8 months ago

  • Assignee changed from Andreas Müller to Katja Luther

please do first review on nightly

#33 Updated by Katja Luther 8 months ago

the item is really small and after adding the first typedesignation the view is not updated, so the item does not appear.

But the creation of a duplicate works as expected!

#34 Updated by Katja Luther 8 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Katja Luther to Patrick Plitzner

#35 Updated by Patrick Plitzner 8 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther

The buttons are now updated with every add or remove.

The icon is from the Eclipse icon set and it is standard sized.

#36 Updated by Patrick Plitzner 8 months ago

  • Related to bug #8222: Deleting a type designation from a name is directly persisted added

#37 Updated by Katja Luther 8 months ago

  • Assignee changed from Katja Luther to Andreas Müller

now the button is available after creating the first type designation and the creation of the clone works fine.

#38 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

We should change order, first collection, then accession number.

Also the status are not sorted. Order should be same as in details view but on top and preselected should be the most probable status (see "note on available status" in description of this ticket).

#39 Updated by Andreas Müller 8 months ago

After selecting the collection it would be a very helpful feature to show already existing specimen candidates for this collection. One can then choose either to use one of theses candidates or to create a new one by entering an explict accession number. If we don't do this now we should do it soon as it will prevent from creating unwanted duplicates.

#40 Updated by Andreas Müller 8 months ago

Have we on purpose decided to only show accession number? Shouldn't we also allow barcode and/or catalogue number? Otherwise e.g. for B it will create kind of dirty data which needs to be cleaned up afterwards.

#41 Updated by Andreas Müller 8 months ago

Any kind of accession number should not be required as sometimes such a number does not exist, but only collection and status.

#42 Updated by Andreas Müller 8 months ago

If I enter a type designation and then add a duplicate without saving in between the first type designation gets lost. Maybe related to #8225?

#43 Updated by Andreas Müller 8 months ago

If 2 existing type designations have the same field unit they should not be listed both in the "base type" list IMO. In general to me it looks like the base type list should contain field units not specimen or it there a specific reason for using specimen?

#44 Updated by Patrick Plitzner 8 months ago

  • Related to bug #8233: [Follow up] Creating type duplicates added

#45 Updated by Patrick Plitzner 8 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

I created a new ticket for the remaining issues. Can we close this ticket now? -> #8233

#46 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • % Done changed from 50 to 100

As some of the most important issues from #8233 are solved in the meanwhile we can close this ticket and try to fully implement #8233 soon

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)