Project

General

Profile

feature request #8124

Activate Name Facts in Taxeditor

Added by Katja Luther 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
02/22/2019
Due date:
% Done:

50%

Severity:
normal

Description

Namefacts should be shown for names in bulk editor. (see discussion in #7653)
Therefore following is needed:

  • activate factual data view for name bulkeditor
  • implement operation to create new NameDescription
  • implement correct use of nameFeature vocabulary for menu

  • activation like supplemental data activation when name is selected in details view

  • adapt factual data view label

  • adapt cache strategy to create a titleCache reflecting that it is a name fact

the topics above are implemented.

picture908-1.png View (110 KB) Patrick Plitzner, 04/04/2019 08:33 AM


Related issues

Related to Edit - feature request #8128: Add indicator for feature facts and/or vocabularies which description type they support In Progress 02/22/2019
Copied to Edit - bug #8229: reload of the bulkeditor does not work correctly Feedback 04/09/2019

Associated revisions

Revision 52d76872 (diff)
Added by Katja Luther 3 months ago

ref #8124: adapt editor to be able to edit NameFacts

Revision c495b39b (diff)
Added by Katja Luther 3 months ago

ref #8124: adapt NaturalLanguageGenerator to usage in nameFacts

Revision b6f51ff3 (diff)
Added by Katja Luther 3 months ago

ref #8124: activate name facts for name in taxon details view

Revision 2a8f0c28 (diff)
Added by Katja Luther 3 months ago

ref #8124: add new TaxonNameDescriptionDefaultCacheStrategy

Revision 9bc62cb0 (diff)
Added by Katja Luther 3 months ago

ref #8124: add deleteTaxonNameDescription operation

Revision 872fe921 (diff)
Added by Katja Luther 3 months ago

ref #8124: fix add NameDescription with source

Revision 78f2e016 (diff)
Added by Katja Luther 3 months ago

ref #8124: rename createTaxonNameDescriptionOperation

Revision 0e1842fc (diff)
Added by Katja Luther 3 months ago

ref #8124: rename createTaxonNameDescriptionOperation - continue

Revision 6ec2be5e (diff)
Added by Katja Luther about 1 month ago

ref #8124: adapt TaxonNameDescriptionDefaultCacheStrategy

Revision 5ce89578 (diff)
Added by Katja Luther about 1 month ago

ref #8124: do not show move description(element) menu item for name facts

Revision 5fcf8d0f (diff)
Added by Katja Luther about 1 month ago

ref #8124: change label for name facts

Revision 68d759c3 (diff)
Added by Katja Luther about 1 month ago

ref #8124: remaining issues for name facts (protologue filter)

Revision 72c67e90 (diff)
Added by Katja Luther about 1 month ago

ref #8124: adapt NaturalLanguageGenerator to usage in nameFacts

Revision 3a9a4643 (diff)
Added by Katja Luther about 1 month ago

ref #8124: add new TaxonNameDescriptionDefaultCacheStrategy

Revision dd834f23 (diff)
Added by Katja Luther about 1 month ago

ref #8124: adapt TaxonNameDescriptionDefaultCacheStrategy

History

#1 Updated by Katja Luther 3 months ago

  • Status changed from New to In Progress

#2 Updated by Andreas Müller 3 months ago

Can we also activate name facts in the same way as supplemental data are activated => if focus is explicitly on a name then name facts are shown in the facts view?

#3 Updated by Andreas Müller 3 months ago

  • Related to feature request #8128: Add indicator for feature facts and/or vocabularies which description type they support added

#4 Updated by Andreas Müller 3 months ago

Also consider #8128 for future implementations.

#5 Updated by Katja Luther 3 months ago

for the name bulk editor the name facts are activated now.

still missing is the activation if name is selected in details view.

#6 Updated by Katja Luther 3 months ago

  • Description updated (diff)

#7 Updated by Katja Luther 3 months ago

when activating the name facts for the name displayed in the details view, the details view is the selectionProviding part for the factual data view and the the factual data view is the selection providing part of the details view.

This leads to an endless loop in findSavablePart.

#8 Updated by Katja Luther 3 months ago

  • Description updated (diff)

#9 Updated by Katja Luther 3 months ago

Katja Luther wrote:

when activating the name facts for the name displayed in the details view, the details view is the selectionProviding part for the factual data view and the the factual data view is the selection providing part of the details view.

This leads to an endless loop in findSavablePart.

this is fixed

#10 Updated by Katja Luther 3 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

please review

#11 Updated by Andreas Müller about 2 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

please do first review on nightly

#12 Updated by Andreas Müller about 2 months ago

  • % Done changed from 0 to 50

#13 Updated by Patrick Plitzner about 2 months ago

Tested on nightly:

  • I selected a name in the bulk editor
  • Creation of name description works
  • The list of available features is filtered (see image). I don't know if this is correct, though.
  • I created a description element and saved
  • I opened the taxon belonging to this name, selected the name in the details view and it showes the description + the element
  • I edited the element and saved again
  • minor (refresh) issue: Going back to the bulk editor, the change of the description element did not show until I closed and re-opened the bulk editor

#14 Updated by Andreas Müller about 1 month ago

  • Assignee changed from Andreas Müller to Katja Luther

When entering via NameDetailsView and name selection the facts view still contains menu element "Move fact data set to other taxon". It should be disabled or should allow moving to another name, not taxon. This is the case for data sets and for single data records.

If selected via bulk editor it is either disabled or invisible (not sure why sometimes disabled and sometimes invisible, could not reproduce, but at least it is kind of correct).

#15 Updated by Andreas Müller about 1 month ago

It would be nice to have a separate label to point out that we are working on name level, not taxon level now. E.g Name facts instead of Factual data or so.
Also the cache strategy for the description could be adapted to "Name facts for xxx" or "Factual data set for name xxxx".

#16 Updated by Andreas Müller about 1 month ago

  • Status changed from Resolved to Feedback

I wonder if we should explicitly remove "Protologue" from the feature list. Protologues will soon be handled differently in the source part of the name. To avoid users to create protologue data which is not according to our current standards filtering the feature might be helpful. We remove the filter later if users still wish to have it as freetext feature.

#17 Updated by Andreas Müller about 1 month ago

In bulk editor there are 2 strange behaviors which are may be more bulk editor related then name facts related.

If I open 2 bulk editor searching for the same name, e.g. "Gattung art*" in rem_conf_am. Then I add additional name facts to the name in 1 one the bulk editors and save.

Switching to the other name bulk editor does not change the currently shown data in facts view, but only because name facts view seems not to be updated (but should! Maybe difficult because same object, but in other state because edited in 2 different sessions!).

Changing focus to some other object and back now shows the old data, which is expected because the other bulk editor was not yet refreshed.

Runnting the search again in the other bulk editor does still not change the data in facts view => this is unexpected because re-search is expected to completely reload all data.

If these issues are primarily bulk editor related we may open new tickets, but with high priority. By the way you can also reproduce if the editing is done not in a bulk editor by via selection of scientific name in details view.

#18 Updated by Katja Luther about 1 month ago

Andreas Müller wrote:

In bulk editor there are 2 strange behaviors which are maybe more bulk editor related then name facts related.

If I open 2 bulk editor searching for the same name, e.g. "Gattung art*" in rem_conf_am. Then I add additional name facts to the name in 1 one the bulk editors and save.

Switching to the other name bulk editor does not change the currently shown data in facts view, but only because name facts view seems not to be updated (but should! Maybe difficult because same object, but in other state because edited in 2 different sessions!).

This is because it is the same object, I will have a look if it is easy to fix, otherwise I create a new ticket.

Changing focus to some other object and back now shows the old data, which is expected because the other bulk editor was not yet refreshed.

Runnting the search again in the other bulk editor does still not change the data in facts view => this is unexpected because re-search is expected to completely reload all data.

This seems to be a problem of the bulk editor, too.

If these issues are primarily bulk editor related we may open new tickets, but with high priority.
By the way you can also reproduce if the editing is done not in a bulk editor by via selection of scientific name in details view.

#19 Updated by Katja Luther about 1 month ago

Katja Luther wrote:

Andreas Müller wrote:

In bulk editor there are 2 strange behaviors which are maybe more bulk editor related then name facts related.

If I open 2 bulk editor searching for the same name, e.g. "Gattung art*" in rem_conf_am. Then I add additional name facts to the name in 1 one the bulk editors and save.

Switching to the other name bulk editor does not change the currently shown data in facts view, but only because name facts view seems not to be updated (but should! Maybe difficult because same object, but in other state because edited in 2 different sessions!).

This is because it is the same object, I will have a look if it is easy to fix, otherwise I create a new ticket.

To avoid too many new rendering of the details view the actual and the previous selection are compared and when they are the same nothing is refreshed. -> #8228

#20 Updated by Katja Luther about 1 month ago

Andreas Müller wrote:

It would be nice to have a separate label to point out that we are working on name level, not taxon level now. E.g Name facts instead of Factual data or so.
Also the cache strategy for the description could be adapted to "Name facts for xxx" or "Factual data set for name xxxx".

The label and the cacheStrategy for NameDescriptions are adapted.

#21 Updated by Katja Luther about 1 month ago

  • Description updated (diff)
  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

the issues mentioned above are fixed and for the bulk editor issue a new ticket is created. So I close this ticket.

#22 Updated by Andreas Müller about 1 month ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Can you please link the bulk editor tickets?

The switching between 2 bulk editors with same name seems to work now.

Updating the data via a new search in same bulk editor does not seem to work yet. Is there a ticket for this? Please either link to ticket or create new one (or fix if simple to fix).

#23 Updated by Katja Luther about 1 month ago

  • Status changed from Feedback to Closed

the ticket for the updating of bulkeditors is #8229, the rest is implemented and reviewed so I close this ticket.

#24 Updated by Katja Luther about 1 month ago

  • Related to bug #8229: reload of the bulkeditor does not work correctly added

#25 Updated by Andreas Müller 3 days ago

  • Related to deleted (bug #8229: reload of the bulkeditor does not work correctly)

#26 Updated by Andreas Müller 3 days ago

  • Copied to bug #8229: reload of the bulkeditor does not work correctly added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)