Project

General

Profile

bug #7766

Remaining issues for using relationship DTO webservice in portal

Added by Andreas Kohlbecker about 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
06/01/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

for details see #7658

  • taxonrelation footnotes missing (see #7658#note-51 for details)
  • sort order of the relations (see #7658#note-46 for details) The expected sort order is:
    1. pro parte/partial synonyms,
    2. then invalid designations,
    3. then MANs
    4. followed (or including?) pro parte/partial MAN
    5. and finally concept relationships.
  • links to related taxa (new) - before the refactoring the related concepts were linked, at least for real concept relationships we should again do this, needs discussion if we also want this for ppSyns, MANs, and inval desigs. (maybe configurable?)
  • related issue for formatting MAN search results: #7771
  • identifier links missing when footnote is created in MANs code part: #7778

Related issues

Related to Edit - feature request #7771: Format Misapplication search results as MAN, not as accepted taxa New 09/19/2018
Copied from Edit - feature request #7658: use new taxon relationship DTO webservice in portal Closed 06/01/2017
Copied to Edit - bug #7778: identifier links missing in taxon relations footnotes Closed 06/01/2017

Associated revisions

Revision e5926729 (diff)
Added by Andreas Kohlbecker about 2 years ago

ref #7766 creating testcase - currently ignored

Revision 8b2a5cc0 (diff)
Added by Andreas Kohlbecker about 2 years ago

ref #7766 adapting test to modified data

Revision ca2ed7a5 (diff)
Added by Andreas Kohlbecker about 2 years ago

ref #7766 adapting test to modified data - 2.

Revision c88416e1 (diff)
Added by Andreas Kohlbecker about 1 year ago

ref #7766 completing test case

Revision 5c750190 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #7766 order taxon relationships by type and scientific name, adapting tests

History

#1 Updated by Andreas Kohlbecker about 2 years ago

#2 Updated by Andreas Müller about 2 years ago

  • Subject changed from taxonrelation footnotes missing after using relationship DTO webservice in portal to Remaining issues for using relationship DTO webservice in portal
  • Description updated (diff)

#3 Updated by Andreas Müller about 2 years ago

  • Description updated (diff)

#4 Updated by Andreas Müller about 2 years ago

  • Related to feature request #7771: Format Misapplication search results as MAN, not as accepted taxa added

#5 Updated by Andreas Kohlbecker about 2 years ago

  • Description updated (diff)

#6 Updated by Andreas Kohlbecker about 2 years ago

  • Copied to bug #7778: identifier links missing in taxon relations footnotes added

#7 Updated by Andreas Kohlbecker about 2 years ago

  • Description updated (diff)

#8 Updated by Andreas Kohlbecker about 2 years ago

  • Description updated (diff)

#9 Updated by Andreas Kohlbecker about 2 years ago

  • Status changed from Feedback to Closed

this issue seems complete, since #7771 is in it's own ticket.

#10 Updated by Andreas Müller about 2 years ago

  • Status changed from Closed to Resolved
  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • % Done changed from 0 to 90

#11 Updated by Andreas Kohlbecker about 1 year ago

  • Description updated (diff)

#12 Updated by Andreas Kohlbecker about 1 year ago

  • Status changed from Resolved to In Progress
  • Assignee changed from Andreas Müller to Andreas Kohlbecker
  • % Done changed from 90 to 70

The sort order seem to have problems. Is this an regression or has this point be missed?

#13 Updated by Andreas Kohlbecker about 1 year ago

  • Target version changed from Release 5.4 to Release 5.11

#14 Updated by Andreas Kohlbecker about 1 year ago

  • Target version changed from Release 5.11 to Release 5.12

#15 Updated by Andreas Kohlbecker 11 months ago

  • Target version changed from Release 5.12 to Release 5.13

#16 Updated by Andreas Kohlbecker 8 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 70 to 100

Andreas Kohlbecker wrote:

The sort order seem to have problems. Is this an regression or has this point be missed?

The sort order is fixed now. The correctness is approved by the test which has been adapted to meet the requirements from the ticket description.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)