Project

General

Profile

Actions

feature request #7305

closed

[Dicuss] searching for authorteam with more than three members is incomplete

Added by Katja Luther over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
New
Category:
cdmlib
Target version:
Start date:
Due date:
% Done:

50%

Estimated time:
Severity:
normal

Description

mail von Henning:

noch eine Folge davon, dass bibliografische Autoren nach einigen Positionen als et al. abgekürzt werden.
Suche ich nach Autoren, die im bibliografischen Autorenstring vorkommen, bekomme ich die Autoren und die entsprechenden Teams.

Fiktive Suche nach „Richt.“
Richt.
Richt.
Richt.
Soundso & Richt.
Soundso & Richt.
Soundso, Richt., Müller & al. (Annahme & al. = Meyer)

Aber : Suche nach „Meyer“ ergibt keinen Treffer des Teams, in dem es vorkommt, da der Name nicht im Cache vorkommt.
Meyer
Meyer
Meyer

Das erschwert die Analyse und Suche nach Doppelten.


Related issues

Related to EDIT - feature request #9326: Show all authors in bibliographic referencesClosedWolf-Henning Kusber

Actions
Is duplicate of EDIT - task #9624: Centralize team formatting and fix et al. position handlingClosedAndreas Müller

Actions
Actions #1

Updated by Andreas Müller over 4 years ago

Generally we need "advanced searches" for all types of searches like bulk editor, taxon search, etc.

However, the current search always works on titleCache or similar and this should stay as it is as simple search. There are other ways to do e.g. deduplication by e.g. using the referencing objects view together with bulk editor.

In the given case we probably will add more cache fields to Person/Team which includes 1 or 2 cache fields for citation while the titleCache in future will hold the most complete information full name(s). Search will then run on titleCache and all other caches.

Actions #2

Updated by Andreas Kohlbecker over 1 year ago

  • Tags set to search
Actions #3

Updated by Andreas Müller over 1 year ago

  • Category set to cdmlib
  • Assignee changed from Katja Luther to Andreas Müller
  • Target version changed from Unassigned CDM tickets to Release 5.25

This is related to the max number of authors handled in this milestone.

Actions #4

Updated by Andreas Müller over 1 year ago

  • Tags changed from search to search, formatting
Actions #5

Updated by Andreas Müller over 1 year ago

Actions #6

Updated by Andreas Müller over 1 year ago

  • Is duplicate of task #9624: Centralize team formatting and fix et al. position handling added
Actions #7

Updated by Andreas Müller over 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 50

This should be fixed with #9624. Before reviewing you may need to run the cache updater.

Actions #8

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.25 to Release 5.23
Actions #9

Updated by Katja Luther over 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Andreas Müller

works as expected.

Actions

Also available in: Atom PDF