Project

General

Profile

Actions

feature request #9326

closed

Show all authors in bibliographic references

Added by Wolf-Henning Kusber about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal

Description

In PhycoBank it is necessary to show a complete reference including all bibliographical authors. This is also relevant for section author teams.



A second issue is, that normally the title has no full stop (in our example the full stop is added to the title to be displayed) and followed by in and the e.g. journal.

If there is no full stop one cannot distinguish between title and journal, e.g. "...in diatom research in Nova Hedwigia" first in is part of the title, second introduces the journal.

A full stop by the system and (if agreed a dash) would be helpful. The "in" is necessary if no title is given as in references of a scientific name.

This is to be discussed (also with other projects).


Files

Referenzen1.JPG (135 KB) Referenzen1.JPG Wolf-Henning Kusber, 11/25/2020 07:53 PM
Referenzen2.JPG (132 KB) Referenzen2.JPG Wolf-Henning Kusber, 11/25/2020 07:53 PM
Referenzen3.JPG (132 KB) Referenzen3.JPG Wolf-Henning Kusber, 11/25/2020 07:53 PM
picture432-1.png (75.2 KB) picture432-1.png Wolf-Henning Kusber, 05/19/2021 04:48 PM

Related issues

Related to EDIT - feature request #7305: [Dicuss] searching for authorteam with more than three members is incompleteClosedAndreas Müller

Actions
Related to EDIT - bug #9529: Correct formatting for bibliographic in-reference separationClosedAndreas Müller

Actions
Has duplicate EDIT - feature request #9464: Show all team members in agent selection dialogDuplicateKatja Luther

Actions
Is duplicate of EDIT - task #9624: Centralize team formatting and fix et al. position handlingClosedAndreas Müller

Actions
Actions #1

Updated by Wolf-Henning Kusber about 2 years ago

The third screen shot shows a (new?) truncation of a long title. Looks not bad but is not correct. In this case Fragilaria crotonensis was not typified as suggested by the truncated title.

Actions #2

Updated by Andreas Kohlbecker almost 2 years ago

  • Subject changed from Show all authors in a reference to Show all authors in bibliographic references
Actions #3

Updated by Andreas Kohlbecker almost 2 years ago

  • Category changed from cdm-dataportal to cdmlib
  • Assignee changed from Andreas Kohlbecker to Andreas Müller

this is rather a question of how the cache strategy. Therefore I am changing category and assignee accordingly

Actions #4

Updated by Andreas Müller almost 2 years ago

  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.18
Actions #5

Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 5.18 to Release 5.19
Actions #6

Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 5.19 to Release 5.21
Actions #7

Updated by Andreas Müller almost 2 years ago

Actions #8

Updated by Andreas Müller almost 2 years ago

Generally all authors should be stored in Agent.titleCache as mentioned in #9464. So we need to implement it there first.
However, we need to find a solution that the et. al. version is still shown where needed.

Actions #9

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.21 to Release 5.22
Actions #10

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.22 to Release 5.25
Actions #11

Updated by Andreas Müller over 1 year ago

  • Tags changed from phycobank to phycobank, formatting
Actions #12

Updated by Andreas Müller over 1 year ago

  • Related to feature request #7305: [Dicuss] searching for authorteam with more than three members is incomplete added
Actions #13

Updated by Andreas Müller over 1 year ago

  • Is duplicate of task #9624: Centralize team formatting and fix et al. position handling added
Actions #14

Updated by Andreas Müller over 1 year ago

  • Related to bug #9529: Correct formatting for bibliographic in-reference separation added
Actions #15

Updated by Andreas Müller over 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Müller to Wolf-Henning Kusber
  • % Done changed from 0 to 50

This should be fixed now. Maybe before review an (title)cache update is necessary. For single teams this can be done in the details view. For the whole database it can be done in TaxEditor-Admin menu.

The second part of the request is handled in #9529 as far as I can see. Please let me know if there are issues left.

Actions #16

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.25 to Release 5.23
Actions #17

Updated by Wolf-Henning Kusber over 1 year ago

Habe die Beispiele angeschaut, Uptdate der Caches war notwendig.
Fast alles ist jetzt gut umgesetzt. 19.05.2021

Es hakt noch bei einer Sektion (Neubeschreibung einer Art durch ein Autorenteam das vom Autorenteam der bibliographischen Referenz des Journal Articles abweicht), und zwar in der bibliographischen Ausgabe (siehe Screenshot).

Actions #19

Updated by Andreas Müller over 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Wolf-Henning Kusber

Wolf-Henning Kusber wrote:

Habe die Beispiele angeschaut, Uptdate der Caches war notwendig.
Fast alles ist jetzt gut umgesetzt. 19.05.2021

Es hakt noch bei einer Sektion (Neubeschreibung einer Art durch ein Autorenteam das vom Autorenteam der bibliographischen Referenz des Journal Articles abweicht), und zwar in der bibliographischen Ausgabe (siehe Screenshot).

Fehlt hier nicht auch noch die Seitenzahl des Artikels? Die kommt ganz ans Ende wie bei "normalen" Artikeln auch, oder? Oder muss man bei Sections da irgendwas besonderes beachten?

Actions #20

Updated by Andreas Müller over 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

I guess this can be closed as it is about team formatting and full stop separation which both is fixed.
Open issues for correct section in article or bookSection formatting are handled in #3764.

Actions

Also available in: Atom PDF