Project

General

Profile

Actions

bug #4707

open

LSID Authority service cannot find CoL LSIDs

Added by Andreas Kohlbecker almost 7 years ago. Updated almost 3 years ago.

Status:
In Progress
Priority:
Highest
Category:
data
Start date:
07/06/2016
Due date:
% Done:

10%

Estimated time:
Severity:
major
Found in Version:
Tags:
col

Description

The following request fails

https://test.e-taxonomy.eu/cdmserver/col/authority/data.do?lsid=urn%3Alsid%3Acatalogueoflife.org%3Ataxon%3Aedce3354-29c1-102b-9a4a-00304854f820%3Acol20140122

Caused by:

com.ibm.lsid.server.LSIDServerException: 201 : Unknown LSID
    at eu.etaxonomy.cdm.api.service.lsid.impl.LsidDataServiceImpl.getData(LsidDataServiceImpl.java:46)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:317)

====

NOTE (AM): Please be aware that not all accepted taxa have a valid LSID. There are currently 4614 taxa without LSID. Reasons might be that they are not well formed or do not exist.

SELECT *
FROM TaxonBase tb
WHERE tb.DTYPE = 'Taxon' AND tb.lsid_lsid IS NULL

Files

picture665-1.png (7.37 KB) picture665-1.png Andreas Müller, 08/12/2017 12:16 PM
picture769-1.png (7.48 KB) picture769-1.png Andreas Müller, 08/12/2017 12:19 PM
Actions #1

Updated by Andreas Kohlbecker almost 7 years ago

The problem is the missing data on the LSIDAuthority and on the namespaces.

The following SQL statements are fixing the bug by adding the missing entries:

LSIDAuthority

The cdm_col database in edit-test has already been modified this way!

  1. This must be added at least to the CoL import, therefore reassigning this ticket to a.mueller

  2. Should we implement a validation rule for this?

  3. Should the LSIDAuthority and namespace be added automatically a when setting the LSID for an identifiable entity?

Actions #2

Updated by Andreas Kohlbecker almost 7 years ago

  • Target version changed from cdmlib RELEASE 3.5.0 to cdmlib RELEASE 3.5.1

moving tickets to next milestone

Actions #3

Updated by Andreas Kohlbecker almost 7 years ago

  • Keywords set to catalogueoflife
  • Category changed from cdmlib to data
Actions #4

Updated by Andreas Müller almost 7 years ago

  • Priority changed from Priority08 to Highest
Actions #5

Updated by Andreas Müller over 6 years ago

  • Target version changed from cdmlib RELEASE 3.5.1 to cdmlib RELEASE 3.5.2

move open 3.5.1 tickets to next milestone after release

Actions #6

Updated by Andreas Müller about 6 years ago

  • Target version changed from cdmlib RELEASE 3.5.2 to Unassigned CDM tickets
Actions #7

Updated by Andreas Kohlbecker almost 6 years ago

it seems as if this is biting me gain!

see #5624

Actions #8

Updated by Andreas Kohlbecker almost 6 years ago

Andreas Müller: can you care for this?

Actions #9

Updated by Andreas Müller over 5 years ago

  • Target version changed from Unassigned CDM tickets to Release 4.1
Actions #10

Updated by Andreas Müller over 5 years ago

  • Keywords changed from catalogueoflife to CoL
Actions #11

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.1 to Release 4.2
Actions #12

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.2 to Release 4.3
Actions #13

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.3 to Release 4.4
Actions #14

Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 4.4 to Release 4.5
Actions #15

Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.5 to Release 4.6
Actions #16

Updated by Andreas Müller almost 5 years ago

  • Description updated (diff)
  • Private changed from Yes to No
Actions #17

Updated by Andreas Müller almost 5 years ago

  • Target version changed from Release 4.6 to Release 4.7
Actions #18

Updated by Andreas Müller over 4 years ago

  • Target version changed from Release 4.7 to Release 4.8
Actions #19

Updated by Andreas Müller over 4 years ago

  • Target version changed from Release 4.8 to Release 4.9
Actions #20

Updated by Andreas Müller over 4 years ago

  • Target version changed from Release 4.9 to Release 4.10
Actions #22

Updated by Andreas Müller over 4 years ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Müller to Andreas Kohlbecker

This seems to be fixed. I just run the import and all LSID fields seem to be filled for accepted taxa. Please check after the next import is online (or check on test, but imports may run there).

Note: taxon uuids may have changed

Please remove target version after review (data tickets must not have target versions)

Actions #23

Updated by Andreas Müller over 4 years ago

  • % Done changed from 0 to 80
Actions #24

Updated by Andreas Müller over 4 years ago

  • Description updated (diff)
Actions #25

Updated by Andreas Müller over 4 years ago

  • Description updated (diff)
Actions #26

Updated by Andreas Müller over 4 years ago

AK, now I understand the problem. There are missing entries in tables "LSIDAuthority" and "lsidauthority_namespaces". They should look like

and

Actions #28

Updated by Andreas Müller over 4 years ago

INSERT INTO `col_test`.`LSIDAuthority` (`id`, `uuid`, `authority`, `port`) VALUES ('1', 'cab132a8-b26a-4e07-ab47-0e9754d982d8', 'catalogueoflife.org', '0');
INSERT INTO `col_test`.`LSIDAuthority_namespaces` (`LSIDAuthority_id`, `namespaces_element`, `namespaces_mapkey`) VALUES ('1',`namespaces_element`='eu.etaxonomy.cdm.model.taxon.TaxonBase', 'taxon');
Actions #29

Updated by Andreas Müller over 4 years ago

  • Status changed from Resolved to In Progress
Actions #30

Updated by Andreas Müller over 4 years ago

  • % Done changed from 80 to 10
Actions #31

Updated by Andreas Müller over 4 years ago

  • Target version changed from Release 4.10 to Release 4.12
Actions #32

Updated by Andreas Müller about 4 years ago

  • Target version changed from Release 4.12 to Release 4.13
Actions #33

Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 4.13 to Release 4.14
Actions #34

Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 4.14 to Release 5.0
Actions #35

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.0 to Release 5.1
Actions #36

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.1 to Release 5.2
Actions #37

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.2 to Release 5.3
Actions #38

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.3 to Release 5.5
Actions #39

Updated by Andreas Müller almost 3 years ago

  • Target version changed from Release 5.5 to Release 5.6
Actions #40

Updated by Andreas Müller almost 3 years ago

  • Target version changed from Release 5.6 to Reviewed Next Major Release
Actions

Also available in: Atom PDF