Project

General

Profile

bug #4409

feature request #3904: EuroMed: Implement filtering rules for distributions

fallback areas are not adressable in the shape file

Added by Andreas Kohlbecker over 6 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Highest
Category:
data
Target version:
Start date:
07/16/2015
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

Lilium martagon (http://test.e-taxonomy.eu/dataportal/preview/euromed/cdm_dataportal/taxon/7ddb75d9-b5a1-4941-99e6-c81456750bda)

es sind keine Unterareale vorhanden, also müssten Ju, Cz und Tcs auch in der Karte grün markiert sein, sie sind aber weiß. Da funktioniert die Regel also nicht, nach der diese Areale nur ignoriert werden sollen, wenn Unterareale vorhanden sind. Dies ist aber für keines der drei genannten Areale der Fall.

so sollte es aussehen


Related issues

Related to Edit - task #9161: E+M shapefile with Kaukasus regions New 07/22/2020
Related to Edit - bug #8310: Issues to solve in E+M shapefile Closed 05/28/2019
Related to Edit - feature request #9502: Implement subarea preference rule and fallback areas for areas with complex hierarchy New 03/02/2021
Copied to Edit - bug #9486: Fallback areas not handled in area hierarchy are not showing up correctly if subarea data exists Duplicate 03/01/2021

History

#1 Updated by Andreas Müller almost 6 years ago

  • Target version changed from Euro+Med Migration to Euro+Med Portal Release

#2 Updated by Andreas Kohlbecker almost 6 years ago

  • Subject changed from filtering rules for Distributions: some named areas with sub areas are missing in distribution to fallback areas are not adressable in the shape file

even after solving #4408 this is still not working. The cause for this that the fallback areas Ju*, Cz, *IJ and LS are not yet mapped to the shape file.

With the exception of Sr and Gc the sub areas of these fallback areas are at level 1, in the cdm we are treating them as on level 2. The named exceptions Gg and Sr are at level 2 and are subareas of SM.

SM (Serbia Montenego) is not listed on the legend of the

condensed_distribution so i am assuming that this area is never to be shown.

Solution:

  • all subareas of the fallbackareas move to level 2, which makes them consistent with the cdm

  • the fallbackareas become the parent of these subareas.

#3 Updated by Andreas Kohlbecker almost 6 years ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • Category changed from cdmlib-remote to data
  • Target version changed from Euro+Med Portal Release to Release 3.8

#4 Updated by Andreas Kohlbecker almost 6 years ago

The above changes have been applied to the shapefile and the updated shapefile has been send to Tervuren in order to update the geoserver.

changes in https://dev.e-taxonomy.eu/git/euromed-map.git:

  • cdd1f99 #4409 adding BH to Ju

  • 9d03ca0 #4409 adding fallback areas to shapefile

next steps:

  • update the area/shapefile mapping with the new euromed_2013.csv

#5 Updated by Andreas Kohlbecker almost 6 years ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Müller to Andreas Kohlbecker

Replying to a.kohlbecker:

The above changes have been applied to the shapefile and the updated shapefile has been send to Tervuren in order to update the geoserver.

next steps:

  • update the area/shapefile mapping with the new euromed_2013.csv

edit-test has been updated, edit-production is still running the old version of the database and should be updated by installing the db from edit-test

Last action in this issue is to do the review once the new shapefile is installed in the geoserver

#6 Updated by Andreas Kohlbecker almost 6 years ago

  • Assignee changed from Andreas Kohlbecker to e.raab-straube -

the distribution map is now ok

Eckhard. please can you confirm that?

#7 Updated by Eckhard von Raab-Straube over 5 years ago

It is ok now for Ju and for Cz, but still not fixed for Tcs and Bt! See:

http://test.e-taxonomy.eu/dataportal/preview/euromed/cdm_dataportal/taxon/7ddb75d9-b5a1-4941-99e6-c81456750bda

Bt: Baltic states (Estonia, Latvia, Lithuania) and Kaliningrad region

Tcs:Transcaucasia (Azerbaijan, Armenia, and Georgia)

Erlaubt mir die Bemerkung, dass diese Fehler sehr leicht gefunden werden können, wenn man

a) die jetzige Testportal-Karte mit der bisherigen Euro+Med-Karte vergleicht,

und/oder

b) den occurrence-string und die ausformulierte Areal-Liste im Testportal, die direkt unter der Karte stehen, mit dieser vergleicht.

Wenn ihr das selbst macht, braucht ihr nicht so lange zu warten, bis ich mal die Zeit für ein review gefunden habe... das könnte ja das bug-fixing beschleunigen :-)

#8 Updated by Andreas Kohlbecker over 5 years ago

Hallo Eckhard,

die Anzeige und Verarbeitung der Verbreitungsangaben für Euro+Med ist ein recht komplexes Thema, das mittlerweile in mehreren Tickets behandelt wird, wobei manche der Tickets einen ganz spezifischen Fokus auf ein Teilproblem haben.

In diesem Ticket geht es ausschließlich um die Anzeige der sogenannten 'fallback areas' Ju, Cz, IJ and LS. Diese wurden in den Karten nicht angezeigt, diese Problem ist behoben. Zumindest sehe ich das so, nachdem ich einige Karten der originalen Euro+Med Website mit dem CDM Portal verglichen habe - ich mach das tatsächlich ;-) .

Für Ju und Cz hast du das ja schon bestätigt: "It is ok now for Ju and for Cz,".

Die Nicht-Anzeige der Areale Tcs and Bt und einiger anderer wird im Ticket #3908 (http://dev.e-taxonomy.eu/trac/ticket/3908) behandelt. Ich habe im letzten Kommentar des Tickets alle Details zusammengefasst damit es verständlicher und übersichtlicher wird, zu diesem Ticket bräuchte ich dringend dein Feedback.

Das es so viele Tickets zu ein und dem selben Thema gibt ist lästig und zeitaufwändig aber es geht nun leider nicht anders.

Andreas

#9 Updated by Andreas Müller 2 months ago

  • Description updated (diff)
  • Status changed from Resolved to Closed
  • Assignee changed from Eckhard von Raab-Straube to Andreas Kohlbecker

This should be fixed now. Either with #8858 or already before. Open issues are otherwise handled in #8297 and related tickets.

#10 Updated by Andreas Müller 2 months ago

  • Related to bug #8858: Ordering of distribution status 'undefined' is not correct in E+M added

#11 Updated by Andreas Müller 2 months ago

  • Related to deleted (bug #8858: Ordering of distribution status 'undefined' is not correct in E+M)

#12 Updated by Andreas Müller 2 months ago

  • Status changed from Closed to Resolved
  • Assignee changed from Andreas Kohlbecker to Andreas Müller

Andreas Müller wrote:

This should be fixed now. Either with #8858 or already before. Open issues are otherwise handled in #8297 and related tickets.

Sorry, wrong ticket. I still have to check this ticket.

#13 Updated by Andreas Müller 2 months ago

  • Related to task #9161: E+M shapefile with Kaukasus regions added

#14 Updated by Andreas Müller 2 months ago

  • Related to bug #8310: Issues to solve in E+M shapefile added

#15 Updated by Andreas Müller 2 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Andreas Kohlbecker
  • % Done changed from 0 to 100

This seems to be fully fixed except for the Baltic states issue handled in #9367. TCS is now shown as 1 area if no subareas have data.

#16 Updated by Andreas Müller 2 months ago

Andreas Müller wrote:

This seems to be fully fixed except for the Baltic states issue handled in #9367. TCS is now shown as 1 area if no subareas have data.

Unfortunately it is not true that the TCS problem is fully fixed already (only the maps show TCS better now, done in #8310).

However, I keep the ticket closed as the original problem described in the ticket description is fixed and a followup ticket #9486 was created.

#17 Updated by Andreas Müller 2 months ago

  • Copied to bug #9486: Fallback areas not handled in area hierarchy are not showing up correctly if subarea data exists added

#18 Updated by Andreas Müller 2 months ago

  • Private changed from Yes to No

#19 Updated by Andreas Müller 2 months ago

  • Related to feature request #9502: Implement subarea preference rule and fallback areas for areas with complex hierarchy added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)