Project

General

Profile

Actions

bug #9318

closed

TaxonNameEditor: nomenclatural reference no longer selectable

Added by Andreas Kohlbecker about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
critical
Found in Version:
Tags:

Description

after the changes that turn the nomenclatural reference into a DescriptionElementSource (#9225, #6581) the nomenclatural reference is no longer selectable in the TaxonNameEditor

Steps to reproduce:

  1. Open the name editor (e.g for a new name)
  2. add a basionym
  3. try to select the nom ref.

--> the selection always is make empty since and a validation exception is thrown "This field is required ..."


Related issues

Related to EDIT - feature request #9225: Make TaxonName.nomenclaturalSource a new DescriptionElementSource subclassClosedAndreas Müller

Actions
Related to EDIT - feature request #6581: Make all microreferenced references OriginalSourcesClosedAndreas Müller

Actions
Actions #1

Updated by Andreas Kohlbecker about 2 years ago

  • Related to feature request #9225: Make TaxonName.nomenclaturalSource a new DescriptionElementSource subclass added
Actions #2

Updated by Andreas Kohlbecker about 2 years ago

Actions #3

Updated by Andreas Kohlbecker about 2 years ago

  • Description updated (diff)

this is actually a bug introduced with #9229 - implementation was incomplete.

Actions #4

Updated by Andreas Kohlbecker about 2 years ago

  • Status changed from New to Duplicate
  • Target version deleted (Release 5.18)
Actions #5

Updated by Andreas Kohlbecker about 2 years ago

  • Is duplicate of feature request #9229: TaxonNameEditor: use NomenclaturalStatusDTO to avoid data loading probems within setters in TaxonName added
Actions #6

Updated by Andreas Kohlbecker about 2 years ago

  • Is duplicate of deleted (feature request #9229: TaxonNameEditor: use NomenclaturalStatusDTO to avoid data loading probems within setters in TaxonName)
Actions #7

Updated by Andreas Kohlbecker about 2 years ago

  • Status changed from Duplicate to In Progress
  • Target version set to Release 5.18
Actions #8

Updated by Andreas Kohlbecker about 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 0 to 50

this should be fixed now, can you please review?

Actions #9

Updated by Wolf-Henning Kusber about 2 years ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

Reference selectable for basionym, replaced synonym, and validation. The ticket can be closed.

Actions #10

Updated by Andreas Kohlbecker about 2 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF