Project

General

Profile

bug #8631

ABCD import fails to put new taxa into the classification, create mediaspecimens, etc

Added by Andreas Kohlbecker 23 days ago. Updated 7 days ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
10/29/2019
Due date:
% Done:

80%

Severity:
normal
Found in Version:
Tags:

Description

To reproduce:

at the end the exception as described in #8630 happens.

As result of the import a classification has been created as well as the taxon "Arenaria serpyllifolia L. subsp. serpyllifolia sec. ABCD classic" but

  • the taxon is not part of the classification.
  • the specimen is not related to the name or taxon
  • a media object was created (http://ww2.bgbm.org/herbarium/images/B/10/04/63/63/B_10_0463639.jpg) but is not associated with the specimen. A media specimen should have been created as derivative of the specimen B 10 0463639
  • The DNA Sample which was fetched from a BioCase Provider is not a derivative of the specimen

BTW:
* What's the purpose of the text field close to the bottom of the dialog?

picture367-1.png View (59.8 KB) Andreas Kohlbecker, 10/29/2019 03:28 PM

Arenaria_ABCD_one_unit.xml View (9.74 KB) Andreas Kohlbecker, 10/29/2019 03:29 PM

picture699-1.png View (56.9 KB) Andreas Kohlbecker, 11/06/2019 09:24 AM

picture673-1.png View (20.1 KB) Katja Luther, 11/06/2019 02:57 PM

picture860-1.png View (20.2 KB) Katja Luther, 11/08/2019 11:00 AM

picture468-1.png View (51.2 KB) Patrick Plitzner, 11/11/2019 11:08 AM


Related issues

Related to Edit - bug #8630: ClassCastException when ABCD import has finished Closed 10/29/2019
Related to EDIT Platform Etablierung - task #8580: Update documentation to latest revision of the Taxeditor In Progress 10/10/2019
Related to Edit - bug #8632: ABCD retrieves DNA Sample from Biocase Provider even if it is not selected in the import configuration Closed 10/29/2019
Related to Edit - bug #8582: Taxon Navigator: Classification label not refreshed & new taxa not visible Closed 10/10/2019

Associated revisions

Revision f7717334 (diff)
Added by Katja Luther 22 days ago

ref #8631: fix errors in abcd import

Revision 92546b65 (diff)
Added by Katja Luther 22 days ago

ref #8631: fix ClassCastException for abcd import and NPE in abcd preferences

Revision 8a720214 (diff)
Added by Katja Luther 22 days ago

ref #8631: remove the possibility to search for dna when importing from abcd file

Revision 21850e02 (diff)
Added by Katja Luther 15 days ago

ref #8631: remove nomenclatural code selection page for file import

Revision cb45e05b (diff)
Added by Katja Luther 10 days ago

ref #8631: layout issues in abcd import wizard page and refresh of navigator after abcd import

Revision 905fdec1 (diff)
Added by Katja Luther 9 days ago

ref #8631: same layout for unit id and nomenclatural code combobox

Revision d36d2eb8 (diff)
Added by Patrick Plitzner 8 days ago

ref #8631 Fixed layout + merged constructors

Revision 18683dc6 (diff)
Added by Katja Luther 7 days ago

ref #8631: layout issues

History

#1 Updated by Andreas Kohlbecker 23 days ago

  • Description updated (diff)

#3 Updated by Andreas Kohlbecker 23 days ago

  • Related to bug #8630: ClassCastException when ABCD import has finished added

#4 Updated by Andreas Kohlbecker 23 days ago

  • Description updated (diff)

#5 Updated by Andreas Kohlbecker 23 days ago

  • Description updated (diff)

#6 Updated by Andreas Kohlbecker 23 days ago

  • Related to task #8580: Update documentation to latest revision of the Taxeditor added

#7 Updated by Andreas Kohlbecker 23 days ago

  • Subject changed from ABCD import fails to put new taxa into the classification to ABCD import fails to put new taxa into the classification, create mediaspeciemens, etc

#8 Updated by Andreas Kohlbecker 23 days ago

  • Related to bug #8632: ABCD retrieves DNA Sample from Biocase Provider even if it is not selected in the import configuration added

#9 Updated by Andreas Kohlbecker 23 days ago

  • Description updated (diff)

#10 Updated by Katja Luther 22 days ago

the media was not imported because of a NPE, this is fixed.
the dna was not associated to the specimen because of wrong associationType parsing when the abcd version is different, this is fixed.

The problem of the taxon appears only for the import from file. It is a lazy loading exception while creating the nomenclatural titleCache of a team during cascading.

#11 Updated by Katja Luther 22 days ago

  • Status changed from New to In Progress

#12 Updated by Katja Luther 22 days ago

  • Target version changed from Unassigned CDM tickets to Release 5.11

The ClassCastException should be solved with the last commit

#13 Updated by Katja Luther 22 days ago

As a workaround the possibility to search for dna is disabled for file import. For the biocase seach it is still possible to add a dna biocase provider.

There is a test in cdmlib for import from file with dna search, it works.

#14 Updated by Katja Luther 16 days ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Kohlbecker

#15 Updated by Andreas Kohlbecker 15 days ago

  • Assignee changed from Andreas Kohlbecker to Katja Luther

There are still some problems which are not yet fixed:

  • the taxon is not part of the classification.
  • the specimen is not related to the name or taxon

and I found some new problems

  • after the import the Taxonnavigator is not refreshes, the new classification only becomes visible after closing and re-openening this view, I will add this obeservarion to #8582
  • The "Configure Import Dialog" has changed, and has two issues:
    • The select field for "Unit ID Mapping" is hardly readable and should be moved, aligned differently so that it is completely visible also in linux
    • There is a new select field offering codes, the purpose of this field is unclear, even more unclear since the next page of the import wizard allows to choose the code again.

#16 Updated by Andreas Kohlbecker 15 days ago

  • Related to bug #8582: Taxon Navigator: Classification label not refreshed & new taxa not visible added

#17 Updated by Andreas Kohlbecker 15 days ago

#18 Updated by Katja Luther 15 days ago

Andreas Kohlbecker wrote:

There are still some problems which are not yet fixed:

  • the taxon is not part of the classification.
  • the specimen is not related to the name or taxon

and I found some new problems

  • after the import the Taxonnavigator is not refreshes, the new classification only becomes visible after closing and re-openening this view, I will add this obeservarion to #8582
  • The "Configure Import Dialog" has changed, and has two issues:
    • The select field for "Unit ID Mapping" is hardly readable and should be moved, aligned differently so that it is completely visible also in linux
    • There is a new select field offering codes, the purpose of this field is unclear, even more unclear since the next page of the import wizard allows to choose the code again.

that the field for Unit ID Mapping is hardly readable seems to be a OS problem with windows it looks like this:

#19 Updated by Katja Luther 15 days ago

the nomenclatural code selection page is removed

#20 Updated by Katja Luther 15 days ago

Andreas Kohlbecker wrote:

There are still some problems which are not yet fixed:

  • the taxon is not part of the classification.
  • the specimen is not related to the name or taxon

I think this is related to the lazy loading exception during the import. There is now a import report at the end of the import, there these exceptions should be shown.

#21 Updated by Katja Luther 15 days ago

Katja Luther wrote:

Andreas Kohlbecker wrote:

There are still some problems which are not yet fixed:

  • the taxon is not part of the classification.
  • the specimen is not related to the name or taxon

maybe there is no "preferred" flag for one of the determinations (if there is only one determination this is the preferred determination), if this is missing the import does not create the taxon node and relation from the taxon and specimen.

#22 Updated by Andreas Kohlbecker 15 days ago

Katja Luther wrote:

the nomenclatural code selection page is removed

Did you add a label to the code selection field?

#23 Updated by Andreas Kohlbecker 15 days ago

Katja Luther wrote:

Andreas Kohlbecker wrote:

  • The "Configure Import Dialog" has changed, and has two issues:
    • The select field for "Unit ID Mapping" is hardly readable and should be moved, aligned differently so that it is completely visible also in linux
    • There is a new select field offering codes, the purpose of this field is unclear, even more unclear since the next page of the import wizard allows to choose the code again.

that the field for Unit ID Mapping is hardly readable seems to be a OS problem with windows it looks like this:

I don't share this view that is an OS problem. I checked a coupld of dialogs with selects in eclipse and in dBeaver and none of the dialogs has this problem.

To me it looks like the width of the select elements is determined by the code selection field (At least in QT/GTK driven desktop environments).

The way the label is added to the select is a bit special in this import dialog as in all other cases the label prepends the select:

label: [select]

#24 Updated by Andreas Müller 13 days ago

  • % Done changed from 0 to 40

Can you please leave a note if this is easy to fix? Otherwise please move to new ticket as the layout is not really part of the original ticket description

#25 Updated by Katja Luther 13 days ago

Andreas Müller wrote:

Can you please leave a note if this is easy to fix? Otherwise please move to new ticket as the layout is not really part of the original ticket description

the label and the combo box are now in one line:

@AK: could you please check, whether the combo box is displayed correctly on linux?

#26 Updated by Andreas Müller 13 days ago

  • Assignee changed from Katja Luther to Andreas Kohlbecker

#27 Updated by Andreas Müller 12 days ago

  • Subject changed from ABCD import fails to put new taxa into the classification, create mediaspeciemens, etc to ABCD import fails to put new taxa into the classification, create mediaspecimens, etc

#28 Updated by Patrick Plitzner 10 days ago

This is how it looks for me. Started the editor from the IDE.

#29 Updated by Andreas Müller 10 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Kohlbecker to Katja Luther

So the layout still needs some update for linux, I guess.

#30 Updated by Katja Luther 8 days ago

  • Assignee changed from Katja Luther to Patrick Plitzner

@Patrick could you have another look, whether it looks better now. It is difficult to check for me because with windows it looks ok.

#31 Updated by Patrick Plitzner 8 days ago

  • Assignee changed from Patrick Plitzner to Katja Luther

I made some changes myself. Looks fine on Linux. Please test on windows.

#32 Updated by Andreas Müller 7 days ago

It look ok now. Only change I suggest: let the "Biocase provider for DNA" dropdown start at the same horizontal position as all other dropdowns.

@Andreas K.: Can you also check if it looks ok on your Linux?

#33 Updated by Andreas Müller 7 days ago

  • % Done changed from 40 to 80

#34 Updated by Andreas Müller 7 days ago

Andreas Müller wrote:

It look ok now. Only change I suggest: let the "Biocase provider for DNA" dropdown start at the same horizontal position as all other dropdowns.

@Andreas K.: Can you also check if it looks ok on your Linux?

upps, sorry, I tested the preference page, not the file import. However, the little change in the preference would also be nice ...

#35 Updated by Andreas Kohlbecker 7 days ago

It looks ok in KDE!

The ticket can be closed.

#36 Updated by Katja Luther 7 days ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)