Project

General

Profile

bug #8630

ClassCastException when ABCD import has finished

Added by Andreas Kohlbecker 23 days ago. Updated 15 days ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
10/29/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

after a ABCD import has run a ClassCastException happens on processing the result data:

!MESSAGE An internal error occurred during: "Import: Abcd206ImportConfigurator".
!STACK 0
java.lang.ClassCastException: eu.etaxonomy.cdm.io.common.ImportResult cannot be cast to eu.etaxonomy.cdm.api.service.UpdateResult
        at eu.etaxonomy.taxeditor.model.AbstractUtility.updateNameEditors(AbstractUtility.java:803)
        at eu.etaxonomy.taxeditor.model.AbstractUtility$3.run(AbstractUtility.java:645)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

!ENTRY eu.taxeditor 2 0 2019-10-29 15:04:13.510
!MESSAGE Reset usage data

!ENTRY org.eclipse.core.jobs 4 0 2019-10-29 15:04:13.657
!MESSAGE This is an unexpected error.
Please contact EDIT Support (EditSupport@bgbm.org) with the error trace below (click on the 'Details' button).
!STACK 0
java.lang.Exception: login : 
editor version : 5.10.0
server :  ()
schema version : 
os : Linux 5.0.0-32-generic amd64
java : 1.8.0_131
java.lang.ClassCastException: eu.etaxonomy.cdm.io.common.ImportResult cannot be cast to eu.etaxonomy.cdm.api.service.UpdateResult
        at eu.etaxonomy.taxeditor.model.AbstractUtility.updateNameEditors(AbstractUtility.java:803)
        at eu.etaxonomy.taxeditor.model.AbstractUtility$3.run(AbstractUtility.java:645)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

        at eu.etaxonomy.taxeditor.model.MessagingUtils$1.run(MessagingUtils.java:286)
        at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
        at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
        at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4536)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4154)
        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)


Related issues

Related to Edit - bug #8631: ABCD import fails to put new taxa into the classification, create mediaspecimens, etc Closed 10/29/2019
Related to EDIT Platform Etablierung - task #8580: Update documentation to latest revision of the Taxeditor In Progress 10/10/2019

Associated revisions

Revision 92546b65 (diff)
Added by Katja Luther 22 days ago

ref #8631: fix ClassCastException for abcd import and NPE in abcd preferences

History

#1 Updated by Andreas Kohlbecker 23 days ago

  • Related to bug #8631: ABCD import fails to put new taxa into the classification, create mediaspecimens, etc added

#2 Updated by Andreas Kohlbecker 23 days ago

  • Related to task #8580: Update documentation to latest revision of the Taxeditor added

#3 Updated by Andreas Kohlbecker 17 days ago

  • Tags set to import

#4 Updated by Katja Luther 16 days ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Kohlbecker
  • Target version changed from Unassigned CDM tickets to Release 5.11
  • % Done changed from 0 to 50

this is fixed.

#5 Updated by Andreas Kohlbecker 15 days ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Kohlbecker to Katja Luther
  • % Done changed from 50 to 100

The problem is no longer reproducible, closing the issue.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)