Project

General

Profile

bug #8531

factual data and media view always opened when opening taxon

Added by Katja Luther about 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Priority14
Assignee:
Category:
taxeditor
Target version:
Start date:
09/09/2019
Due date:
% Done:

80%

Severity:
normal
Found in Version:

Description

the factual data and media view should stay closed when opening a new taxon.
when opening the distribution editor the factual data and media view should be closed (see #7854), but when opening a taxon the factual data view should be opened again only if it was open before.
we need to handle the switch between open views. For example switch between the distribution editor and an already opened taxon

mail of WB:

Das Schließen der Media und Facts Views wird jetzt nicht nur beim Start des Editors ignoriert, sondern sie gehen auch wieder auf, wenn man ein neues Taxon aufruft.


Related issues

Related to Edit - bug #8898: remaining problems with closed/open facts/media view when opening name editor or distribution editor New 03/20/2020

Associated revisions

Revision 4297a77c (diff)
Added by Katja Luther about 1 year ago

ref #8531: open facts view only if it was open before

History

#1 Updated by Katja Luther about 1 year ago

  • Description updated (diff)
  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Katja Luther about 1 year ago

  • Status changed from Resolved to In Progress

#3 Updated by Katja Luther about 1 year ago

  • Description updated (diff)

#4 Updated by Katja Luther about 1 year ago

the editor now remember whether the facts and media view were open before distribution editor was opened and depending on that the facts and media view is opened again when opening a new taxon.

Still missing:
Open the facts view when switching to an already opened taxon.

#5 Updated by Katja Luther about 1 year ago

  • Target version changed from Release 5.10 to Release 5.11

#6 Updated by Katja Luther 11 months ago

this is fixed.

Last problem is when the facts view is closed while the distribution editor is already open, then the fatcs will be opened when switching between distribution editor and name editor

#7 Updated by Katja Luther 11 months ago

  • Target version changed from Release 5.11 to Release 5.12

#8 Updated by Katja Luther 9 months ago

  • Target version changed from Release 5.12 to Release 5.13

#9 Updated by Katja Luther 7 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

this should be fixed, now.

#10 Updated by Andreas Müller 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 80

This mostly works but sometimes the behavior is still unexpected, but not that easy to reproduce.

Something that often seems to happen:

  • Only Facts View is opened (Media View closed
  • Open taxon
  • open distribution editor
  • go back to taxon and close facts view
  • go back to distribtuion editor and back to taxon again => facts view is open again though it shoudl be closed

I also had some more weired combinations where I closed the facts view and afterwards the media view was open again and similar issues, but this I could not reproduce.

Please check again intensively that the behavior is as expected even if often change the focus.

However, the main problem is solved. The remaining issues are not release relevant I think and could be moved to a new ticket.

#11 Updated by Katja Luther 6 months ago

  • Related to bug #8898: remaining problems with closed/open facts/media view when opening name editor or distribution editor added

#12 Updated by Katja Luther 6 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)