Project

General

Profile

Actions

feature request #8147

closed

Add "plural" to representation detail element

Added by Patrick Plitzner about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Highest
Assignee:
Patrick Plitzner
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Tags:

Related issues

Follows EDIT - feature request #8142: Representations have optional "plural" as additional fieldClosedAndreas Müller

Actions
Precedes EDIT - feature request #8288: Use plural for e.g. Common Name feature in dataportalNewAndreas Kohlbecker

Actions
Actions #1

Updated by Patrick Plitzner about 3 years ago

  • Due date set to 02/26/2019
  • Start date changed from 02/27/2019 to 02/26/2019
  • Follows feature request #8142: Representations have optional "plural" as additional field added
Actions #2

Updated by Patrick Plitzner about 3 years ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50
Actions #3

Updated by Andreas Müller about 3 years ago

  • Priority changed from New to Highest
Actions #4

Updated by Andreas Müller about 3 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

It works in Details View. In Translation Editor the value is not stored if only plural is added. Together with label it seems to work. This differs from how abbrevLabel works.

Actions #5

Updated by Patrick Plitzner about 3 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Andreas Müller wrote:

It works in Details View. In Translation Editor the value is not stored if only plural is added. Together with label it seems to work. This differs from how abbrevLabel works.

I don't understand what you mean? How can you only add a plural? And does this even make sense? Every term needs at least a label. Otherwise I could not close the translation editor.

I also tested again and everything seems to work for me.

Actions #6

Updated by Andreas Müller about 3 years ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

Patrick Plitzner wrote:

Andreas Müller wrote:

It works in Details View. In Translation Editor the value is not stored if only plural is added. Together with label it seems to work. This differs from how abbrevLabel works.

I don't understand what you mean? How can you only add a plural? And does this even make sense? Every term needs at least a label. Otherwise I could not close the translation editor.

I agree that we need a discussion if a translation without a label translation makes sense. But 1.) translation should be consistent (handling of abbrevTitle and handling of plural) and 2.) as long as it is possible to enter only plural and press ok button the value should either be stored (expected behaviour) or we should get a warning that saving is not possible. Simply not storing the entered data without warning is definetely not the expected/correct behavior.

I also tested again and everything seems to work for me.

No, it doesn't. I tested with current nightly. Can you describe what exactly you did for testing.

Actions #7

Updated by Andreas Müller about 3 years ago

What I did:

  • open any term, e.g. Feature "Description" in term editor
  • open translation editor
  • choose German as language on right side
  • enter "Zusammenfassungen" in right side field "Plural"
  • Press button "Finish" (no warning!!)
  • Open translation editor again
  • choose German => Field plural is empty, but shouldn't

If you do the same for abbrev. Label the field is not empty

Note: The "Finish" Button should be disabled if nothing was entered yet on right side, but isn't

Actions #8

Updated by Patrick Plitzner about 3 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 80

Fixed the plural field and the "Finish" button

Actions #9

Updated by Andreas Müller about 3 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • % Done changed from 80 to 100

The plural issue fully works now.

However there is an issue with the translation editor. When opening the translation editor the first language in the list of available languages is shown in the right dropdown. But the data for this language is not loaded into the form.
We either need to show no text in the language dropdown to make clear no language is chosen yet or we should load the form with the data for the shown language.
This might be another ticket so feel free to close this and open new one.

Actions #10

Updated by Patrick Plitzner about 3 years ago

  • Status changed from Feedback to Closed

Created new ticket #8224

Actions #11

Updated by Andreas Müller about 3 years ago

Actions

Also available in: Atom PDF