Project

General

Profile

feature request #6595

feature request #6565: [MASTER] Eclipse 4 Migration

Migrate name editor

Added by Patrick Plitzner over 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
04/27/2017
Due date:
% Done:

100%

Severity:
major
Tags:

synonymHasFocus.PNG View (31.3 KB) Katja Luther, 10/25/2017 01:27 PM

synonymHighlighted.PNG View (56.2 KB) Katja Luther, 10/25/2017 01:27 PM

picture804-1.png View - Unnecessary change to menu item for accepted taxon (4.15 KB) Andreas Müller, 11/07/2017 10:49 AM


Related issues

Related to Edit - bug #6550: ArrayIndexOutOfBoundsException when opening a taxon with double click from the navigator Closed 04/03/2017
Copied to Edit - bug #7064: NameEditor remaining issues Closed 11/07/2017
Copied from Edit - feature request #7071: Reenable restore functionality New 10/06/2017

Associated revisions

Revision 4ff11da5 (diff)
Added by pplitzner over 1 year ago

ref #6595 Initial commit of migrated/refactored classes (not working)

Revision 033ef209 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Fix composite cascade

Revision 65514c8c (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 further migration of name editor

  • Add context menu
  • fix selection propagation
  • fix saving

Revision ae55584a (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 remove unused parameter

Revision a7d1d751 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 migrate concept menu handlers

Revision 90cf660a (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Set visibility of context menu items in name editor

Revision b692de70 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Fix active part fetching

Revision 186b9558 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Refresh after delete

Revision 459a7535 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Do not hide subMenuItems

Revision a1764026 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Migrate conversation handling of moveSynonym operation

Revision 15cd5e08 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Migrate handler for opening taxon nodes in name editor

Revision 200e8530 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Use only e4 handler for opening name editor

Revision b02af7f6 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Refresh after moving synonym

Revision c8cdc672 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Propagate dirty state handling

Revision e378d285 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Update part name with changes

Revision eaff1338 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 refactor selection handling to migrated name editor

Revision e9fa67ee (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595, #6925 Use EventBroker to keep track of active taxon editor

Revision fb85fe2e (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 Evaluate current taxon in taxon relationship detail element

Revision 24b8f2f1 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 migrate drag and drop functionality

Revision 860316c8 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 removed e3 name editor classes (unstable navigator plugin)

Revision e3624fa7 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6595 remove e3 references

Revision 5d040c73 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Remove e3 popup menu

Revision 8fb03377 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Do not open name editor twice for same taxon

Revision 31e5785c (diff)
Added by Katja Luther about 1 year ago

fix #6595: not editable synonyms should be enabled to be clickable

Revision fbd8e961 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Do not open name editor twice for same taxon (fully fixed)

Revision e34c0af1 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Set correct focus when opening a taxon/synonym

Revision 48af2464 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Fix NPE when opening orphaned taxon

Revision 3fd7ed16 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Fix initial selection for synonymy and accepted taxa

Revision be02f4f9 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595, 6568 Open taxon name editor in editor area

  • migrate taxonomic perspective

Revision 41c668f3 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 code refactoring

Revision 61d94a7a (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595, #6597 Optimize selection event propagation

  • reduce rendering of details view etc.

Revision c175c2ff (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Show full title cache of name in name editor tab

Revision 0bd0e199 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Remove exception from editor opening

Revision 4ae1033f (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Fix "move synonym to another taxon" handler

Revision ffa3cdff (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Another fix for "move synonym to another taxon" handler

  • close old editor
  • open new one

Revision 776e3e99 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Preselect classification when moving factual data

Revision 0f199310 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Fix selection propagation for name editor when entering text

Revision 3f0054fb (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Fix selection propagation for name editor when entering text

Revision 96e9845f (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Enhance selection propagation for name editor

Revision b6b0c782 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6595 Enhance selection propagation for name editor

Revision 9af93aa7 (diff)
Added by Andreas Müller about 1 year ago

ref #6595 fix never ending details view rendering

Revision e153d114 (diff)
Added by Andreas Müller about 1 year ago

ref #6595 fix never ending details view rendering

History

#1 Updated by Andreas Müller over 1 year ago

  • Related to bug #6550: ArrayIndexOutOfBoundsException when opening a taxon with double click from the navigator added

#2 Updated by Andreas Müller over 1 year ago

  • Target version changed from Unassigned CDM tickets to Release 4.8

#3 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 4.8 to Release 4.9

#4 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 4.9 to Release 4.10

#5 Updated by Patrick Plitzner over 1 year ago

  • Status changed from New to In Progress

#6 Updated by Patrick Plitzner about 1 year ago

  • Target version changed from Release 4.10 to Release 4.11

#7 Updated by Patrick Plitzner about 1 year ago

  • % Done changed from 0 to 40

#8 Updated by Patrick Plitzner about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 40 to 50

#9 Updated by Katja Luther about 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Patrick Plitzner

seems to work

#10 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Closed to Resolved
  • % Done changed from 50 to 80

Katja:

Es gibt noch zwei Sachen, die ich im Hinblick auf den Workshop kritisch finde:

Wenn ich einen neuen Namen erzeugt habe und eine Referenz in den NameEditor eingebe, dann funktioniert zwar der Parser richtig, aber der Details View wird nicht aktualisiert, so dass es so aussieht als hätte es nicht funktioniert.

Wenn Synonyme nicht im Name Editor nicht editierbar sind, dann kann ich sie auch nicht auswählen, dann kann ich im Name Editor auch keine Änderungen machen, so dass ich das Problem nicht beheben kann und ich kann sie dann auch nicht löschen.

#11 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback

#12 Updated by Katja Luther about 1 year ago

  • Status changed from Feedback to Resolved
  • % Done changed from 80 to 50

#13 Updated by Katja Luther about 1 year ago

  • % Done changed from 50 to 80

Wenn Synonyme nicht im Name Editor nicht editierbar sind, dann kann ich sie auch nicht
auswählen, dann kann ich im Name Editor auch keine Änderungen machen, so dass ich das
Problem nicht beheben kann und ich kann sie dann auch nicht löschen.

the textWidget needs to be enabled but not editable to be clickable.

#14 Updated by Katja Luther about 1 year ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

#15 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 80 to 60
  • Severity changed from normal to major

The Name Editor can still be opened multiple times for the same taxon. At least this is the case when trying opening via search result view or referencing objects view. It seems to be not the case when opening via taxon navigator.
In general opening strategy should be independent from where the opening was triggered. If this is not yet the case we should try to make it independent and use 1 single access point.

#16 Updated by Patrick Plitzner about 1 year ago

Andreas Müller wrote:

The Name Editor can still be opened multiple times for the same taxon. At least this is the case when trying opening via search result view or referencing objects view. It seems to be not the case when opening via taxon navigator.
In general opening strategy should be independent from where the opening was triggered. If this is not yet the case we should try to make it independent and use 1 single access point.

This has now also been fixed

#17 Updated by Katja Luther about 1 year ago

  • Assignee changed from Katja Luther to Patrick Plitzner

when opening a taxon that has a synonym the synonym has the focus. But the accepted taxon should have the focus.

No it's more difficult: Opening a taxon in the name editor -> the synonym is highlighted but the selected item seems to be the accepted taxon (details and factual data are displayed) but when clicking on the tab to move it the synonym gets the focus (I did not click in the freetext field) and the details of the synonym are displayed. see attached images

#19 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 60 to 70

#20 Updated by Katja Luther about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Katja Luther to Patrick Plitzner

the focus still moves to the synonym when moving the tab.

#21 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 70 to 80

Fixed the initial selection.

I think all the issues mentioned in the comments are done. Please close if correct

#22 Updated by Katja Luther about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Katja Luther to Patrick Plitzner

I don't know if this is an old issue: but setting a synonym in a heterotypic (to the accepted taxon) homotypic group as basionym changes the symbol of the synonym from homotypic to heterotypic.

#23 Updated by Katja Luther about 1 year ago

the focus stuff works fine now.

#24 Updated by Katja Luther about 1 year ago

Katja Luther wrote:

I don't know if this is an old issue: but setting a synonym in a heterotypic (to the accepted taxon) homotypic group as basionym changes the symbol of the synonym from homotypic to heterotypic.

this is again an update problem because the basionym should be the first synonym in the list and then the icon is correct.
same problem when drag&drop a synoym in the homotypical group of an other synonym, the order should be recalculated.

#25 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

Created a new ticket for the remaining issues -> #7058

#26 Updated by Andreas Müller about 1 year ago

  • Status changed from Closed to Feedback

Have to reopen as it is not possible anymore to add a misapplication to an accepted taxon. The according submenu in the "New" context menu is disabled.

Another less critical issue: context menu of accepted taxon shows "change to" which has 3 disabled submenus. In e3 the "change to" menu item was invisible, which is more appropriate.

Finally, in e3 we had a "save" menu item which is missing in e4 version (not so critical, as save is possible at other places, however, some users might be used to)

#28 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

Fixed misapplication handler and opened ticket for remaining issues. #7064

Please close after review

#29 Updated by Patrick Plitzner about 1 year ago

  • Copied to bug #7064: NameEditor remaining issues added

#30 Updated by Andreas Müller about 1 year ago

Misapplication issue seems to be fixed. Keep ticket open for general review of name editor.

#31 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Name editor tabs do still show taxon titleCache but should show name titleCache

#32 Updated by Andreas Müller about 1 year ago

Restoring name editors tabs after restart (maybe also reconnect?) does not work anymore, but did in 4.10. (see similar issue in navigator ticket #6909)

#33 Updated by Andreas Müller about 1 year ago

Move synonym (homot. group) to a new accepted taxon does not work correctly. The result is correct, but after the operation only the dirty flag is set. The homotypic group is still visible. It should be the other way round:

  • the synonym group should be removed
  • the dirty flag should NOT be set (because the operation is saved immediately and can't be reverted)
  • additionally the new taxon should be opened (showing the synonym group being moved)

Partly this already didn't work in v4.10: here the synonym group WAS removed but the dirty flag was still set. Also the new accepted taxon was not opened.

#34 Updated by Andreas Müller about 1 year ago

#35 Updated by Andreas Müller about 1 year ago

#36 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 100 to 90

Handler was fixed.

Restoring was disabled on purpose (as described in #6909)

#37 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Patrick Plitzner wrote:

Handler was fixed.

In the old taxon, the synonym group is still visible (after reopen it is disappeared so it is only a refresh issue) but shouldn't. All the rest works.

#38 Updated by Andreas Müller about 1 year ago

#39 Updated by Katja Luther about 1 year ago

Andreas Müller wrote:

Patrick Plitzner wrote:

Handler was fixed.

In the old taxon, the synonym group is still visible (after reopen it is disappeared so it is only a refresh issue) but shouldn't. All the rest works.

I can't reproduce this. The old taxon is closed and the new one is opened.

#40 Updated by Katja Luther about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

#41 Updated by Patrick Plitzner 7 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • % Done changed from 90 to 100

The E4 migration has been done up to a sufficient state.
Remaining issues should be handled in separate tickets.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)