Project

General

Profile

feature request #7063

improve the area selection wizard for distribution editor

Added by Katja Luther about 1 year ago. Updated about 2 months ago.

Status:
Feedback
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
11/07/2017
Due date:
% Done:

40%

Estimated time:
8.00 h
Severity:
normal
Tags:

Description

The wizard for selection of areas for the distribution editor should be improved.

  • while opening the wizard the vocabularies are not correctly marked if the whole vocabulary or only parts of it should be used in the distribution editor.
  • the wizard is quite slow (performance)

For the first issue we decided to implement the following:

  1. we keep selection via tree structure
  2. the checkbox uses triple state: a. checked, if, and only if, all subareas, and their subareas are fully included
    • undefined, if, some subareas are checked, but not all (including recursive subareas
    • not checked, if no of the subareas is checked or in "undefinded" state it self
  3. opening a node in the tree works via "triangle button"
  4. click actions: double functionality is needed
    • select/deselect all subareas
    • select the given area (not including the subareas)
    • problem: we want to avoid right click menus or other double functionality handling modes (e.g. single click/double click) as they are maybe not intuitive
    • solution: to select/deselect the single area (without subareas) we add it to itself as child node at first position, without children
  5. click action "select all subareas" will
    • open the for one more level
    • check the parent checkbox and all child checkboxes
    • check all grandchild checkboxes if expanded, however for all grand(grand) children the information needs to be stored that they are "checked"
    • opening also all grandchildren takes a lot of rendering time and is not necessary
  6. click "deselect all" will
    • unckeck all child and grandchild areas
    • not change the expansion state of the tree

For performance improvement need something like a UuidAndTitleCache for trees (including the parent information). Loading this should be faster then current implementation but can still load the full vocabulary at once if voc is not extremely large. But maybe this already exists e.g. from taxon navigator DTO.

Open issues:

  • triple state is not yet correctly propagated to vocabulary during initial load (checkbox always empty)
  • deselection only propagates to next parent, but not to grandparent (e.g. if parent switches from checked to undefined and grandparent is also checked, it also needs to switch to undefined)
  • clicking on a parent which is in "undefined" does not change its state but should (either going to checked or unchecked, because also all its children switch to this state

Related issues

Related to Edit - bug #6297: [Overview] BGBM User group wishes 2017 New 05/29/2017
Related to Edit - feature request #7793: Master ticket for E+M editor issues Feedback 09/27/2018
Related to Edit - feature request #7235: Make available area vocabularies a database preference for TaxEditor distribution editor Resolved 02/01/2018
Related to Edit - task #7854: Open issues in TaxDistributionEditor In Progress 10/23/2018
Copied from Edit - bug #6159: improve distribution editor in TaxEditor Resolved 10/24/2016

Associated revisions

Revision 1a7fff5e (diff)
Added by Katja Luther about 1 year ago

ref #7063: fix gray and checked marks in area tree

Revision 7a440129 (diff)
Added by Katja Luther 11 months ago

ref #7063: sort terms by label

Revision 4f25e642 (diff)
Added by Katja Luther 3 months ago

ref #7063: add vocabulary selection for distribution editor and area selection in editor

Revision 9c8494ea (diff)
Added by Katja Luther 3 months ago

ref #7063: fix preselection of vocabulary

Revision 04f83f13 (diff)
Added by Katja Luther 3 months ago

ref #7063:fix that the last selection always appears in next field in distribution editor

Revision aff7bab0 (diff)
Added by Katja Luther 3 months ago

ref #7063:fix that the last selection always appears in next field in distribution editor

Revision 1d76231c (diff)
Added by Katja Luther 3 months ago

ref #7063: better handling of preferences for distribution editor and other places

Revision be7068cc (diff)
Added by Katja Luther 3 months ago

ref #7063:handle orderedTerms without orderindex and order by lable

Revision fc9c0563 (diff)
Added by Katja Luther 3 months ago

ref #7063:handle orderedTerms without orderindex and order by lable

Revision 3a77d114 (diff)
Added by Katja Luther 3 months ago

ref #7063: work in progress: selection in treeview of namedAreas for distribution editor should be more reasonable

Revision 61cd8ee1 (diff)
Added by Katja Luther 2 months ago

ref #7063: optimise setGrayed and check children in distribution selection wizard

Revision 5642c43a (diff)
Added by Katja Luther 2 months ago

ref #7063: optimise setGrayed and check children in distribution selection wizard

Revision eb82a77d (diff)
Added by Katja Luther 2 months ago

ref #7063: add base element to named area tree in selection wizard to provide the posibility to check this and/or the elements of it

Revision f53701cb (diff)
Added by Katja Luther 2 months ago

ref #7063: fix NPE in local preferences

Revision 84f5eea0 (diff)
Added by Katja Luther 2 months ago

ref #7063: fix NPE in distribution editor

Revision 925bbb39 (diff)
Added by Andreas Müller about 2 months ago

ref #7063 change label for distribution area selection button

Revision 789f987c (diff)
Added by Andreas Müller about 2 months ago

ref #7063 remove "Base -" from area label for parent areas (was not intuitive)

Revision abfc6b6e (diff)
Added by Andreas Müller about 2 months ago

ref #7063 change labels for dialog help

History

#1 Updated by Andreas Müller about 1 year ago

  • Subject changed from improve the area selection wizard for sistribution editor to improve the area selection wizard for distribution editor

#2 Updated by Katja Luther about 1 year ago

The area selection wizard works better now then before. Some minor issues:

  • Handling of triple states: if only parts of a vocabulary are selected I would expect a triple state. As the vocabulary itself is not an area, it should only show the state of the selected areas within this vocabulary, with (1) selected = all areas selescted, (2) undefined = some areas selected, (3) unselected = no area selected. I managed to get such an "undefined" state once for the Waterbody vocabulary, but could not reproduce for any other. This is different for parent nodes which are areas themselves. They must not have a triple state because they might be shown or not shown in the editor.

  • The performance of e.g. clicking on TDWG vocabulary is very bad. Probably it is not a use case to select ALL TDWG areas. We may think for a better solution. Maybe it is enough to only select the next layer (e.g. TDWG level 1) and one has to select the next level manually, but this has also drawbacks, so we have to further think about a good solution

#3 Updated by Andreas Müller about 1 year ago

#4 Updated by Andreas Müller about 1 year ago

#5 Updated by Andreas Müller about 1 year ago

  • Copied from bug #6159: improve distribution editor in TaxEditor added

#6 Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 4.12 to Release 4.13

#7 Updated by Katja Luther about 1 year ago

Katja Luther wrote:

The area selection wizard works better now then before. Some minor issues:

  • Handling of triple states: if only parts of a vocabulary are selected I would expect a triple state. As the vocabulary itself is not an area, it should only show the state of the selected areas within this vocabulary, with (1) selected = all areas selescted, (2) undefined = some areas selected, (3) unselected = no area selected. I managed to get such an "undefined" state once for the Waterbody vocabulary, but could not reproduce for any other. This is different for parent nodes which are areas themselves. They must not have a triple state because they might be shown or not shown in the editor.

this is partly implemented by checkmark if all areas of a vocabulary are selected and a grayed if only some areas are selected. It is not possible to select a parent node which is an area and deselect the children or select only some of the children (then the parent node is not displayed in distribution editor)

#8 Updated by Katja Luther 11 months ago

  • Status changed from New to In Progress

for better usabilty the terms are sorted now

#9 Updated by Katja Luther 10 months ago

  • Target version changed from Release 4.13 to Release 4.14

#10 Updated by Katja Luther 10 months ago

  • Target version changed from Release 4.14 to Release 5.0

the grayed check boxes for larger hierarchies needs to be improved

#11 Updated by Andreas Müller 10 months ago

  • Related to bug #6297: [Overview] BGBM User group wishes 2017 added

#12 Updated by Katja Luther 7 months ago

  • Target version changed from Release 5.0 to Release 5.1
  • % Done changed from 0 to 40

#13 Updated by Andreas Müller 7 months ago

  • Estimated time set to 8.00 h

#14 Updated by Katja Luther 6 months ago

  • Target version changed from Release 5.1 to Release 5.2

#15 Updated by Andreas Müller 4 months ago

  • Target version changed from Release 5.2 to Release 5.3

#16 Updated by Katja Luther 3 months ago

  • Target version changed from Release 5.3 to Release 5.4

#17 Updated by Katja Luther 3 months ago

now the admin can define the vocabulary and in the distribution editor itself the shown areas can be defined.

#18 Updated by Andreas Müller about 2 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

A lot of work on this has been done in #7793. I put to resolved to check if all issues reported here are resolved now.

#19 Updated by Andreas Müller about 2 months ago

#20 Updated by Andreas Müller about 2 months ago

  • Related to feature request #7235: Make available area vocabularies a database preference for TaxEditor distribution editor added

#21 Updated by Andreas Müller about 2 months ago

  • Related to task #7854: Open issues in TaxDistributionEditor added

#22 Updated by Andreas Müller about 2 months ago

Performance has been improved by preselecting vocabularies in DB prefs or local prefs.

#23 Updated by Andreas Müller about 2 months ago

  • Description updated (diff)
  • Status changed from Resolved to Feedback

#24 Updated by Andreas Müller about 2 months ago

I updated description to refelct our decisions how the selection tree should work

#25 Updated by Andreas Müller about 2 months ago

  • Description updated (diff)

#26 Updated by Andreas Müller about 2 months ago

  • Description updated (diff)

#27 Updated by Andreas Müller about 2 months ago

  • Description updated (diff)

#28 Updated by Andreas Müller about 2 months ago

  • Assignee changed from Andreas Müller to Katja Luther

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)