Project

General

Profile

feature request #6909

feature request #6565: [MASTER] Eclipse 4 Migration

Migrate taxon navigator

Added by Patrick Plitzner over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
08/14/2017
Due date:
% Done:

100%

Severity:
critical
Tags:

picture532-1.png View - Symbols before (463 Bytes) Andreas Müller, 10/19/2017 10:43 PM

picture532-2.png View - Symbols missing (2.65 KB) Andreas Müller, 10/19/2017 10:43 PM


Related issues

Related to Edit - bug #7041: D&D for classifications should not be possible and corrupts data Closed 10/27/2017
Copied to Edit - feature request #7071: Reenable restore functionality New 10/06/2017

Associated revisions

Revision 2b7bbafc (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 migrate/delete e3 name editor refs

Revision 27a1e008 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 migrate taxon navigator

Revision 95d1ab8c (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 migrate taxon navigator context menu

Revision 259ce092 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Add navigator context listening

Revision c3bb7840 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Implement menu item/handler visibility

Revision e82f01c0 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Hide disabled menu items

Revision eb759485 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Add missing @Execute annotation

Revision 35c85fae (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Propagate TreeSelection

Revision a8459c2d (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Fix method parameter ambiguity

Revision 95ccdfd3 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Migrate remote handler

  • delete e3 handlers

Revision fabdcb1b (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Add double-click listener

Revision 9befe8ce (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Refactore double click behavior

Revision 0db2412a (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909, #6598 migrate default open handlers

Revision 713438dc (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Adapt to interace changes

Revision 369d3230 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Implement canExecute() for remoting handler

Revision 5c594099 (diff)
Added by Patrick Plitzner over 1 year ago

ref #6909 Remove unused class variable

Revision c7ea9840 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Remove e3 plugin extensions

Revision fb76c216 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 migrate dnd for navigator

Revision 944a0058 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 link with taxon editor selection

Revision 9b9d0652 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 select linked taxon editor in navigator

Revision 8136f2a8 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Fix potential NPE

Revision 81bfa200 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Simplify link with name editor

Revision 800c39e9 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Re-order context menu

Revision d111c39a (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Add "Link with editor" icon to navigator toolbar

Revision 6ca6495d (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Add "Link with editor" item to context menu

  • removed icon from navigator toolbar

Revision 6c7364f9 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Change labe of "Link with editor" item

Revision 494dbb7e (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Evaluate preferences for open distribution editor

Revision 7a8de069 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Enable "Open in referencing objects view"

Revision 4160115e (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Add toolbar to taxon navigator

  • move "Link with taxon" from context menut to toolbar

Revision 04d9b6cb (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Add "Collapse" toolbar item to navigator

Revision 22b6f3ce (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Refactor part to part descriptor

Revision 1aa2508a (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Fix potential NPE

Revision 0d60fc16 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Add canExecute to linkWithTaxonHandler

Revision 4beb3f81 (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Fix enabling of experimental handlers

Revision 862eb9dc (diff)
Added by Patrick Plitzner about 1 year ago

ref #6909 Directly update tree when linking with taxon

Revision 68699322 (diff)
Added by Katja Luther about 1 year ago

fix NPE for cloneClassification

Revision c960706c (diff)
Added by Katja Luther 12 months ago

fix NPE in cloneClassification

Revision b3fe1135 (diff)
Added by Patrick Plitzner 10 months ago

ref #6909 Fixed handler for creating new classifications

History

#1 Updated by Patrick Plitzner over 1 year ago

  • Status changed from New to In Progress
  • Target version changed from Unassigned CDM tickets to Release 4.10

#2 Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 4.10 to Release 4.11

#3 Updated by Patrick Plitzner about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 0 to 50

#4 Updated by Katja Luther about 1 year ago

in RemotingCdmHandlerE4.postOperation there is a NPE because onComplete of the operation returns null

Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.operation.e4.RemotingCdmHandlerE4.postOperation(RemotingCdmHandlerE4.java:64)
    at eu.etaxonomy.taxeditor.model.AbstractUtility.lambda$4(AbstractUtility.java:241)
    at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
    at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 24 more

    at eu.etaxonomy.taxeditor.model.MessagingUtils$1.run(MessagingUtils.java:286)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

#5 Updated by Katja Luther about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Katja Luther to Patrick Plitzner

#6 Updated by Patrick Plitzner about 1 year ago

  • Assignee changed from Patrick Plitzner to Katja Luther

Katja Luther wrote:

in RemotingCdmHandlerE4.postOperation there is a NPE because onComplete of the operation returns null

Caused by: java.lang.NullPointerException
  at eu.etaxonomy.taxeditor.operation.e4.RemotingCdmHandlerE4.postOperation(RemotingCdmHandlerE4.java:64)
  at eu.etaxonomy.taxeditor.model.AbstractUtility.lambda$4(AbstractUtility.java:241)
  at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
  at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
  at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
  at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
  ... 24 more

  at eu.etaxonomy.taxeditor.model.MessagingUtils$1.run(MessagingUtils.java:286)
  at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
  at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
  at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
  at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
  at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
  at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
  at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
  at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
  at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
  at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
  at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
  at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
  at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
  at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
  at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
  at java.lang.reflect.Method.invoke(Unknown Source)
  at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
  at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
  at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
  at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

I cannot reproduce that behavior. What did you do?

#7 Updated by Katja Luther about 1 year ago

select "Set secundum for subtree" with right click on taxon node

#8 Updated by Katja Luther about 1 year ago

  • Assignee changed from Katja Luther to Patrick Plitzner

#9 Updated by Patrick Plitzner about 1 year ago

  • Assignee changed from Patrick Plitzner to Katja Luther

Katja Luther wrote:

select "Set secundum for subtree" with right click on taxon node

This is the exception I get. And it happens because the updateResult is returned before the operation is started. I think the error is in SetSecundumForSubtreeOperation.doUpdateExecute(). Could that be?

Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.operation.RemotingCdmUpdateOperation.doExecute(RemotingCdmUpdateOperation.java:58)
    at eu.etaxonomy.taxeditor.operation.RemotingCdmOperation.execute(RemotingCdmOperation.java:50)

#10 Updated by Andreas Müller about 1 year ago

The complete symbol bar is missing (see attachement).

Therefore it is not possible anymore to switch off "Link with Editor". Also it is not possible anymore to Collapse and to Customize view. The first is very important, the second medium, the last minor (currently not in use).

#11 Updated by Andreas Müller about 1 year ago

  1. The "Open in Referencing objects view" is missing in context menu.

  2. "Open in Distribution Editor" is shown even if preference "Enable Distribution Editor" is not switched on, but shouldn't.

#12 Updated by Patrick Plitzner about 1 year ago

I added the "link" option to the context menu. That was the fastest way to do it. I tried adding it to the toolbar programatically but that caused problems with the workbench.xmi. Later we will define the toolbars in the application model.

#13 Updated by Patrick Plitzner about 1 year ago

The "Open in" options should now be correct. Now it also shows up in the referencing objects view but that should be a minor problem now

#14 Updated by Katja Luther about 1 year ago

  • Assignee changed from Katja Luther to Patrick Plitzner

the button for the sync taxon -> navigator should show if it is enabled or not. But it works.

the open in options work now

#15 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 50 to 70

All issues should be fixed now

#16 Updated by Katja Luther about 1 year ago

  • Assignee changed from Katja Luther to Andreas Müller

It seems to be fixed completely, @AM maybe you want to have a final look.

#17 Updated by Katja Luther about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

It seems that there is a problem with the method LocalSelectionTransfer.getTransfer().getSelection(); which is used for getting the selected taxonNode for drag&drop. This seems to return always the first taxonnode in the navigator.

#18 Updated by Katja Luther about 1 year ago

Katja Luther wrote:

It seems that there is a problem with the method LocalSelectionTransfer.getTransfer().getSelection(); which is used for getting the selected taxonNode for drag&drop. This seems to return always the first taxonnode in the navigator.

this is handled in #7041.

#19 Updated by Katja Luther about 1 year ago

  • Related to bug #7041: D&D for classifications should not be possible and corrupts data added

#20 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 70 to 100

Everything should be fixed or moved in to issues

#21 Updated by Andreas Müller about 1 year ago

  • Status changed from Closed to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

#22 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

The "Link" button still does not work always. If I switch it on I first have to reset the focus to the name editor. In e3 it automatically recognized which name editor had the focus before.

#23 Updated by Andreas Müller about 1 year ago

The "Customize View" does not exist anymore. But as filtering and showing synonyms did not seem to work in 4.10 neither we may live with this and wait until someone requires theses features.

#24 Updated by Andreas Müller about 1 year ago

There is an issue with "move factual data" but this is not migration related: #7068.
Another issue is related to delete and is handled in #7069.

#25 Updated by Andreas Müller about 1 year ago

The experimental featues "Create taxon hierarchy" and "Clone classification" are missing in e4 context menu for classifications. They were still available in 4.10.

#26 Updated by Andreas Müller about 1 year ago

All other functionality seems to work. So the open issues are #6909#note-22 and #6909#note-25

#27 Updated by Andreas Müller about 1 year ago

One more open issue: if restore is selected in preferences this does not work anymore. The navigator is always opened in collapsed state. This still worked in 4.10 (also restoring name editors does not work anymore but this will be mentioned in the name editor migration ticket)

#28 Updated by Patrick Plitzner about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 100 to 90

Fixed the two mentioned issues.

About restoring: Nothing is restored because we decided to start with a fresh workbench every startup. We can think about re-enabling this after full migration IF we want to. Restoring 10+ name editors was also a performance killer because it has to load the name editor AND expand the tree to the corresponding node.

#29 Updated by Andreas Müller about 1 year ago

#30 Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

The clone assistent throws an NPE. All the rest works.

login : admin
editor version : 4.11.0.201711080902
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 4.7.0.0.201710040000
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
    at org.eclipse.e4.core.internal.di.ConstructorRequestor.execute(ConstructorRequestor.java:52)
    at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:373)
    at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:294)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
    at eu.etaxonomy.taxeditor.navigation.navigator.e4.handler.CloneClassificationHandlerE4.execute(CloneClassificationHandlerE4.java:50)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 36 more
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.ui.section.classification.CloneClassificationWizard.<init>(CloneClassificationWizard.java:53)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at org.eclipse.e4.core.internal.di.ConstructorRequestor.execute(ConstructorRequestor.java:40)
    ... 45 more

#31 Updated by Andreas Müller about 1 year ago

It looks like the automated creation of a new classification if no classification exists yet does not work anymore. I tested on test/test1 (cdm_test1).

In general in this state it looks like it is not possible to create a new classification. Nothing works.

I havn't tested yet if this is a general issue also valid for DBs having a classification already.

#32 Updated by Katja Luther 12 months ago

Andreas Müller wrote:

The clone assistent throws an NPE. All the rest works.

this works now, but the service throws an exception:

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
Failed to execute runnable (java.lang.NullPointerException)
  login : admin
  editor version : 4.13.0.qualifier
  server : localhost (localhost-dev)
  schema version : 4.7.0.0.201710040000
  os : Windows 7 6.1 amd64
  java : 1.8.0_121
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

  Caused by : java.lang.NullPointerException
    at eu.etaxonomy.cdm.api.service.ClassificationServiceImpl.addChildTaxa(ClassificationServiceImpl.java:159)
    at eu.etaxonomy.cdm.api.service.ClassificationServiceImpl.addChildTaxa(ClassificationServiceImpl.java:180)
    at eu.etaxonomy.cdm.api.service.ClassificationServiceImpl.addChildTaxa(ClassificationServiceImpl.java:180)
    at eu.etaxonomy.cdm.api.service.ClassificationServiceImpl.addChildTaxa(ClassificationServiceImpl.java:180)
    at eu.etaxonomy.cdm.api.service.ClassificationServiceImpl.cloneClassification(ClassificationServiceImpl.java:150)
    ....

#33 Updated by Katja Luther 12 months ago

the NPE is fixed now.

#34 Updated by Patrick Plitzner 10 months ago

  • Target version changed from Release 4.11 to Release 4.14

#35 Updated by Patrick Plitzner 10 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Andreas, could you test again it the creation of the first classification still throws an exception? I just tried and it worked.
If this works then please close the ticket because this is the last remaining issue.

#36 Updated by Patrick Plitzner 10 months ago

I just had the problem that hitting "New->Classification" did nothing, not even an exception. I fixed the handler for this. This should work now.

#37 Updated by Andreas Müller 10 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

Creating a new classification works now. Also no exception is thrown anymore.

But in a completely empty database (with no classification) still no default classification is created. But this was the case in earlier versions.

I am not 100% sure if this is an issue that came with e4 or already with remoting.

#38 Updated by Patrick Plitzner 10 months ago

  • Target version changed from Release 4.14 to Release 5.0

moving to current milestone

#39 Updated by Patrick Plitzner 9 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 90 to 100

Andreas Müller wrote:

Creating a new classification works now. Also no exception is thrown anymore.

But in a completely empty database (with no classification) still no default classification is created. But this was the case in earlier versions.

I am not 100% sure if this is an issue that came with e4 or already with remoting.

This problem is not related to this issue, created a new one (#7306) and closing this.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)