Project

General

Profile

Actions

task #4911

closed

improve performance of distributionInfoFor service

Added by Andreas Kohlbecker almost 9 years ago. Updated 24 days ago.

Status:
Duplicate
Priority:
Highest
Category:
cdmlib
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal


Related issues

Related to EDIT - feature request #9271: Improve E+M dataportal performanceIn ProgressAndreas Müller

Actions
Related to EDIT - task #10222: Use DTOs for portal taxon page - first implementation for E+MClosedAndreas Müller

Actions
Related to EDIT - feature request #10322: Use DTOs for portal taxon page (cont.)In ProgressAndreas Müller

Actions
Related to EDIT - feature request #10474: Improve occurrence loading for taxon pageNewAndreas Müller

Actions
Is duplicate of EDIT - task #9524: Use non-model objects in database queries for getDistributionInfoFor In ProgressAndreas Müller

Actions
Actions #1

Updated by Andreas Kohlbecker almost 9 years ago

  • Status changed from New to In Progress
Actions #2

Updated by Andreas Kohlbecker almost 9 years ago

improvements implemented:

  • r23851, r23844, r23840,

See also the related improvements made at the AdvancedBeanInitializer #4919#note-1

Actions #3

Updated by Andreas Kohlbecker almost 9 years ago

  • Target version changed from cdmlib RELEASE 3.5.2 to Release 3.7

this was not closed in Release 3.5.2

Applying another improvement which is only in git at the moment: d798947 (UPDATE: pushed and now also in svn as r24421) - avoiding second distribution filtering when creating the DistributionServiceRequestParameterString

Actions #4

Updated by Andreas Müller almost 9 years ago

  • Target version changed from Release 3.7 to Release 3.8
Actions #5

Updated by Andreas Kohlbecker over 8 years ago

  • Target version deleted (Release 3.8)

moving unresolved tickets to next milestone after release of 3.8.0

Actions #6

Updated by Andreas Müller over 8 years ago

  • Target version deleted (Release 3.12)
Actions #7

Updated by Andreas Müller almost 8 years ago

  • Target version changed from Release 4.0 to Release 4.1
Actions #8

Updated by Andreas Müller almost 8 years ago

  • Target version changed from Release 4.1 to Release 4.2
Actions #9

Updated by Andreas Müller almost 8 years ago

  • Target version changed from Release 4.2 to Release 4.3
Actions #10

Updated by Andreas Müller over 7 years ago

  • Target version changed from Release 4.3 to Release 4.4
Actions #11

Updated by Andreas Müller over 7 years ago

  • Target version changed from Release 4.4 to Release 4.5
Actions #12

Updated by Andreas Müller over 7 years ago

  • Target version changed from Release 4.5 to Release 4.6
Actions #13

Updated by Andreas Müller about 7 years ago

  • Target version changed from Release 4.6 to Release 4.7
Actions #14

Updated by Andreas Müller almost 7 years ago

  • Description updated (diff)
  • Private changed from Yes to No
Actions #15

Updated by Andreas Kohlbecker almost 7 years ago

  • Target version changed from Release 4.7 to Release 4.8
Actions #16

Updated by Andreas Müller almost 7 years ago

  • Target version changed from Release 4.8 to Release 4.9
Actions #17

Updated by Andreas Müller almost 7 years ago

  • Target version changed from Release 4.9 to Release 4.10
Actions #18

Updated by Andreas Kohlbecker over 6 years ago

  • Target version changed from Release 4.10 to Release 4.11
Actions #19

Updated by Andreas Müller over 6 years ago

  • Target version changed from Release 4.11 to Release 4.12
Actions #20

Updated by Andreas Müller over 6 years ago

  • Target version changed from Release 4.12 to Release 4.13
Actions #21

Updated by Andreas Müller about 6 years ago

  • Target version changed from Release 4.13 to Release 4.14
Actions #22

Updated by Andreas Müller about 6 years ago

  • Target version changed from Release 4.14 to Release 5.0
Actions #23

Updated by Andreas Kohlbecker almost 6 years ago

  • Target version changed from Release 5.0 to Release 5.1
Actions #24

Updated by Andreas Kohlbecker almost 6 years ago

  • Tags changed from performance to performance, euro+med
  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • Target version changed from Release 5.1 to Release 5.2

Hi Andreas, I am passing this issue to you, since you are in the euro+med sprint, ähhh, long-distance run!

Actions #25

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 5.2 to Release 5.3
Actions #26

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 5.3 to Release 5.5
Actions #27

Updated by Andreas Müller about 5 years ago

  • Target version changed from Release 5.5 to Release 5.6
Actions #28

Updated by Andreas Müller about 5 years ago

  • Priority changed from New to Highest
  • Target version changed from Release 5.6 to Reviewed Next Major Release
Actions #29

Updated by Andreas Müller over 3 years ago

Actions #30

Updated by Andreas Müller about 2 years ago

  • Target version changed from Reviewed Next Major Release to Release 5.44
Actions #31

Updated by Andreas Müller about 2 years ago

  • Related to task #9524: Use non-model objects in database queries for getDistributionInfoFor added
Actions #32

Updated by Andreas Müller 11 months ago

  • Related to task #10222: Use DTOs for portal taxon page - first implementation for E+M added
Actions #33

Updated by Andreas Müller 11 months ago

Actions #34

Updated by Andreas Müller 2 months ago

  • Target version changed from Release 5.44 to Release 5.43

The remaining issues here are probably mostly duplicating #9524.

Actions #35

Updated by Andreas Müller 2 months ago

Actions #36

Updated by Andreas Müller 29 days ago

  • Related to deleted (task #9524: Use non-model objects in database queries for getDistributionInfoFor )
Actions #37

Updated by Andreas Müller 29 days ago

  • Is duplicate of task #9524: Use non-model objects in database queries for getDistributionInfoFor added
Actions #38

Updated by Andreas Müller 29 days ago

  • Status changed from In Progress to Duplicate
  • Target version deleted (Release 5.43)
Actions #39

Updated by Andreas Müller 24 days ago

  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF