Project

General

Profile

bug #9838

Loading of details of categorical and quantitative data takes very long

Added by Katja Luther 29 days ago. Updated 27 days ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
11/01/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

The loading of the details view of categorical data or quantitative data takes really long and the loaded objects in default cache (term cache) increases extremely (up to 9000-10000)


Related issues

Related to Edit - bug #8243: Cdm Cache uses a lot of disk space In Progress 04/16/2019

Associated revisions

Revision aae4cb3d (diff)
Added by Katja Luther about 1 month ago

fix term caching for term type and avoid doubled call of populate terms

Revision d7ad25d9 (diff)
Added by Katja Luther 29 days ago

ref #9838: change order of ui element creation and setting entity in collection elements

Revision be9359f3 (diff)
Added by Katja Luther 28 days ago

ref #9838: change order of ui element creation and setting entity in collection elements - continue

History

#1 Updated by Katja Luther 29 days ago

The long time loading was produced by a mistake in term manager.

The extreme number of loaded objects is caused by the initialization of the state combo box with term type state. This should be filled only with the used states.

#2 Updated by Andreas Müller 29 days ago

  • Target version changed from Unassigned CDM tickets to Release 5.28

This is at least partly handled in 5.28 as far as I can see. If needed can we split ticket?

How far is it solved?

#3 Updated by Andreas Müller 29 days ago

  • Description updated (diff)

#4 Updated by Katja Luther 29 days ago

  • Status changed from New to Resolved

Katja Luther wrote:

The long time loading was produced by a mistake in term manager.

The extreme number of loaded objects is caused by the initialization of the state combo box with term type state. This should be filled only with the used states.

Now the entity is set during initialization before the elements are created, this avoids the creation of a combo box with all available states.

#5 Updated by Andreas Müller 28 days ago

#6 Updated by Andreas Müller 28 days ago

#7 Updated by Andreas Müller 28 days ago

  • Related to bug #8243: Cdm Cache uses a lot of disk space added

#8 Updated by Katja Luther 28 days ago

  • Assignee changed from Katja Luther to Andreas Müller

Tested all collection elements in nightly and could not find any problems. Please have another look and review.

#9 Updated by Andreas Müller 27 days ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

I think we can close this ticket.

Loading categorical data facts is much faster now and only a view objects are loaded to the default cache.

#10 Updated by Andreas Müller 27 days ago

  • Assignee changed from Andreas Müller to Katja Luther

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)