Project

General

Profile

Actions

bug #8243

open

Cdm Cache uses a lot of disk space

Added by Patrick Plitzner almost 4 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

60%

Estimated time:
Severity:
normal
Found in Version:

Description

Recently Tilo experienced a sudden system freeze when his main partition went from ~3GB free disk space to 100% full in seconds.
We found out that it was the CDM cache file that took +2,5GB disk space.

This is not a problem per se but the users should be informed about the cache and it should be reflected in the specs.

He was working in the Additivity context with the FeatureTreeEditor, TermEditor, DatasetEditor and the CharacterMatrix.


Files

picture710-1.png (7.16 KB) picture710-1.png Patrick Plitzner, 04/16/2019 11:48 AM

Related issues

Related to EDIT - bug #9838: Loading of details of categorical and quantitative data takes very long ClosedKatja Luther

Actions
Related to EDIT - task #9842: Improve performance for loading DDS (RowWrapperDTO)In ProgressKatja Luther

Actions
Actions #1

Updated by Patrick Plitzner over 3 years ago

  • Description updated (diff)
Actions #2

Updated by Andreas Kohlbecker about 3 years ago

The description states that the increase of diskspace usage happened in seconds "free disk space to 100% full in seconds."

If this is true it should be quite easy to pin down the cause for this cache growth.

Actions #3

Updated by Andreas Kohlbecker about 3 years ago

  • Tags set to performance
Actions #4

Updated by Andreas Kohlbecker about 3 years ago

  • Tags changed from performance to performance, ehcache
Actions #5

Updated by Katja Luther over 1 year ago

  • Tags changed from performance, ehcache to performance, ehcache, matrix

We should have a look on this with the new implementation because the matrix worked with descriptions and descriptiveDataset as cdm objects and now everything comes as dtos.

Actions #6

Updated by Andreas Müller over 1 year ago

  • Related to bug #9838: Loading of details of categorical and quantitative data takes very long added
Actions #7

Updated by Andreas Müller over 1 year ago

Katja Luther wrote:

We should have a look on this with the new implementation because the matrix worked with descriptions and descriptiveDataset as cdm objects and now everything comes as dtos.

As this was not only a problem of the matrix the new DTOs for the matrix may reduce the problem but not fully resolve it.
A further (or maybe even final) step could be the solving of #9838 which is seems to be partly (of fully) a duplicate for this ticket).

Actions #8

Updated by Andreas Müller over 1 year ago

  • Status changed from New to In Progress
Actions #9

Updated by Andreas Müller 11 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Andreas Müller to Katja Luther
  • Target version changed from Unassigned CDM tickets to Release 5.37
  • % Done changed from 0 to 60

Please review if this is maybe fully fixed already or will be fixed after fully solving #9842.

Please pass to me after review.

Actions #10

Updated by Andreas Müller 11 months ago

  • Related to task #9842: Improve performance for loading DDS (RowWrapperDTO) added
Actions

Also available in: Atom PDF