Project

General

Profile

feature request #9647

After deduplication the remaining record should get the focus in bulk editor

Added by Andreas Müller 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
06/03/2021
Due date:
% Done:

100%

Severity:
normal

Description

this is helpful when working on longer lists because after save the list jumps to the beginning otherwise

Associated revisions

Revision 5924653e (diff)
Added by Katja Luther 4 months ago

fix #9647: set focus to deduplication target

History

#1 Updated by Katja Luther 4 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Katja Luther 4 months ago

  • Assignee changed from Katja Luther to Andreas Müller

This should be fixed, please review.

#3 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

This generally works as expected but in 20-30% of the cases after setting the focus it got lost immediately again though I did not press anything else after using the deduplication menu item.
Also the details view gets empty then so it looks like I clicked elsewhere.

Can you reproduce this and maybe fix it?

(maybe it is only my mouse which behaves strange sometimes, but something like this I did not recognize yet but here it happens quite often)

#4 Updated by Katja Luther 4 months ago

  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

This generally works as expected but in 20-30% of the cases after setting the focus it got lost immediately again though I did not press anything else after using the deduplication menu item.
Also the details view gets empty then so it looks like I clicked elsewhere.

Can you reproduce this and maybe fix it?

(maybe it is only my mouse which behaves strange sometimes, but something like this I did not recognize yet but here it happens quite often)

I tried several times, but never got this behaviour. Maybe we open a new ticket for the case it happens again for other users or for you with another mouse?

#5 Updated by Andreas Müller 4 months ago

  • Status changed from Feedback to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

I also could not reproduce this anymore. So I think we can close this ticket and watch the deduplication in production.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)