Project

General

Profile

Actions

bug #8521

closed

User details view: Change password button accessible for ROLE_USER_MANAGER

Added by Andreas Kohlbecker over 3 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
New
Assignee:
Category:
taxeditor
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Severity:
normal
Found in Version:

Description

The "Change password button" must also be accessible for the Role ROLE_USER_MANAGER not only for Admin


Related issues

Is duplicate of EDIT - bug #8925: Users with ROLE_USER_MANAGER must be able to change any user passwordClosedKatja Luther

Actions
Actions #1

Updated by Andreas Müller over 3 years ago

  • Assignee changed from Andreas Müller to Katja Luther

I think not only the change password button but generally all User related issues need to be accessible. Can you please add a link to the definition what exact rights ROLE_USER_MANAGER has?

Actions #2

Updated by Andreas Kohlbecker over 3 years ago

according to what I wrote in https://dev.e-taxonomy.eu/redmine/projects/edit/wiki/CdmAuthorisationAndAccessControl the role ROLE_USER_MANAGER is defined as "(permission to modify User, Group, GrantedAuthority)"

Actions #3

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
  • Status changed from New to Feedback
  • Target version changed from Unassigned CDM tickets to Release 5.25

This to me seems to be a duplicate for #8925. If this is true, please close the ticket as duplicate and remove target version

Actions #4

Updated by Andreas Müller almost 2 years ago

  • Is duplicate of bug #8925: Users with ROLE_USER_MANAGER must be able to change any user password added
Actions #5

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.25 to Release 5.23
Actions #6

Updated by Katja Luther over 1 year ago

  • Status changed from Feedback to Duplicate
  • Target version deleted (Release 5.23)

this is handled with #8925

Actions

Also available in: Atom PDF