Project

General

Profile

bug #8316

Endless loop when editing name in source of distribution

Added by Katja Luther 26 days ago. Updated 20 days ago.

Status:
Feedback
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
05/29/2019
Due date:
% Done:

50%

Severity:
normal
Found in Version:

Description

mail AM:

also bei nameUsedInSource bekomme ich das weiterhin regelmäßig, spätestens beim 2. oder 3. Mal. Kannst du dir das vielleicht nochmal anschauen mit E+M Daten und v.a. auch das Limit wieder hinzufügen? Es reicht ja, wenn wir es einigermaßen hoch ansetzen z.B. 5000 DS, oder so. Hoffe ich jedenfalls. Vielleicht ist das Problem ja auch ein anderes.

In diesem Zusammenhang hab ich gerade im Logfile folgendes Problem gefunden, was wohl sehr häufig auftrat. Daher auch Patrick in cc.
Es könnte mit dem Problem im Zusammenhang stehen.


!ENTRY org.eclipse.equinox.event 4 0 2019-05-28 16:02:40.960
!MESSAGE Exception while dispatching event org.osgi.service.event.Event [topic=org/eclipse/e4/ui/renderer/requestEnablementUpdate] {org.eclipse.e4.data=ALL} to handler org.eclipse.e4.ui.internal.di.UIEventObjectSupplier$UIEventHandler@23d5e304
!STACK 0
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.StackOverflowError)
               at org.eclipse.swt.SWT.error(SWT.java:4533)
               at org.eclipse.swt.SWT.error(SWT.java:4448)
               at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:255)
               at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:145)
               at org.eclipse.swt.widgets.Display.syncExec(Display.java:4821)
               at org.eclipse.e4.ui.internal.workbench.swt.E4Application$1.syncExec(E4Application.java:211)
               at org.eclipse.e4.ui.internal.di.UIEventObjectSupplier$UIEventHandler.handleEvent(UIEventObjectSupplier.java:53)
               at org.eclipse.equinox.internal.event.EventHandlerWrapper.handleEvent(EventHandlerWrapper.java:201)
               at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:197)
               at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:1)
               at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
               at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Caused by: java.lang.StackOverflowError
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)
               at eu.etaxonomy.taxeditor.workbench.WorkbenchUtility.findSavablePart(WorkbenchUtility.java:81)

The problem was the handling of the selected taxonname in the factual data view. Now the factual data view ignores the selection if the input of the detailsview is a descriptionelementbase

Associated revisions

Revision 9b4eaf57 (diff)
Added by Katja Luther 26 days ago

fix #8316: fix endless loop when editing name in source

Revision 4765e3e9 (diff)
Added by Katja Luther 26 days ago

fix #8316: fix endless loop when editing name in source

History

#1 Updated by Katja Luther 26 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Katja Luther 26 days ago

  • Description updated (diff)

#3 Updated by Katja Luther 26 days ago

  • Assignee changed from Katja Luther to Andreas Müller

please review

#4 Updated by Andreas Müller 21 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

The endless loop does now not show up anymore.
But after closing the dialog the supplemental data view does not get the focus on the newly selected object. It still shows information on the old object.

#5 Updated by Andreas Müller 20 days ago

Please also check if this is related to #8283#note-4

#6 Updated by Katja Luther 20 days ago

Andreas Müller wrote:

Please also check if this is related to #8283#note-4

this seems to be an older problem, testing on stable the newly selected element is not shown in the supplemental data view.

#7 Updated by Katja Luther 20 days ago

  • Target version changed from Release 5.8 to Release 5.7

this issue is cherry-picked to hotfix5.7.3, therefore change the milestone to 5.7

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)