Project

General

Profile

feature request #8283

Allow adding media to terms in taxeditor

Added by Patrick Plitzner 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
05/17/2019
Due date:
% Done:

100%

Severity:
normal

Description

This could be done in the details view for example


Related issues

Related to Edit - bug #8367: Advanced media view is not available for term media New 07/15/2019
Related to Edit - bug #8129: Load images asynchronously in media details view Feedback 02/22/2019
Related to Edit - bug #8380: Unsaved media gets lost in details view New 07/17/2019

Associated revisions

Revision d4184136 (diff)
Added by Patrick Plitzner 5 months ago

fix #8283 Add media section to term details view

Revision 909326e9 (diff)
Added by Patrick Plitzner 4 months ago

fix #8283 Add media section to term details view

Revision 8b2071a3 (diff)
Added by Patrick Plitzner 3 months ago

ref #8283 Add media uuids to term dto

  • fix HQL response handling for left outer joins

Revision 7fa459c8 (diff)
Added by Patrick Plitzner 3 months ago

ref #8283 Fix possible NPE when no media is attached to term

History

#1 Updated by Patrick Plitzner 5 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Patrick Plitzner 5 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

#3 Updated by Andreas Müller 4 months ago

should we add to HFX?

#4 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

The data may got lost the following way.

  • Open term
  • add media
  • open referencing objects view (-> Details View is empty which is anyway not wanted)
  • go back to term => media is not shown anymore

#5 Updated by Andreas Müller 4 months ago

With the current implementation it is not possible to switch between advanced and simple view but sometimes it is essential to add >1 representations to a media.
In general it is a bit critical to have media together with other data in the details view, because the media part can become large and also because (until now) we do not yet have asynchronous loading for media which makes everything very slow once media are selected.

I can see that we can not use the media view with the current model as it requires a DescriptionBase, but maybe we can a switch in the media view which decides if it should show a media gallery or a simple media list depending on the selected parent.
In general for UX I think it is better if media are always handled the same way (in media view).
These thoughts are only for discussion, I am not sure what the best solution really is.

#6 Updated by Andreas Müller 4 months ago

Katja, can you please cherry pick however. The above problems are minor issues and the media are not used much anyway but urgently needed for additivity.

#7 Updated by Andreas Müller 4 months ago

Andreas Müller wrote:

The data may got lost the following way.

  • Open term
  • add media
  • open referencing objects view (-> Details View is empty which is anyway not wanted)
  • go back to term => media is not shown anymore

Is this maybe related to new implementation in #8316?

#8 Updated by Katja Luther 4 months ago

cherry-picked to hotfix/5.7.3

#9 Updated by Katja Luther 4 months ago

  • Target version changed from Release 5.8 to Release 5.7

#10 Updated by Patrick Plitzner 4 months ago

  • Status changed from Feedback to Resolved

#11 Updated by Andreas Müller 4 months ago

  • Target version changed from Release 5.7 to Release 5.8

PP just added some more code. Could you check if this also needs to be cherry picked.
Revert milestone as not sure if this is already fully implemented.

#12 Updated by Andreas Müller 4 months ago

Or was this code only from the cherry picking? A bit confusing.

#13 Updated by Katja Luther 4 months ago

Andreas Müller wrote:

Or was this code only from the cherry picking? A bit confusing.

Yes this seems to be the cherry-pick.

#14 Updated by Katja Luther 4 months ago

  • Status changed from Resolved to Feedback

#15 Updated by Patrick Plitzner 4 months ago

Andreas Müller wrote:

PP just added some more code. Could you check if this also needs to be cherry picked.
Revert milestone as not sure if this is already fully implemented.

Interesting to see that interaction of cherry-picking and redmine. Not only is my name shown but also the 'fix' set the status back to resolved again.

#16 Updated by Patrick Plitzner 4 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 80

Andreas Müller wrote:

The data may got lost the following way.

  • Open term
  • add media
  • open referencing objects view (-> Details View is empty which is anyway not wanted)
  • go back to term => media is not shown anymore

This does not happen anymore for me. Andreas, can you also try one more time and then we close this ticket and open a new one for the ideas mentioned in #8283#note-5

#17 Updated by Katja Luther 3 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Andreas Müller to Patrick Plitzner

this seems to work now. (the details view is still empty when changing to referencing objects view, but adding the media is fixed)

#18 Updated by Patrick Plitzner 3 months ago

  • Related to bug #8367: Advanced media view is not available for term media added

#19 Updated by Patrick Plitzner 3 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

#20 Updated by Patrick Plitzner 3 months ago

Added #8367 for remaining issues and discussion

All the rest should be implemented and functional now

#21 Updated by Patrick Plitzner 3 months ago

  • Related to bug #8129: Load images asynchronously in media details view added

#22 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Feedback

Patrick Plitzner wrote:

Andreas Müller wrote:

The data may got lost the following way.

  • Open term
  • add media
  • open referencing objects view (-> Details View is empty which is anyway not wanted)
  • go back to term => media is not shown anymore

This does not happen anymore for me. Andreas, can you also try one more time and then we close this ticket and open a new one for the ideas mentioned in #8283#note-5

It still happens somehow but not so easy to reproduce.
I could reproduce this way:

On rem_conf_am open features.

  1. Got to Vocabulary "Untitled" and open term "test2".
  2. Open a media by simply clicking the "+" button
  3. Open "User Vocabulary"
  4. Click on first term (Citation Chromosome Numbers)
  5. Click back on test2 Repeat 4. and 5. a couple of times

After a while the media is not shown anymore.
Also there is another issue that sometimes when peforming step 5 the details view does not switch to "test2". Which is probably another issue and needs a new ticket.

#23 Updated by Andreas Müller 3 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

#24 Updated by Patrick Plitzner 3 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Andreas Müller wrote:

Patrick Plitzner wrote:

Andreas Müller wrote:

The data may got lost the following way.

  • Open term
  • add media
  • open referencing objects view (-> Details View is empty which is anyway not wanted)
  • go back to term => media is not shown anymore

This does not happen anymore for me. Andreas, can you also try one more time and then we close this ticket and open a new one for the ideas mentioned in #8283#note-5

It still happens somehow but not so easy to reproduce.
I could reproduce this way:

On rem_conf_am open features.

  1. Got to Vocabulary "Untitled" and open term "test2".
  2. Open a media by simply clicking the "+" button
  3. Open "User Vocabulary"
  4. Click on first term (Citation Chromosome Numbers)
  5. Click back on test2 Repeat 4. and 5. a couple of times

After a while the media is not shown anymore.
Also there is another issue that sometimes when peforming step 5 the details view does not switch to "test2". Which is probably another issue and needs a new ticket.

I tried these steps on rem_conf_am about 20 times and could not reproduce this behavior. This issue in general never happens when the new media is saved, right? I would say that this is a very rare corner case then and we may close this ticket.

#25 Updated by Patrick Plitzner 3 months ago

Just when I wrote the last comment it happened. But still, it is very unlikely that this will happen to a user. We may open another ticket to investigate why this can happen at all. I suspect that it's either a problem with the widget management or the term cache.

I tried also with saving the term and then it did not occur anymore.

#26 Updated by Andreas Müller 3 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner
  • % Done changed from 80 to 90

Patrick Plitzner wrote:

Just when I wrote the last comment it happened. But still, it is very unlikely that this will happen to a user. We may open another ticket to investigate why this can happen at all. I suspect that it's either a problem with the widget management or the term cache.

I tried also with saving the term and then it did not occur anymore.

Why do you think it is very unlikely to happen? It happened to me several times, though of course adding media to terms in general is not really core functionality - and save in general works so only returning to the term creates a problem.
But opening a ticket and close this one is ok. Anyway we should handle media via Media view soon so maybe the problem will not occurr this way anyway so it is not worth speding much time on it.

#27 Updated by Patrick Plitzner 3 months ago

  • Related to bug #8380: Unsaved media gets lost in details view added

#28 Updated by Patrick Plitzner 3 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 90 to 100

Created new ticket for remaining issues -> #8380

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)