Project

General

Profile

task #8166

Adapt dataportal to term structure changes

Added by Andreas Kohlbecker 6 months ago. Updated 11 days ago.

Status:
Closed
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
03/06/2019
Due date:
% Done:

100%

Severity:
normal

Description

the dataportal needs to be adapted to the changes applied in the context of #6794


Related issues

Related to Edit - feature request #6794: Improve term structure In Progress 07/09/2017

Associated revisions

Revision b011743c (diff)
Added by Andreas Kohlbecker 6 months ago

ref #8166 adapting to change in FeatureNode property 'feature' becomes 'term'

Revision c5a114a8 (diff)
Added by Andreas Kohlbecker 6 months ago

ref #8166 adapting to change in FeatureNode property 'feature' becomes 'term' - 2

Revision 9dddc68a (diff)
Added by Andreas Kohlbecker 22 days ago

ref #8166 adapting dataportal to TermTree novelties: using new term tree controller endpoints

Revision 9725f08e (diff)
Added by Andreas Kohlbecker 21 days ago

ref #8166 using ternmType filter to restrict to feature trees only

History

#1 Updated by Andreas Kohlbecker 6 months ago

#2 Updated by Andreas Müller 6 months ago

  • Target version changed from CDM UML 5.0 to CDM UML 5.5

#3 Updated by Andreas Müller 4 months ago

  • Target version changed from CDM UML 5.5 to CDM UML 5.10

#4 Updated by Andreas Kohlbecker 29 days ago

  • Copied to task #8405: Adapt cdm-vaadin to term structure changes added

#5 Updated by Andreas Müller 29 days ago

  • Priority changed from New to Highest
  • Target version changed from CDM UML 5.10 to Release 5.9

Are there any changes needed? Currently it looks like most things work (except maybe for the Specimen page, is this caused by the changes?).

#6 Updated by Andreas Kohlbecker 28 days ago

  • Status changed from New to Worksforme

Andreas Müller wrote:

Are there any changes needed? Currently it looks like most things work (except maybe for the Specimen page, is this caused by the changes?).

The Specimens pages already are broken in the Production portal, so this has nothing to do with the term structure changes.

I think that there are no changes required in the portal to adapt it to the changes-

#7 Updated by Andreas Kohlbecker 28 days ago

  • Status changed from Worksforme to New

I am reopening this issue since the data portal code even if being fully functional might need to be adapted to the modified naming of classes, etc.:

  • FeatureTree -> TermTree

#8 Updated by Andreas Müller 28 days ago

Yes, we should at least do a string search for "FeatureTree". Also a string search on "FeatureNode".

#9 Updated by Andreas Kohlbecker 28 days ago

  • Copied to deleted (task #8405: Adapt cdm-vaadin to term structure changes)

#10 Updated by Andreas Kohlbecker 21 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

check taxon profile settings in a couple of test portals:

  • Cichorieae
  • Corvidea
  • Palmweb
  • Cyprus

#11 Updated by Andreas Kohlbecker 11 days ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

profile settings are working in the above test portals (palmweb has not been tested, since there is no cdm test instance running)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)