Project

General

Profile

Actions

bug #7913

closed

Remove authorship from IJournal and IPrintSeries

Added by Andreas Müller about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Priority14
Assignee:
Category:
cdm
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

Authorship should be removed from journals and print series. Even if they share a common author the authorship should be stored in the underlying article, book, ... to avoid confusion and inconsistency.
Existing authorship may create problems when finding duplicates via matching algorithms.


Related issues

Related to EDIT - bug #7223: ReferenceEditor: disable fields depending on the Reference type ClosedAndreas Kohlbecker

Actions
Related to EDIT - bug #7915: Remove date published from journals and print seriesClosedKatja Luther

Actions
Related to EDIT - bug #7828: Remove date published from journals in E+MIn ProgressAndreas Müller

Actions
Related to EDIT - task #7918: Revision of reference type specific propertiesClosedAndreas Müller

Actions
Related to EDIT - bug #7930: Remove DOI from journals, print series and person communicationsClosedKatja Luther

Actions
Has duplicate EDIT - bug #7839: IJournal should not have author, date published etc.DuplicateAndreas Müller

Actions
Actions #1

Updated by Andreas Müller about 4 years ago

  • Related to bug #7223: ReferenceEditor: disable fields depending on the Reference type added
Actions #2

Updated by Andreas Müller about 4 years ago

  • Is duplicate of bug #7839: IJournal should not have author, date published etc. added
Actions #3

Updated by Andreas Müller about 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50
Actions #4

Updated by Andreas Müller about 4 years ago

  • Status changed from Resolved to Duplicate
Actions #5

Updated by Andreas Müller about 4 years ago

  • Status changed from Duplicate to Resolved
  • Assignee changed from Andreas Müller to Katja Luther
Actions #6

Updated by Andreas Müller about 4 years ago

  • Is duplicate of deleted (bug #7839: IJournal should not have author, date published etc.)
Actions #7

Updated by Andreas Müller about 4 years ago

  • Has duplicate bug #7839: IJournal should not have author, date published etc. added
Actions #8

Updated by Andreas Müller about 4 years ago

  • Related to bug #7915: Remove date published from journals and print series added
Actions #9

Updated by Andreas Müller about 4 years ago

  • Related to bug #7828: Remove date published from journals in E+M added
Actions #10

Updated by Andreas Kohlbecker about 4 years ago

  • Related to task #7918: Revision of reference type specific properties added
Actions #11

Updated by Andreas Müller about 4 years ago

  • Related to bug #7930: Remove DOI from journals, print series and person communications added
Actions #12

Updated by Katja Luther about 4 years ago

this is also implemented in taxeditor. Please review.

Actions #13

Updated by Katja Luther about 4 years ago

  • Assignee changed from Katja Luther to Andreas Müller
Actions #14

Updated by Andreas Müller about 4 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • Priority changed from New to Priority14
  • % Done changed from 50 to 100

works as expected

Actions

Also available in: Atom PDF