Project

General

Profile

bug #7850

Further problems with term editor

Added by Andreas Müller 5 months ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
10/23/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

After fixing LIE in #7827 there are further issues with term editor.

  • Sometimes when opening or working with term editor during EagerLoading an not server not available comes (though the server responds but may work load is to much) (#7827#note-8)
  • Moving e.g. a NamedArea somewhere else (not same parent) does not remove it from the old position in tree view, when trying to save a multiple representations exception shows up

====

Copy from #7827#note-6: The Termeditor has to be refactored as still all term operation are done on the editor side and should be moved into the cdmlib service layer.

picture357-1.png View (4.88 KB) Andreas Müller, 10/24/2018 06:19 PM


Related issues

Related to Edit - bug #7851: [DISCUSS] How to handle connection issues during tasks New 10/23/2018
Duplicates Edit - feature request #7887: Use DTOs in term editor Closed 11/05/2018
Copied from Edit - bug #7827: LazyInitializationException when saving term editor (named areas) Closed 10/16/2018

Associated revisions

Revision 3c6e3303 (diff)
Added by Patrick Plitzner 5 months ago

ref #7827 Fix term/distribution content provider

  • Remove accidental merging of "includes" set into "eneralizationOf" set

Revision 0bfb1b18 (diff)
Added by Patrick Plitzner 5 months ago

ref #7827 Also remove generalizationOf if term is moved

Revision 1f5b408c (diff)
Added by Patrick Plitzner 5 months ago

ref #7827 Code cleanup

Revision 89cdb669 (diff)
Added by Patrick Plitzner 5 months ago

ref #7850 Refresh vocabulary when moving terms

History

#1 Updated by Andreas Müller 5 months ago

  • Description updated (diff)

#2 Updated by Andreas Müller 5 months ago

  • Description updated (diff)

#3 Updated by Andreas Müller 5 months ago

  • % Done changed from 0 to 20

Added commits from #727 related to this ticket to the ticket.

#4 Updated by Andreas Müller 5 months ago

AM:

Gibts für die MultiRep bzw. das Term Verschiebeproblem schon ein Ticket? Wenn ich ein Area verschiebe wird er derzeit an der alten Stelle nicht im Baum entfernt. Wenn ich dann save kommt es regelmäßig zu MultiRep Exception. Das müsste da rein. Getestet mit test.E+M

(this happened after the above commits were pushed and nightly were build)

#5 Updated by Andreas Müller 5 months ago

  • Related to bug #7851: [DISCUSS] How to handle connection issues during tasks added

#6 Updated by Andreas Müller 5 months ago

  • Copied from bug #7827: LazyInitializationException when saving term editor (named areas) added

#7 Updated by Patrick Plitzner 5 months ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 20 to 50

#8 Updated by Andreas Müller 5 months ago

still not yet fully fixed

#9 Updated by Andreas Müller 5 months ago

Next time when opening term editor Belgium was completely gone, though in the DB everything was ok (vocabulary, parent_id and orderindex correctly set).

After restarting the TaxEditor everything at the correct place again.

#10 Updated by Andreas Müller 5 months ago

The problem always occurs during the second move. Moving first time works correctly.

#11 Updated by Andreas Müller 5 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

Maybe one problem is the order index. After moving the area gets the highest order index though it is placed as child somewhere in the middle (child of Great Britain in my test).
By the way this time I could save the data so the area was displayed 2x.

Maybe we should stop this here.
Term structure urgently needs to be refactored and will be done soon. We should fix the hierarchie issues of the term editor then (maybe they are automatically fixed then)

#12 Updated by Patrick Plitzner 4 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

@Andreas M.: Can you please check if this is still an issue?

#13 Updated by Andreas Müller 4 months ago

  • Target version changed from Release 5.4 to Release 5.5

#14 Updated by Andreas Müller 2 months ago

#15 Updated by Andreas Müller 2 months ago

Andreas Müller wrote:

Copy from #7827#note-6: The Termeditor has to be refactored as still all term operation are done on the editor side and should be moved into the cdmlib service layer.

I think this is better handled in #7887. However, it is not recommended to run these operations only on server side as this requires immedate save which is against the general TaxEditor philosophy.

#16 Updated by Andreas Müller 2 months ago

  • Status changed from Resolved to Duplicate
  • Assignee changed from Andreas Müller to Patrick Plitzner

I think these issues have all been fixed by #7887 so I make this ticket a duplicate of #7887. Please change if I am not correct.

#17 Updated by Andreas Müller 2 months ago

#18 Updated by Andreas Müller 2 months ago

#19 Updated by Andreas Müller 2 months ago

  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)