Project

General

Profile

Actions

feature request #3533

closed

Prefill nomenclatural reference information if possible

Added by Andreas Müller over 9 years ago. Updated 11 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
03/07/2022
Due date:
03/14/2022
% Done:

100%

Estimated time:
Severity:
normal

Description

When entering a nomenclatural reference for a taxon name which already has a defined author we may want to prefilter the list of available references to those having the same author. Also the type of the reference may act as an additional filter.

As this is a feature of the old Berlin Model editor it is a requirement for Euro+Med migration. Therefore I chose this milestone.

related to #3983 (easier reference selection - Euro+Med sourceID [DISCUSS]) and #3984

probably duplicate for #2055


Related issues

Related to EDIT - task #2055: Improve Article creation for nomenclatural referencesRejectedKatja Luther

Actions
Related to EDIT - feature request #3984: Easier reference selection - recently used referencesClosedKatja Luther

Actions
Has duplicate EDIT - feature request #3983: [DISCUSS] Easier reference selection - Euro+Med sourceIDDuplicateKatja Luther

Actions
Actions #1

Updated by Andreas Müller about 9 years ago

related to and possibly a duplicate of #3983 (easier referenz selection - Euro+Med sourceID [DISCUSS])

It is related but not a duplicate,. #3983 is about sourceId, this ticket is about prefilling with nomenclatural author information. Also closely related is #3984.

Actions #2

Updated by Andreas Kohlbecker over 8 years ago

  • Keywords set to Euro+Med,Migration
Actions #3

Updated by Katja Luther almost 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50
Actions #4

Updated by Katja Luther almost 6 years ago

  • Description updated (diff)
  • Assignee changed from Andreas Kohlbecker to Andreas Müller
  • Target version changed from Euro+Med Migration to Release 4.7
Actions #5

Updated by Andreas Müller almost 6 years ago

  • Private changed from Yes to No
Actions #6

Updated by Andreas Müller over 5 years ago

Actions #7

Updated by Andreas Müller over 5 years ago

  • Related to task #2055: Improve Article creation for nomenclatural references added
Actions #8

Updated by Andreas Müller over 5 years ago

  • Description updated (diff)
Actions #9

Updated by Andreas Müller over 5 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 80

Seems to work, but maybe also Eckhard should have a look as it is an E+M requirement.

Also the type of the reference may act as an additional filter. Seems not to be implemented yet, but maybe we should open a new ticket for it as this is not strictly related. Semantics might be that all reference types that do not implement INomenclaturalReference should be filtered (all types except Generic, Book, Book Section, Article and Section)

Actions #10

Updated by Katja Luther over 5 years ago

Hallo Katja,

diese Funktion sollte nur diejenigen Referenzen liefern, bei denen Greuter der alleinige Autor ist. Im Screenshot unten ist er einer von mehreren Team-Autoren. Das ergibt keinen Sinn, denn dann müssten diese Autoren schon im Autorenfeld auftauchen. Oder aber die Referenz sollte z.B. lauten "Greuter in Greuter & al." und müsste auch so angezeigt werden.

Schönen Gruß Eckhard

Actions #11

Updated by Katja Luther almost 5 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Eckhard von Raab-Straube
Actions #12

Updated by Andreas Müller 11 months ago

Actions #13

Updated by Andreas Müller 11 months ago

Actions #14

Updated by Andreas Müller 11 months ago

Actions #15

Updated by Katja Luther 11 months ago

  • Assignee changed from Eckhard von Raab-Straube to Andreas Müller
  • Target version changed from Release 4.7 to Release 5.37

Changed from matching of nomenclatural titleCache to matching of id of the author. Now only references of exact the same author are shown when opening the nomenclatural reference selection dialog. Also added a test.

Actions #16

Updated by Andreas Müller 11 months ago

  • Target version changed from Release 5.37 to Release 5.31
Actions #17

Updated by Andreas Müller 11 months ago

  • Due date set to 03/14/2022
  • Start date set to 03/07/2022
Actions #18

Updated by Andreas Müller 11 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

The search works again but it does not seem to use the new search via author id. It looks like the code for the TaxEditor is not yet commited.

Note: testdata on rem_conf_am are 2 authors with cache "Testlink" (1 is used by 3 refs, the other one by 1 ref)

Actions #19

Updated by Katja Luther 11 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
Actions #20

Updated by Katja Luther 11 months ago

Tested with nightly and it worked as expected. Please review.

Actions #21

Updated by Andreas Müller 11 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 80 to 100

works as expected

Actions

Also available in: Atom PDF