Project

General

Profile

Actions

bug #2969

closed

task #4338: [MASTER] Handle abbreviated title and protected cache correctly in TaxEditor

Correct formatting for bibliographic references

Added by Andreas Müller almost 10 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
critical
Found in Version:
Tags:

Description

Bibliographic references need other formatting then nomenclatural references. Current cache strategies are optimized for nom.ref. formatting. We do need cache strategies for bibliographic references.

Examples for formats:

PalmWeb: Henderson, A.J. (2012). A revision of Pholidostachys (Arecaceae). Phytotaxa 43: 1-48.

Cichorieae:

strongly related to #1625 and kind of duplicate for #1924


Related issues

Related to EDIT - bug #1924: CIHORIEAE in-references in FootnotesNewAndreas Müller

Actions
Related to EDIT - bug #6960: Improve reference cachestrategyDuplicateAndreas Müller

Actions
Is duplicate of EDIT - task #9604: Split bibliographic reference cache strategy and nomenclatural formatter + orginal source formatterClosedAndreas Müller

Actions
Actions #1

Updated by Andreas Müller almost 6 years ago

  • Target version changed from cdm_dataportal - Next Major Release to Release 4.2
Actions #2

Updated by Andreas Müller almost 6 years ago

  • Target version changed from Release 4.2 to Release 4.3
Actions #3

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.3 to Release 4.4
Actions #4

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.4 to Release 4.5
Actions #5

Updated by Andreas Müller over 5 years ago

  • Target version changed from Release 4.5 to Release 4.6
Actions #6

Updated by Andreas Müller about 5 years ago

  • Description updated (diff)
  • Priority changed from Priority14 to Highest
Actions #7

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 4.6 to Release 5.19

This is not yet fixed therefore I move it to current milestone.

Actions #8

Updated by Andreas Müller over 1 year ago

  • Related to bug #1924: CIHORIEAE in-references in Footnotes added
Actions #9

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.19 to Release 5.21
Actions #10

Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 5.21 to Release 5.22
Actions #11

Updated by Andreas Müller about 1 year ago

  • Related to bug #6960: Improve reference cachestrategy added
Actions #12

Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 5.22 to Release 5.25
Actions #13

Updated by Andreas Müller about 1 year ago

  • Tags set to formatting
  • Private changed from Yes to No
Actions #14

Updated by Andreas Müller about 1 year ago

  • Is duplicate of task #9604: Split bibliographic reference cache strategy and nomenclatural formatter + orginal source formatter added
Actions #15

Updated by Andreas Müller about 1 year ago

  • Status changed from New to Closed
  • Target version deleted (Release 5.25)

The cache strategies are split now (e.g. #9604). Examples for correct formatting bibliographic references are given in #1924.

It has been decided not to use brackets arround the year.

So this ticket can be closed as duplicate (and partly works for me).

Actions #16

Updated by Andreas Müller about 1 year ago

  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF