Project

General

Profile

Actions

bug #6960

closed

Improve reference cachestrategy

Added by Andreas Müller over 4 years ago. Updated 8 months ago.

Status:
Duplicate
Priority:
Highest
Category:
cdmlib
Target version:
-
Start date:
09/20/2017
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

There are a number of issues with the existing reference cache strategy (DefaultReferenceCacheStrategy).

This ticket is supposed to be a container for all these smaller issues.

  • webpage without title duplicates the URI

See also "Zitierweise2.doc" in #1924


Related issues

Related to Edit - feature request #5833: Implement single cache strategy for referencesClosedAndreas Müller05/25/201607/11/2016

Actions
Related to Edit - bug #6499: Remaining issues to include pages in bibliographic reference titleCachesIn ProgressAndreas Müller03/15/2017

Actions
Related to Edit - bug #6496: Pages not shown in biblographic reference of articlesClosedAndreas Müller03/13/2017

Actions
Related to Edit - bug #5834: Show volume etc. for generic referencesClosedAndreas Müller07/06/2016

Actions
Related to Edit - bug #9529: Correct formatting for bibliographic in-reference separationClosedAndreas Müller03/13/2021

Actions
Related to Edit - bug #2969: Correct formatting for bibliographic referencesClosedAndreas Müller07/17/2012

Actions
Related to Edit - bug #1924: CIHORIEAE in-references in FootnotesNewAndreas Müller08/02/2010

Actions
Related to Edit - feature request #9530: Add pages to bibliographic book sectionsClosedAndreas Müller03/13/2021

Actions
Related to Edit - feature request #3562: Implement abbreviated title in DataportalNewAndreas Kohlbecker05/02/2016

Actions
Related to Edit - task #9624: Centralize team formatting and fix et al. position handlingClosedAndreas Müller05/14/2021

Actions
Related to Edit - bug #4330: Correct handling of nomenclatural inreferences of JournalsNewAndreas Müller07/06/2016

Actions
Related to Edit - feature request #3764: Improve formatting for reference type SectionResolvedAndreas Müller05/08/2014

Actions
Is duplicate of Edit - task #4338: [MASTER] Handle abbreviated title and protected cache correctly in TaxEditorIn ProgressAndreas Müller01/16/201007/11/2016

Actions
Actions #1

Updated by Andreas Müller over 4 years ago

Actions #2

Updated by Andreas Müller over 4 years ago

  • Related to bug #6499: Remaining issues to include pages in bibliographic reference titleCaches added
Actions #3

Updated by Andreas Müller over 4 years ago

  • Related to bug #6496: Pages not shown in biblographic reference of articles added
Actions #4

Updated by Andreas Müller over 4 years ago

  • Related to bug #5834: Show volume etc. for generic references added
Actions #6

Updated by Andreas Müller over 4 years ago

  • Target version changed from Release 4.10 to Release 4.11
Actions #7

Updated by Andreas Müller about 4 years ago

  • Target version changed from Release 4.11 to Release 4.12
Actions #8

Updated by Andreas Müller about 4 years ago

  • Target version changed from Release 4.12 to Release 4.13
Actions #9

Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 4.13 to Release 4.14
Actions #10

Updated by Andreas Müller almost 4 years ago

  • Target version changed from Release 4.14 to Release 5.0
Actions #11

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.0 to Release 5.1
Actions #12

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.1 to Release 5.2
Actions #13

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.2 to Release 5.3
Actions #14

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.3 to Release 5.4
Actions #15

Updated by Andreas Müller about 3 years ago

  • Target version changed from Release 5.4 to Release 5.5
Actions #16

Updated by Andreas Müller almost 3 years ago

  • Target version changed from Release 5.5 to Release 5.6
Actions #17

Updated by Andreas Müller almost 3 years ago

  • Priority changed from New to Highest
  • Target version changed from Release 5.6 to Reviewed Next Major Release
Actions #18

Updated by Andreas Müller 10 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 30
Actions #19

Updated by Andreas Müller 10 months ago

  • Related to bug #9529: Correct formatting for bibliographic in-reference separation added
Actions #20

Updated by Andreas Müller 10 months ago

  • Related to bug #2969: Correct formatting for bibliographic references added
Actions #21

Updated by Andreas Müller 10 months ago

  • Related to bug #1924: CIHORIEAE in-references in Footnotes added
Actions #23

Updated by Andreas Müller 10 months ago

  • Description updated (diff)
Actions #24

Updated by Andreas Müller 10 months ago

Actions #26

Updated by Andreas Müller 10 months ago

Actions #27

Updated by Andreas Müller 8 months ago

  • Target version changed from Reviewed Next Major Release to Release 5.25
Actions #28

Updated by Andreas Müller 8 months ago

  • Related to task #9624: Centralize team formatting and fix et al. position handling added
Actions #29

Updated by Andreas Müller 8 months ago

  • Related to bug #4330: Correct handling of nomenclatural inreferences of Journals added
Actions #30

Updated by Andreas Müller 8 months ago

Actions #31

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
  • % Done changed from 30 to 50

webpage without title duplicates the URI

can't reproduce this anymore, seems to be fixed in the meanwhile

Actions #32

Updated by Andreas Müller 8 months ago

  • Is duplicate of task #4338: [MASTER] Handle abbreviated title and protected cache correctly in TaxEditor added
Actions #33

Updated by Andreas Müller 8 months ago

  • Status changed from In Progress to Duplicate
  • % Done changed from 50 to 100

This duplicates #4338

Actions #34

Updated by Andreas Müller 8 months ago

  • Target version deleted (Release 5.25)
Actions

Also available in: Atom PDF