Project

General

Profile

bug #9825

Selection wizards for areas in mulitlanguage instances show every vocabulary twice

Added by Katja Luther about 1 month ago. Updated 27 days ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
10/25/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

The selection wizard for areas for the distribution editor shows the vocabularies twice in cuba, this is a multilanguage instance.


Related issues

Related to Edit - bug #9598: Deduplicate NamedAreas with >1 representations and include label in search Closed 05/01/2021

Associated revisions

Revision d955087e (diff)
Added by Andreas Müller 28 days ago

ref #9825 try to fix duplicated vocabularies in distribution editor (probably not working yet due to generics)

Revision 4eccb67a (diff)
Added by Andreas Müller 28 days ago

ref #9825 revert "failing" deduplication and add test showing that deduplication works on dao level

Revision 259c70d2 (diff)
Added by Andreas Müller 28 days ago

ref #9825 fix failing vocDto test

Revision e3538034 (diff)
Added by Andreas Müller 27 days ago

fix #9825 implement deduplication for list(Set) methods in term and vocabulary services

History

#1 Updated by Katja Luther about 1 month ago

  • Related to bug #9598: Deduplicate NamedAreas with >1 representations and include label in search added

#2 Updated by Andreas Müller 29 days ago

  • Tags set to fast

#3 Updated by Andreas Müller 28 days ago

  • Status changed from New to In Progress
  • Assignee changed from Katja Luther to Andreas Müller
  • Priority changed from New to Highest
  • Target version changed from Release 5.29 to Release 5.28
  • % Done changed from 0 to 20

First implementation with d955087e . However, it may not yet work due to generics (the current DefinedTermDaoImpl.deduplicateResult() method maybe works only for CdmBase objects) but we work with DTOs here. Once this is tested we may also adapt other DTO based methods in TermVocabularyDaoImpl as there are lots of methods being DTO based but still loading the representation(s) as model objects.

#4 Updated by Andreas Müller 28 days ago

  • Assignee changed from Andreas Müller to Katja Luther

The method used is a DTO method VocabularyService.findVocabularyDtoByTermType() or finally on DTO level TermVocabularyDaoImpl.findVocabularyDtoByTermTypes(). This method already implements deduplication server side as the new test (259c70d2e105) shows.
The DTO stores both representations in the result. So I guess the problem is somewhere on client side. Katja, can you check this.

#5 Updated by Katja Luther 28 days ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

The method used is a DTO method VocabularyService.findVocabularyDtoByTermType() or finally on DTO level TermVocabularyDaoImpl.findVocabularyDtoByTermTypes(). This method already implements deduplication server side as the new test (259c70d2e105) shows.
The DTO stores both representations in the result. So I guess the problem is somewhere on client side. Katja, can you check this.

Sorry it was the wrong method, it is the find(UUID) which gives back two vocabularies for the uuid.

#6 Updated by Andreas Müller 27 days ago

  • Status changed from Feedback to Resolved
  • % Done changed from 20 to 50

#7 Updated by Andreas Müller 27 days ago

  • Assignee changed from Andreas Müller to Katja Luther

Should be solved now. Can you please review?

#8 Updated by Andreas Müller 27 days ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 50 to 100

I tested on rem_conf_am and everything seems to work as expected.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)