Project

General

Profile

bug #9635

LazyInitializationException (LIE) in TaxonPortalContoller

Added by Andreas Kohlbecker 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib-remote
Target version:
Start date:
05/27/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

http://api.cybertaxonomy.org/euromed/portal/taxon/find.json?doTaxaByCommonNames=1&doMisappliedNames=1&doSynonyms=1&doTaxa=1&pageNumber=0&pageSize=25&query=Ruscus+hy%2A&tree=314a68f9-8449-495a-91c2-92fde8bcf344

Caused by: net.sf.json.JSONException: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.agent.Team.teamMembers, could not initialize proxy - no Session
        at net.sf.json.JSONObject._fromBean(JSONObject.java:692)
        at net.sf.json.JSONObject.fromObject(JSONObject.java:172)
        at eu.etaxonomy.cdm.remote.json.processor.bean.HibernateProxyBeanProcessor.processBean(HibernateProxyBeanProcessor.java:28)
        at net.sf.json.JSONObject._fromBean(JSONObject.java:676)
        at net.sf.json.JSONObject.fromObject(JSONObject.java:172)
        at net.sf.json.AbstractJSON._processValue(AbstractJSON.java:274)
        at net.sf.json.JSONObject._processValue(JSONObject.java:2655)
        at net.sf.json.JSONObject.processValue(JSONObject.java:2721)
        at net.sf.json.JSONObject.element(JSONObject.java:1786)
        at eu.etaxonomy.cdm.remote.json.processor.bean.AbstractBeanProcessor.processBean(AbstractBeanProcessor.java:149)
        at net.sf.json.JSONObject._fromBean(JSONObject.java:676)
        at net.sf.json.JSONObject.fromObject(JSONObject.java:172)
        at eu.etaxonomy.cdm.remote.json.processor.bean.HibernateProxyBeanProcessor.processBean(HibernateProxyBeanProcessor.java:28)
        at net.sf.json.JSONObject._fromBean(JSONObject.java:676)
        at net.sf.json.JSONObject.fromObject(JSONObject.java:172)
        at net.sf.json.AbstractJSON._processValue(AbstractJSON.java:274)
        at net.sf.json.JSONObject._processValue(JSONObject.java:2655)
        at net.sf.json.JSONObject.processValue(JSONObject.java:2721)
        at net.sf.json.JSONObject.setInternal(JSONObject.java:2736)
        at net.sf.json.JSONObject.setValue(JSONObject.java:1424)
        at net.sf.json.JSONObject.defaultBeanProcessing(JSONObject.java:765)
        at net.sf.json.JSONObject._fromBean(JSONObject.java:699)
        at net.sf.json.JSONObject.fromObject(JSONObject.java:172)
        at net.sf.json.AbstractJSON._processValue(AbstractJSON.java:274)
        at net.sf.json.JSONObject._processValue(JSONObject.java:2655)
        at net.sf.json.JSONObject.processValue(JSONObject.java:2721)
        at net.sf.json.JSONObject.element(JSONObject.java:1786)
        at eu.etaxonomy.cdm.remote.json.processor.bean.AbstractBeanProcessor.processBean(AbstractBeanProcessor.java:149)
        at net.sf.json.JSONObject._fromBean(JSONObject.java:676)
        at net.sf.json.JSONObject.fromObject(JSONObject.java:172)
        at eu.etaxonomy.cdm.remote.view.JsonView.render(JsonView.java:146)
        at eu.etaxonomy.cdm.remote.view.JsonView.render(JsonView.java:206)
        at org.springframework.web.servlet.DispatcherServlet.render(DispatcherServlet.java:1286)
        at org.springframework.web.servlet.DispatcherServlet.processDispatchResult(DispatcherServlet.java:1041)
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:984)
        at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:901)
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:970)
        ... 80 common frames omitted
Caused by: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.agent.Team.teamMembers, could not initialize proxy - no Session
        at org.hibernate.collection.internal.AbstractPersistentCollection.throwLazyInitializationException(AbstractPersistentCollection.java:584)
        at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:201)
        at org.hibernate.collection.internal.AbstractPersistentCollection.readSize(AbstractPersistentCollection.java:145)
        at org.hibernate.collection.internal.PersistentList.size(PersistentList.java:113)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getCache(TeamDefaultCacheStrategy.java:168)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getTitleCache(TeamDefaultCacheStrategy.java:146)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getTitleCache(TeamDefaultCacheStrategy.java:1)
        at eu.etaxonomy.cdm.model.common.IdentifiableEntity.generateTitle(IdentifiableEntity.java:682)
        at eu.etaxonomy.cdm.model.agent.Team.getTitleCache(Team.java:314)
        at eu.etaxonomy.cdm.remote.json.processor.bean.TeamOrPersonBaseBeanProcessor.processBeanSecondStep(TeamOrPersonBaseBeanProcessor.java:34)
        at eu.etaxonomy.cdm.remote.json.processor.bean.TeamOrPersonBaseBeanProcessor.processBeanSecondStep(TeamOrPersonBaseBeanProcessor.java:22)
        at eu.etaxonomy.cdm.remote.json.processor.bean.AbstractBeanProcessor.processBean(AbstractBeanProcessor.java:167)
        at net.sf.json.JSONObject._fromBean(JSONObject.java:676)
        ... 116 common frames omitted

Review by testing these searches


Related issues

Related to Edit - feature request #9433: Improve titleCache generation for misapplications Closed 01/29/2021

Associated revisions

Revision 1502b939 (diff)
Added by Andreas Kohlbecker 5 months ago

fix #9635 #adding missing init strategy path for misapplications

History

#1 Updated by Andreas Kohlbecker 5 months ago

  • Description updated (diff)

#2 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker 5 months ago

  • Description updated (diff)

#5 Updated by Andreas Müller 5 months ago

  • Target version changed from Release 5.25 to Release 5.24

#6 Updated by Andreas Müller 5 months ago

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)