Project

General

Profile

bug #8828

statistical values must not show empty brackets

Added by Andreas Kohlbecker 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
01/24/2020
Due date:
% Done:

50%

Severity:
critical
Found in Version:

Description

bei den Höhenangaben gab es nun jahrelang bei den Arten, wo Max. und Min. gleich sind, den Standard, dass dann nicht die Spanne, sondern der Wert nur einfach angezeigt wird, bei Strandarten also in der Regel 0 m. Nun steht da auf einmal 0[]m. Beispiel: Euphorbia prostrata. Wahrscheinlich betrifft es alle gleichzahligen Fälle.

This is a regression casused by the work on #8786

TODO:

  1. fix bug
  2. create test case

Related issues

Related to Edit - task #8786: Display of mean value with min max Resolved 12/19/2019

Associated revisions

Revision 7f36e33a (diff)
Added by Andreas Kohlbecker 8 months ago

fix #8828 removing empty brackets from statistical values in QuantitativeData and cleaning up

History

#1 Updated by Andreas Kohlbecker 8 months ago

  • Related to task #8786: Display of mean value with min max added

#2 Updated by Andreas Kohlbecker 8 months ago

Hallo,

ggf auch auf das Leerzeichen vor der Einheit (und ggf. der Klammer) achten. Ich habe nicht überprüft, ob das bei Ralf nur versehentlich fehlte bei „0[]m“.

Viele Grüße,

Andreas M.

#3 Updated by Andreas Kohlbecker 8 months ago

Andreas Kohlbecker wrote:

Hallo,

ggf auch auf das Leerzeichen vor der Einheit (und ggf. der Klammer) achten. Ich habe nicht überprüft, ob das bei Ralf nur versehentlich fehlte bei „0[]m“.

Viele Grüße,

Vor der Klammer sind bisher keine Leerzeichen vorgesehen gewesen (siehe Ticket https://dev.e-taxonomy.eu/redmine/issues/8786 ).

Ich habe mich hier an dem Vorschlag orientiert den Norbert per Email geschickt hatte.

Die Einheit sollte jedenfalls mit einem Leerzeichen vom Wert getrennt werden, so wie es der Standard vorgibt.

Viele Grüße,

Andreas

Andreas M.

#4 Updated by Andreas Kohlbecker 8 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#5 Updated by Andreas Kohlbecker 8 months ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller

#6 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Andreas Kohlbecker

seems to be fully fixed, but there is a related open issue at #8830#note-5

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)