Project

General

Profile

bug #7999

Allow override does not work correctly for distribution areas

Added by Andreas Müller about 1 month ago. Updated 17 days ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
01/17/2019
Due date:
% Done:

100%

Severity:
critical
Found in Version:

Description

I tested with an empty databases with no CdmPreferences at all. I would expect that the default is, that I can define the available vocabularies in the local preferences and that the default value is that all vocabularies are selected (as nobody set a filter yet)

But both is not the case. The area selection is disabled in local preferences and in distribution editor no vocabulary is available.

This currently leads to an NPE when opening the distribution editor as the list of areas is null:

login : admin
editor version : 5.5.0.201901170948
server : test.e-taxonomy.eu (edit-test) / test1
schema version : 5.0.0.0.20180514
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:288)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
                at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
                at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
                at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
...
Caused by: java.lang.NullPointerException
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.DistributionEditor.initLabels(DistributionEditor.java:538)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.DistributionEditor.createLayers(DistributionEditor.java:333)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.DistributionEditor.createTable(DistributionEditor.java:293)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.DistributionEditorPart.init(DistributionEditorPart.java:120)
                at eu.etaxonomy.taxeditor.editor.EditorUtil.openDistributionEditor(EditorUtil.java:105)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.handler.OpenChecklistEditorHandlerE4.open(OpenChecklistEditorHandlerE4.java:66)
                at eu.etaxonomy.taxeditor.editor.view.checklist.e4.handler.OpenChecklistEditorHandlerE4.open(OpenChecklistEditorHandlerE4.java:1)
                at eu.etaxonomy.taxeditor.handler.defaultHandler.e4.DefaultOpenHandlerBaseE4.execute(DefaultOpenHandlerBaseE4.java:39)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
                ... 37 more

picture928-1.png View (6.63 KB) Andreas Müller, 01/29/2019 06:06 PM


Related issues

Related to Edit - bug #7856: Allow local override for distribution vocabularies Closed 10/23/2018
Related to Edit - task #7854: Open issues in TaxDistributionEditor Closed 10/23/2018
Related to Edit - bug #7880: Implement centralized preference default loading strategy Closed 10/30/2018

Associated revisions

Revision 0082e2d6 (diff)
Added by Katja Luther about 1 month ago

ref #7999: if no db pref exists for vocabularies, the button in local pref is editable

Revision 10f96af0 (diff)
Added by Katja Luther about 1 month ago

ref #7999: if no pref exists for area vocs then use all vocs

Revision 57d3d692 (diff)
Added by Katja Luther 20 days ago

ref bug #7999: fix NPEs in preferences pages

Revision 2470b75b (diff)
Added by Katja Luther 18 days ago

fix #7999: fix NPE in namedetailsview config when no db pref available

History

#1 Updated by Andreas Müller about 1 month ago

  • Related to bug #7856: Allow local override for distribution vocabularies added

#2 Updated by Andreas Müller about 1 month ago

  • Related to task #7854: Open issues in TaxDistributionEditor added

#3 Updated by Andreas Müller about 1 month ago

  • Related to bug #7880: Implement centralized preference default loading strategy added

#4 Updated by Katja Luther about 1 month ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

this should be fixed now, please review

#5 Updated by Andreas Müller 23 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Similar(?) issue for distribution status

login : admin
editor version : 5.5.0.201901242349
server : test.e-taxonomy.eu (edit-test) / test1
schema version : 5.0.0.0.20180514
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.ui.internal.handlers.LegacyHandlerService.executeCommand(LegacyHandlerService.java:353)
    at org.eclipse.ui.internal.handlers.LegacyHandlerService.executeCommand(LegacyHandlerService.java:340)
    at eu.etaxonomy.taxeditor.ui.element.CommandHandlerButton$1.widgetSelected(CommandHandlerButton.java:61)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:818)
    at org.eclipse.jface.window.Window.open(Window.java:794)
    at eu.etaxonomy.taxeditor.workbench.handler.OpenPreferencesHandler.execute(OpenPreferencesHandler.java:124)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
    at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
    at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
    at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.preference.wizard.AbstractAdminTermSelectionWizardPage.<init>(AbstractAdminTermSelectionWizardPage.java:37)
    at eu.etaxonomy.taxeditor.preference.wizard.AvailableDistributionStatusPage.<init>(AvailableDistributionStatusPage.java:37)
    at eu.etaxonomy.taxeditor.preference.wizard.AvailableDistributionStatusWizard.<init>(AvailableDistributionStatusWizard.java:46)
    at eu.etaxonomy.taxeditor.handler.e4.OpenDistributionStatusWizardHandler.execute(OpenDistributionStatusWizardHandler.java:31)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
    ... 60 more

#6 Updated by Andreas Müller 23 days ago

But the original issue seems to be fixed or at least works much better. Final testing is difficult and I will do it when the above bug is fixed.

#7 Updated by Katja Luther 20 days ago

  • Status changed from Feedback to Resolved

both problems should be solved now.

#8 Updated by Katja Luther 20 days ago

  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 0 to 60

#9 Updated by Andreas Müller 19 days ago

  • File picture928-1.png View added
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

When opening lokal pref distribution editor page I got

Worked on test/test1. DB prefs all deleted before starting editor.

#10 Updated by Katja Luther 18 days ago

  • Status changed from Feedback to Resolved
  • % Done changed from 60 to 50

#11 Updated by Katja Luther 18 days ago

  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 50 to 60

#12 Updated by Andreas Müller 17 days ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 60 to 100

This seems to work as expected now.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)