Project

General

Profile

bug #7566

TeamOrPersonField: some Persons can not be selected

Added by Andreas Kohlbecker 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
07/19/2018
Due date:
% Done:

100%

Severity:
critical
Found in Version:
Tags:

Description

This issue only occurs with some few Persons:

[originally reported by Hennig]

Folgende Eingabeprobleme im speciemen typedisignations editor
http://test.e-taxonomy.eu/cdmserver/phycobank_production/app/registration#!workingset/c79044bc-341c-4d5a-9a41-4b6e32db094c

Collector:

  1. Auswahl wird angezeigt
  2. Nomenklatorische Autoren angezeigt, z.B. „Ehrenb.“, „Gottschling“
  3. Ausgewählte Autoren nach Auswahl nicht sichtbar, daher nicht speicherbar

Related issues

Duplicated by Edit - bug #7567: SpecimenTypeDesignationEditor: Collection selection only set at second select action Duplicate 07/19/2018

Associated revisions

Revision 99529ce3 (diff)
Added by Andreas Kohlbecker 5 months ago

ref #7566 using the COLLECTOR_TITLE for the collector combobox

Revision 1fc42b13 (diff)
Added by Andreas Kohlbecker 5 months ago

ref #7566 solving problem with unselectable entities due to eagerly selection clearing in updateToolBarButtonStates()

History

#1 Updated by Andreas Kohlbecker 5 months ago

I found one minor issue while investigating this: The NOMENCLATURAL_TITLE was being used for the caption of the collector filed

#2 Updated by Andreas Kohlbecker 5 months ago

These problems are related to the changes made for #7535

The root cause is the code line


private void updateToolBarButtonStates(){
  ...
  if(teamOrPersonSelect.getValue() != val){
      teamOrPersonSelect.clear();
  }

a second level problem detected is that updateToolBarButtonStates() is called too often. it is called at the end of setInternalValue() which covers most usecases.

#3 Updated by Andreas Kohlbecker 5 months ago

  • Duplicated by bug #7567: SpecimenTypeDesignationEditor: Collection selection only set at second select action added

#4 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 0 to 50

#5 Updated by Wolf-Henning Kusber 4 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)