Project

General

Profile

bug #7379

right click menu of accepted taxa should not show "change to"

Added by Katja Luther 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
04/27/2018
Due date:
% Done:

80%

Severity:
normal
Found in Version:

Description

im Rechte-Maus Menu des Nameeditors stimmen gerade ein paar Dinge nicht.

1) Taxa: das Change To Menü wird angezeigt, mit ausgegrauten einträgen. Das sollte hier aber gar nicht erscheinen (das hatte Walter auch schon mal angemerkt, gibt es dazu ein Ticket?)
2) Synonyme: im New Menü werden ausgegraut „Heterotypic Synonym“ und „Homotypic Synonym“ angezeigt. Die könnten auch lieber ganz weggelassen werden, insbesondere da es darunter noch den aktiven Eintrag „Synonym in Homotypical Group“ gibt, der sich von „Homotypic Synonym“ nicht wirklich unterscheidet.
Auch der „Misapplication“ eintrag sollte möglichst ausgeblendet werden.
Bei Change To sollte der „Synonym“ Eintrag gelöscht werden

Associated revisions

Revision e9f9f442 (diff)
Added by Katja Luther 8 months ago

ref #7379: disable change to menu item for accepted taxa in name editor

Revision 74b82668 (diff)
Added by Katja Luther 8 months ago

fix name editor menu for synonyms and misapplications

History

#1 Updated by Katja Luther 8 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • Priority changed from New to Highest

please review

#2 Updated by Andreas Müller 8 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.0

#3 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Issues for 2) are not yet implemented.

#4 Updated by Andreas Müller 8 months ago

  • % Done changed from 0 to 30

#5 Updated by Katja Luther 7 months ago

issues for 2) are done see Revision 74b82668

#6 Updated by Katja Luther 7 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 30 to 80

#7 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

The menu entry seems to be correct now.

However, it often happens that the menu entry for the accepted taxon disappears completely.

I could reproduce this by

  • opening a taxon with a heterotypic synonym.
  • add a synonym to the group of the heterotypic synonym
  • go to accepted taxon => new menu appears

I don't know if this is related to this ticket. If not please open a new ticket if not exists)

#8 Updated by Katja Luther 7 months ago

  • Status changed from Feedback to Closed

Andreas Müller wrote:

The menu entry seems to be correct now.

However, it often happens that the menu entry for the accepted taxon disappears completely.

I could reproduce this by

  • opening a taxon with a heterotypic synonym.
  • add a synonym to the group of the heterotypic synonym
  • go to accepted taxon => new menu appears

I don't know if this is related to this ticket. If not please open a new ticket if not exists)

created a new ticket for this -> #7424 and close this ticket.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)