Project

General

Profile

bug #7424

right click menu does not show up in name editor

Added by Katja Luther 7 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
05/16/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

after some operations the right click menu of the accepted taxon does not show up anymore.

for example after deleting a synonym or change a synonym to misapplication...


Related issues

Related to Edit - bug #6954: Sometimes the context menu of e4 parts does not show up New 09/15/2017

Associated revisions

Revision 7ccb7304 (diff)
Added by Katja Luther 3 months ago

ref #7424: after updating name editor set menu to all containers to avoid missing menu

History

#1 Updated by Katja Luther 3 months ago

  • Status changed from New to In Progress

this problem appears only for synonyms and the accepted taxon, for missapplied names and pro parte synonyms the menu is shown.

#2 Updated by Andreas Müller 3 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.4

Add this to current milestone as it is critical (often mentioned by users)

#3 Updated by Katja Luther 3 months ago

the problem appears because the menu is set to disposed when a groupContainer is removed.

#4 Updated by Patrick Plitzner 3 months ago

  • Related to bug #6954: Sometimes the context menu of e4 parts does not show up added

#5 Updated by Andreas Müller about 2 months ago

  • Assignee changed from Katja Luther to Andreas Müller

not sure if fully fixed already, however I set to resolved for review.

#6 Updated by Andreas Müller about 2 months ago

  • Status changed from In Progress to Resolved

#7 Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 100

PP: KL said this is fixed and discussed fix with me

#8 Updated by Andreas Müller about 2 months ago

As this is difficult to reproduce I close ticket. If it reoccurs we can reopen.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)