Project

General

Profile

bug #6973

Refreshing details and supplemental view

Added by Patrick Plitzner about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
09/22/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

Copied from #6922:

If one adds a new term and then the label of this term is changed, the new label is not reflected in the label of the supplemental data view (it is still showing "Feature: Untitled".
After reconnect the label is correct.

Now, after reconnect the details view and supplemental data is emptied but when clicking on the empty details view the content of the supplemental details reappears.

If this can easier be handled after full e4 migration we can live with it for now and close the ticket. But if it is easy to fix we could try to fix it.

Also the missing refresh of the supplemental data view we decided only to handle in next version after full e4 migration therefore it is not yet fixed. But we should open a new ticket to not forget these issues.

picture128-1.png View - title synchronization issue (10.1 KB) Andreas Müller, 04/27/2018 11:58 AM

picture756-1.png View - after re-connect (59.1 KB) Andreas Müller, 04/27/2018 12:01 PM


Related issues

Copied from Edit - feature request #6922: Migrate term editor Closed 08/23/2017
Copied to Edit - feature request #7741: Refresh supplemental data view title when editing terms New 09/07/2018

Associated revisions

Revision 1c621bae (diff)
Added by Patrick Plitzner 10 months ago

ref #6973 Fix label generation in suppData view

Revision 6e656d8c (diff)
Added by Patrick Plitzner 7 months ago

ref #6973 Clear all CdmEditorParts when (re-)connecting

Revision f628fac5 (diff)
Added by Patrick Plitzner 7 months ago

ref #6973 Refresh supplemental view when saving the term editor

Revision ad804b65 (diff)
Added by Patrick Plitzner 7 months ago

ref #6973 Clear editor parts when reconnecting

History

#1 Updated by Patrick Plitzner about 1 year ago

#2 Updated by Patrick Plitzner about 1 year ago

  • Parent task set to #4135

#3 Updated by Andreas Müller about 1 year ago

  • Target version changed from Unassigned CDM tickets to Release 4.11

#4 Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 4.11 to Release 4.12

#5 Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 4.12 to Release 4.13

#6 Updated by Andreas Müller 11 months ago

  • Target version changed from Release 4.13 to Release 4.14

#7 Updated by Andreas Müller 10 months ago

  • Target version changed from Release 4.14 to Release 5.0

#8 Updated by Patrick Plitzner 10 months ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50

I could not reproduce the behavior you described with clicking in the empty detail view

#9 Updated by Andreas Müller 8 months ago

If one adds a new term and then the label of this term is changed, the new label is not reflected in the label of the supplemental data view (it is still showing "Feature: Untitled".

Issue still exists. See attachment.

#10 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

#11 Updated by Andreas Müller 8 months ago

Now, after reconnect the details view and supplemental data is emptied but when clicking on the empty details view the content of the supplemental details reappears.

Currently, the supplemental data view is not emptied at all after a re-connect. See attachment.

#12 Updated by Patrick Plitzner 7 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 70

all should be fixed now

#13 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Andreas Müller wrote:

If one adds a new term and then the label of this term is changed, the new label is not reflected in the label of the supplemental data view (it is still showing "Feature: Untitled".

Issue still exists. See attachment.

Changing label work now after saving. This is in line with other usages of supplemental data view related to details view.

Anyway, I wonder if we could not update the supplemental data view when ever data changes even if not persisted. This is e.g. the case when you change the name of a taxon in the name editor. To me this looks more intuitive as NameEditor, DetailsView and SupplDataView are part of the same "session" so I would expect data updates immediately, not only after saving. This is different to e.g. navigator<->name editor synchronization where we have 2 different sessions.

As this is maybe a more general issue please feel free to create a new ticket.

#14 Updated by Andreas Müller 7 months ago

Andreas Müller wrote:

Now, after reconnect the details view and supplemental data is emptied but when clicking on the empty details view the content of the supplemental details reappears.

Currently, the supplemental data view is not emptied at all after a re-connect. See attachment.

It is better now, but still it is possible to show the old data.

Howto:

  • open term editor (e.g. feature) and click on a vocabulary => shows up in details and suppleData View.
  • reconnect => details view and suppDataView are empty (white)
  • click single click on taxon in navigator => nothing happens
  • click in empty details view => supplemental data view is filled with data from term vocabulary from prior to reconnect!!

This is not really critical as a seldom use case. But somehow it feels like there are mostly workarounds to handle the situation. Is there not a more straight forward solution?
Is there a reason, why the details view and supplData view become white, not gray? This is somehow not consistent with behavior of facts view and media view.

By the way, the above behavior is not restricted to supplemental data for terms. It also occurs when the name editor was opened before reconnect.

#15 Updated by Patrick Plitzner 7 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 70 to 80

#16 Updated by Andreas Müller 7 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • % Done changed from 80 to 100

Seems to be fixed (though I still don' understand why the details and supplemental data view need to be white not gray, is there a reason for that?)

#17 Updated by Patrick Plitzner 7 months ago

Andreas Müller wrote:

Seems to be fixed (though I still don' understand why the details and supplemental data view need to be white not gray, is there a reason for that?)

This has to do with composite hierarchy. Views like for example the media view simply have a tree viewer whereas the details and supplemental view have several layers of composites. And it seems like a simple setEnabled(false) does not have the same visible effect here than in the other views.

#18 Updated by Patrick Plitzner 3 months ago

#19 Updated by Patrick Plitzner 3 months ago

#20 Updated by Patrick Plitzner 3 months ago

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)