Project

General

Profile

bug #6948

OAIPMH service broken by NPE with verb=ListIdentifiers & set=taxon

Added by Andreas Kohlbecker over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
New
Category:
cdmlib-remote
Target version:
Start date:
09/14/2017
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

taxon/oai?verb=ListIdentifiers&metadataPrefix=oai_dc&set=taxon

this problem also accounts to other service requests and seems to be caused by a broken dozer configuration


Related issues

Duplicates Edit - bug #6324: fix dozer mapping after removal of synonym relations In Progress 01/11/2017

Associated revisions

Revision 224d902d (diff)
Added by Andreas Kohlbecker over 1 year ago

fix #6948 ref #6324 commenting and removing broken dozer mapping for synonymRelations

History

#1 Updated by Andreas Kohlbecker over 1 year ago

  • Description updated (diff)

#2 Updated by Andreas Kohlbecker over 1 year ago

Caused by:

org.springframework.web.util.NestedServletException: Request processing failed; nested exception is org.dozer.MappingException: java.lang.ClassNotFoundException: eu.etaxonomy.cdm.model.taxon.SynonymRelationship
    at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:981)
    at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:860)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:687)
    at org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:845)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:841)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1634)
    at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:316)
    at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:126)
    at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:90)
    at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
    at org.springframework.security.web.access.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:114)
    at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
    at org.springframework.security.web.session.SessionManagementFilter.doFilter(SessionManagementFilter.java:122)
    at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
    at org.springframework.security.web.authentication.AnonymousAuthenticationFilter.doFilter(AnonymousAuthenticationFilter.java:111)

#3 Updated by Andreas Kohlbecker over 1 year ago

  • Duplicates bug #6324: fix dozer mapping after removal of synonym relations added

#4 Updated by Andreas Kohlbecker over 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#5 Updated by Andreas Kohlbecker over 1 year ago

  • Target version changed from Unassigned CDM tickets to Release 4.10

#6 Updated by Andreas Kohlbecker about 1 year ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

The NPE is suppressed by the fix the duplicate issue can not yet be closed since the its solution requires additional work.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)