Project

General

Profile

bug #5684

NPE when trying to move a presence-absence term within the vocabulary

Added by Andreas Müller over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Priority13
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

0%

Severity:
major
Found in Version:

Description

I tried to change the position of a user defined presence-absence term in the Cuba Distribution Status vocabulary in the cuba checklist database. Got an NPE:

login : admin
editor version : 3.12.4
server : api.cybertaxonomy.org / cybertaxonomy.org
schema version : 3.6.0.0.201527040000
os : Windows Server 2012 6.2 amd64
java : 1.7.0_75
org.eclipse.core.commands.ExecutionException: While executing the operation, an exception occurred
    at org.eclipse.core.commands.operations.DefaultOperationHistory.execute(DefaultOperationHistory.java:521)
    at eu.etaxonomy.taxeditor.model.AbstractUtility$1.run(AbstractUtility.java:333)
    at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464)
    at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372)
    at org.eclipse.jface.window.ApplicationWindow$1.run(ApplicationWindow.java:759)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWindow.java:756)
    at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:2649)
    at org.eclipse.ui.internal.progress.ProgressManager$RunnableWithStatus.run(ProgressManager.java:1346)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at org.eclipse.ui.internal.progress.ProgressManager$7.run(ProgressManager.java:1184)
    at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:180)
    at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:150)
    at org.eclipse.swt.widgets.Display.syncExec(Display.java:4683)
    at org.eclipse.ui.internal.progress.ProgressManager.runInUI(ProgressManager.java:1182)
    at eu.etaxonomy.taxeditor.model.AbstractUtility.runInUI(AbstractUtility.java:645)
    at eu.etaxonomy.taxeditor.model.AbstractUtility.executeOperation(AbstractUtility.java:351)
    at eu.etaxonomy.taxeditor.editor.definedterm.DefinedTermDropAdapter.performDrop(DefinedTermDropAdapter.java:70)
    at org.eclipse.jface.viewers.ViewerDropAdapter.drop(ViewerDropAdapter.java:276)
    at org.eclipse.swt.dnd.DNDListener.handleEvent(DNDListener.java:90)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
    at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:774)
    at org.eclipse.swt.dnd.DropTarget.Drop(DropTarget.java:456)
    at org.eclipse.swt.dnd.DropTarget.Drop_64(DropTarget.java:392)
    at org.eclipse.swt.dnd.DropTarget$3.method6(DropTarget.java:260)
    at org.eclipse.swt.internal.ole.win32.COMObject.callback6(COMObject.java:119)
    at org.eclipse.swt.internal.ole.win32.COM.DoDragDrop(Native Method)
    at org.eclipse.swt.dnd.DragSource.drag(DragSource.java:363)
    at org.eclipse.swt.dnd.DragSource.access$0(DragSource.java:289)
    at org.eclipse.swt.dnd.DragSource$1.handleEvent(DragSource.java:172)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4165)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3754)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.editor.definedterm.operation.MoveDefinedTermOperation.execute(MoveDefinedTermOperation.java:112)
    at org.eclipse.core.commands.operations.DefaultOperationHistory.execute(DefaultOperationHistory.java:513)
    ... 56 more

History

#1 Updated by Andreas Müller over 2 years ago

  • Description updated (diff)
  • Priority changed from New to Highest

#2 Updated by Andreas Müller about 2 years ago

  • Priority changed from Highest to Priority13
  • Target version changed from Unassigned CDM tickets to Release 4.4

#3 Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 4.4 to Release 4.5

#4 Updated by Andreas Müller almost 2 years ago

  • Private changed from Yes to No

#6 Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 4.5 to Release 4.6
  • Private changed from No to Yes

#7 Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 4.6 to Release 4.7

#8 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 4.7 to Release 4.8

#9 Updated by Katja Luther over 1 year ago

Is this still an open issue. I can't reproduce it.

#10 Updated by Andreas Müller over 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

#11 Updated by Andreas Müller over 1 year ago

  • Private changed from Yes to No

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)