Project

General

Profile

feature request #5616

Add the"Open in..." menu to taxon search

Added by Andreas Müller over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
11/24/2016
Due date:
% Done:

100%

Severity:
normal

Description

Taxon search lists taxa and names (if name is not attached to a taxon).

So we need an open in

  • "Name Editor" if object is a taxon/synonym and if the (accepted) taxon belongs to a taxon node

  • "Taxon Bulk Editor" if object is a taxon/synonym

  • "Name Bulk Editor" if object is a name

So for ordinary taxa within a classification we offer 2 possibilities. The default for double click is to open the name editor. Only if this is not possible we should open the bulk editor (the later might be a separate ticket)

see also #4731


Related issues

Copied to Edit - bug #6220: Improve definition of orphaned taxon and synonym Feedback 11/24/2016

Associated revisions

Revision 28829 (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 "Open in bulke editor" for taxa in taxon search view

Revision 12a605bc (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 "Open in bulke editor" for taxa in taxon search view

Revision 28830 (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 Fix possible NPE for BulkEditor inputs

Revision 222d6e76 (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 Fix possible NPE for BulkEditor inputs

Revision 28831 (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 Add alternative to double click execution in search view
- Opens either in name or bulk editor

Revision 1d81ea4a (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 Add alternative to double click execution in search view
- Opens either in name or bulk editor

Revision 30afcea0 (diff)
Added by Patrick Plitzner about 3 years ago

fix #5616 Add check for orphaned taxa to CdmViewer context menu

  • removed default handler for this

Revision 4e365f81 (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 Fix NPE for opening synonyms from SearchResult view

Revision 92634d22 (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 Fix class check for bulk editor porperty tester

  • handle UuidAndTitleClache

Revision 0e9a6a75 (diff)
Added by Patrick Plitzner about 3 years ago

ref #5616 Generalize evaluation of available CdmViewers

Revision 4b80789a (diff)
Added by Andreas Müller almost 3 years ago

fix #6220 Improve isOrphaned definition for Taxon.

History

#1 Updated by Patrick Plitzner over 3 years ago

  • Status changed from New to In Progress
  • Target version changed from Unassigned CDM tickets to Release 4.0

#2 Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 4.0 to Release 4.1

#3 Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 4.1 to Release 4.2

#4 Updated by Andreas Müller about 3 years ago

  • Target version changed from Release 4.2 to Release 4.3

#5 Updated by Patrick Plitzner about 3 years ago

  • Description updated (diff)
  • Status changed from In Progress to Feedback
  • Assignee changed from Patrick Plitzner to Andreas Müller

#6 Updated by Andreas Müller about 3 years ago

  • Status changed from Feedback to Resolved

#8 Updated by Andreas Müller about 3 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner
  • Priority changed from New to Highest
  • % Done changed from 0 to 70

Works fine for pure names and taxon nodes.

For orphaned taxa it should not show allow the option "open in name editor" but only "open in bulk editor"

#9 Updated by Patrick Plitzner about 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 70 to 50

Applied in changeset taxeditor:commit:taxeditor|30afcea01068a7e0dcd2bde6b9a5f28e4bbcdd6f.

#10 Updated by Patrick Plitzner about 3 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 70

#11 Updated by Andreas Müller about 3 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

Now it does not offer bulkeditor at all anymore, not for pure names, not for orphaned taxa and not for ordinary taxa/synonyms, but it should for all 3 of them.

#12 Updated by Patrick Plitzner about 3 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Fixed in taxeditor:commit:taxeditor|92634d22a080f6de8af639dae12fe771cda64ceb

#13 Updated by Andreas Müller about 3 years ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

Better now but still some issues:

  • For pure names (not related to taxa) the right click menu does not show up at all anymore. Only double-click works. But even if there is only one alternative we should show a right click menu for consistency.
  • as mentioned above, orphaned taxa should not allow opening in name editor as the name editor can not handle them. Especially double click should not go to name editor but to bulk editor
  • maybe related to the later: orphaned taxa again are not shown with a special icon (brown) but with the icon for accepted taxa (black), this is misleading and should be changed back. We had the same issue a couple of month ago already so there might be a closed ticket about the issue.

#14 Updated by Patrick Plitzner about 3 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Andreas Müller wrote:

Better now but still some issues:

  • For pure names (not related to taxa) the right click menu does not show up at all anymore. Only double-click works. But even if there is only one alternative we should show a right click menu for consistency.
  • as mentioned above, orphaned taxa should not allow opening in name editor as the name editor can not handle them. Especially double click should not go to name editor but to bulk editor
  • maybe related to the later: orphaned taxa again are not shown with a special icon (brown) but with the icon for accepted taxa (black), this is misleading and should be changed back. We had the same issue a couple of month ago already so there might be a closed ticket about the issue.

Fixed the last issue with the last commit but I cannot reproduce the other two issues

#15 Updated by Andreas Müller almost 3 years ago

The first issue seems to be fixed.

Handling of orphaned taxa still does not work (neither the icon nor the right click menu which should not show the name editor, but does).

Please check with taxon "Orphaned taxon" in rem_conf_am on edit-test. It shows a black icon and allows opening in name editor. Maybe this is because it has taxon relationships. But only misapplied name relationships should be handled special and should handle taxa as not orphaned.

#16 Updated by Andreas Müller almost 3 years ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

#17 Updated by Patrick Plitzner almost 3 years ago

Andreas Müller wrote:

The first issue seems to be fixed.

Handling of orphaned taxa still does not work (neither the icon nor the right click menu which should not show the name editor, but does).

Please check with taxon "Orphaned taxon" in rem_conf_am on edit-test. It shows a black icon and allows opening in name editor. Maybe this is because it has taxon relationships. But only misapplied name relationships should be handled special and should handle taxa as not orphaned.

"Orphaned taxon" is returned as UuidAndTitleCache with the isOrphaned flag set to false. This is a service call to ITaxonService.findTaxaAndNamesForEditor().
@Andreas: Didn't you work on this a few days ago?

#18 Updated by Patrick Plitzner almost 3 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

#19 Updated by Katja Luther almost 3 years ago

The problem seems to be in the calculation of the orphan value. A taxon is only orphaned when it is not used in a classification or in a taxon relationship. synonyms never are orphaned.

We have to have a look at this query.

#20 Updated by Andreas Müller almost 3 years ago

Katja Luther wrote:

The problem seems to be in the calculation of the orphan value. A taxon is only orphaned when it is not used in a classification or in a taxon relationship. synonyms never are orphaned.

We have to have a look at this query.

An update will come with the model change merge (probably today). Let's check again afterwards.

#21 Updated by Andreas Müller almost 3 years ago

Katja Luther wrote:

The problem seems to be in the calculation of the orphan value. A taxon is only orphaned when it is not used in a classification or in a taxon relationship. synonyms never are orphaned.

We have to have a look at this query.

OK, this seems to be the reason. I can see in Taxon.class that isOrphaned is implemented such. New ticket #6220 to handle this more correctly.

#22 Updated by Andreas Müller almost 3 years ago

  • Assignee changed from Andreas Müller to Katja Luther

4b80789a fixed the "Open in ..." issue. However there are open questions related to orphaned taxa. See #6220.

#23 Updated by Patrick Plitzner over 1 year ago

  • Target version changed from Release 4.3 to Release 5.0

moving to current milestone to discuss

#24 Updated by Andreas Müller over 1 year ago

Can we move the open questions to a new ticket and close this ticket and move it back to the original milestone?

#25 Updated by Andreas Müller over 1 year ago

  • Private changed from Yes to No

#26 Updated by Katja Luther over 1 year ago

  • Target version changed from Release 5.0 to Release 4.6

I think the open questions are already in ticket #6220, so we can close this ticket.

#27 Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 4.6 to Release 4.3

#28 Updated by Andreas Müller over 1 year ago

  • Assignee changed from Katja Luther to Patrick Plitzner

#29 Updated by Patrick Plitzner over 1 year ago

  • Copied to bug #6220: Improve definition of orphaned taxon and synonym added

#30 Updated by Patrick Plitzner over 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)