Project

General

Profile

Actions

bug #9882

open

Null argument when deleting description in bulkeditor

Added by Katja Luther about 2 months ago. Updated about 4 hours ago.

Status:
Feedback
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
11/24/2021
Due date:
% Done:

60%

Estimated time:
Severity:
normal
Found in Version:

Description

mail AM:

null beim Löschen einer Description:

last remote method : http://api.cybertaxonomy.org:80/flora-malesiana-prospective/remoting/description.service
last remote request client time : 2021-11-18T23:02:28.21
last remote request response header time : Thu, 18 Nov 2021 22:02:28 GMT
client error time : 2021-11-18T23:02:28.288
login : admin
editor version : 5.28.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / flora-malesiana-prospective
schema version : 5.27.1.0.20210922
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_131
org.eclipse.e4.core.di.InjectionException: org.eclipse.core.runtime.AssertionFailedException: null argument:
            at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
            at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
            at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
            at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
            at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
            at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
            at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
            at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
            at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
            at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
            at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
            at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
            at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
            at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
            at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
            at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
            at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
            at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
            at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
            at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
            at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
            at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
            at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:498)
            at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
            at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
            at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: org.eclipse.core.runtime.AssertionFailedException: null argument:
            at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:85)
            at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:73)
            at org.eclipse.jface.viewers.StructuredSelection.<init>(StructuredSelection.java:74)
            at eu.etaxonomy.taxeditor.bulkeditor.e4.BulkEditor.changed(BulkEditor.java:322)
            at eu.etaxonomy.taxeditor.editor.view.descriptive.e4.handler.DeleteHandlerE4.execute(DeleteHandlerE4.java:167)
            at sun.reflect.GeneratedMethodAccessor182.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:498)
            at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
            ... 36 more


Actions #1

Updated by Katja Luther about 2 months ago

  • Status changed from New to In Progress

The original problem is solved, but there is another issue. The deletion of the description elements is not solved by using a service method, but should. The service methods are already available.

Actions #2

Updated by Katja Luther about 2 months ago

  • Subject changed from NPE when deleting description in bulkeditor to Null argument when deleting description in bulkeditor
Actions #3

Updated by Katja Luther 17 days ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

Katja Luther wrote:

The original problem is solved, but there is another issue. The deletion of the description elements is not solved by using a service method, but should. The service methods are already available.

this is fixed now.

Actions #4

Updated by Katja Luther 17 days ago

  • % Done changed from 0 to 60
Actions #5

Updated by Andreas Müller about 4 hours ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

From the ticket description I am not sure if I understand what the original problem was. Was it in taxon bulk editor and then deleting a description in the facts view? If yes, this seems to be fixed. If no, please let me know what/how to test.

Actions

Also available in: Atom PDF