Project

General

Profile

Actions

bug #9478

closed

required ToOneRelatedEntityCombobox field in SpecimenTypeDesignationDTORow fails validation

Added by Andreas Kohlbecker almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

the SpecimenTypeDesignationDTORow contains the ToOneRelatedEntityCombobox<Reference> designationReference
When set to required the field is being validated in MBeanFieldGroup.valueChange() to ensure the existing row is complete before adding a new row.
A new Row is never being add since the the designationReference field always fails during validation.

IMPORTANT: Check that no regression occurs fir the case described in #7245

duplicate of #8249???


Related issues

Related to EDIT - bug #7245: validation of ToOneRelatedEntityCombobox not workingClosedAndreas Kohlbecker

Actions
Blocks EDIT - bug #9476: SpecimenTypeDesignations for existing names in other nom acts can not be createdClosedAndreas Kohlbecker

Actions
Copied to EDIT - bug #9479: ToOneRelatedEntityCombobox misses sending ValueChanged events to MBeanFieldGroupClosedAndreas Kohlbecker

Actions
Actions #1

Updated by Andreas Kohlbecker almost 2 years ago

  • Related to bug #9476: SpecimenTypeDesignations for existing names in other nom acts can not be created added
Actions #2

Updated by Andreas Kohlbecker almost 2 years ago

  • Related to deleted (bug #9476: SpecimenTypeDesignations for existing names in other nom acts can not be created)
Actions #3

Updated by Andreas Kohlbecker almost 2 years ago

  • Blocks bug #9476: SpecimenTypeDesignations for existing names in other nom acts can not be created added
Actions #4

Updated by Andreas Kohlbecker almost 2 years ago

  • Description updated (diff)
  • Status changed from New to In Progress
Actions #5

Updated by Andreas Kohlbecker almost 2 years ago

  • Related to bug #7245: validation of ToOneRelatedEntityCombobox not working added
Actions #6

Updated by Andreas Kohlbecker almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50
Actions #7

Updated by Andreas Kohlbecker almost 2 years ago

  • Subject changed from required ToOneRelatedCombobox field in SpecimenTypeDesignationDTORow fails validation to required ToOneRelatedEntityCombobox field in SpecimenTypeDesignationDTORow fails validation
Actions #8

Updated by Andreas Kohlbecker almost 2 years ago

  • Related to bug #8249: WeaklyRelatedEntityCombobox: validation of isRequired should only happen after user interaction added
Actions #9

Updated by Andreas Kohlbecker almost 2 years ago

  • Description updated (diff)
Actions #10

Updated by Andreas Kohlbecker almost 2 years ago

  • Copied to bug #9479: ToOneRelatedEntityCombobox misses sending ValueChanged events to MBeanFieldGroup added
Actions #11

Updated by Andreas Kohlbecker almost 2 years ago

  • Related to deleted (bug #8249: WeaklyRelatedEntityCombobox: validation of isRequired should only happen after user interaction)
Actions #12

Updated by Andreas Kohlbecker almost 2 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

no regression occurs in the case described in #7245

no duplicate of #8249

and fully solved

Actions

Also available in: Atom PDF