Project

General

Profile

bug #9368

NullPointerException (NPE) in ManifestComposer.representationPartsToImageContent()

Added by Andreas Kohlbecker 10 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib-remote
Target version:
Start date:
01/08/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

15:51:31.562 [cichorieae] [qtp990416209-33917] INFO  e.e.c.r.c.iiif.ManifestController - doGetMedia() GET: /cichorieae/iiif/taxon/aecd40ae-b77d-495b-a63f-a294c8287089/manifest?type=ImageFile&relationships=&relationshipsInvers=&includeTaxonDescriptions=1&includeOccurrences=&includeTaxonNameDescriptions=&includeTaxonomicChildren=
15:51:32.097 [cichorieae] [qtp990416209-33917] INFO  e.e.cdm.common.media.CdmImageInfo - Content-Length not available in http header. Image size computed via input stream size: https://pictures.bgbm.org/digilib/Scaler/IIIF/Cichorieae!Melanoseris_cyanea_Bc_01/full/!400,400/0/default.jpg
15:51:33.008 [cichorieae] [qtp990416209-33917] INFO  e.e.cdm.common.media.CdmImageInfo - Content-Length not available in http header. Image size computed via input stream size: https://pictures.bgbm.org/digilib/Scaler/IIIF/Cichorieae!Melanoseris_cyanea_A_03/full/!400,400/0/default.jpg
15:51:33.955 [cichorieae] [qtp990416209-33917] INFO  e.e.cdm.common.media.CdmImageInfo - Content-Length not available in http header. Image size computed via input stream size: https://pictures.bgbm.org/digilib/Scaler/IIIF/Cichorieae!Melanoseris_cyanea_Ba_02/full/!400,400/0/default.jpg
15:51:35.083 [cichorieae] [qtp990416209-33917] INFO  e.e.cdm.common.media.CdmImageInfo - Content-Length not available in http header. Image size computed via input stream size: https://pictures.bgbm.org/digilib/Scaler/IIIF/Cichorieae!Melanoseris_cyanea_Bc_05/full/!400,400/0/default.jpg
15:51:35.862 [cichorieae] [qtp990416209-33917] INFO  e.e.cdm.common.media.CdmImageInfo - Content-Length not available in http header. Image size computed via input stream size: https://pictures.bgbm.org/digilib/Scaler/IIIF/Cichorieae!Melanoseris_cyanea_Bc_06/full/!400,400/0/default.jpg
15:51:36.766 [cichorieae] [qtp990416209-33917] INFO  e.e.cdm.common.media.CdmImageInfo - Content-Length not available in http header. Image size computed via input stream size: https://pictures.bgbm.org/digilib/Scaler/IIIF/Cichorieae!Melanoseris_cyanea_A_08/full/!400,400/0/default.jpg
15:51:37.952 [cichorieae] [qtp990416209-33917] INFO  e.e.cdm.common.media.CdmImageInfo - Content-Length not available in http header. Image size computed via input stream size: https://pictures.bgbm.org/digilib/Scaler/IIIF/Cichorieae!Melanoseris_cyanea_Bc_13/full/!400,400/0/default.jpg
15:51:38.335 [cichorieae] [qtp990416209-33917] INFO  e.e.cdm.common.media.CdmImageInfo - Content-Length not available in http header. Image size computed via input stream size: https://pictures.bgbm.org/digilib/Scaler/IIIF/Cichorieae!Melanoseris_cyanea_Bc_14/full/!400,400/0/default.jpg
15:51:38.531 [cichorieae] [qtp990416209-33917] WARN  e.e.cdm.servlet.DateHeaderFilter - Can not add data header.
org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NullPointerException
...

...


Caused by: java.lang.NullPointerException: null
        at eu.etaxonomy.cdm.remote.controller.iiif.ManifestComposer.representationPartsToImageContent(ManifestComposer.java:539)
        at eu.etaxonomy.cdm.remote.controller.iiif.ManifestComposer.manifestFor(ManifestComposer.java:149)
        at eu.etaxonomy.cdm.remote.controller.iiif.ManifestController.doTaxonMedia(ManifestController.java:122)
        at sun.reflect.GeneratedMethodAccessor52470.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.springframework.web.method.support.InvocableHandlerMethod.doInvoke(InvocableHandlerMethod.java:205)
        at org.springframework.web.method.support.InvocableHandlerMethod.invokeForRequest(InvocableHandlerMethod.java:133)
        at org.springframework.web.servlet.mvc.method.annotation.ServletInvocableHandlerMethod.invokeAndHandle(ServletInvocableHandlerMethod.java:97)
        at org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerAdapter.invokeHandlerMethod(RequestMappingHandlerAdapter.java:854)
        at org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerAdapter.handleInternal(RequestMappingHandlerAdapter.java:765)
        at org.springframework.web.servlet.mvc.method.AbstractHandlerMethodAdapter.handle(AbstractHandlerMethodAdapter.java:85)
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:967)
        at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:901)
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:970)
        ... 80 common frames omitted

Associated revisions

Revision 7d7ffcf0 (diff)
Added by Andreas Kohlbecker 5 months ago

fix #9368 NullPointerException (NPE) in ManifestComposer

History

#1 Updated by Andreas Kohlbecker 9 months ago

  • Target version changed from Release 5.19 to Release 5.21

#2 Updated by Andreas Müller 8 months ago

  • Target version changed from Release 5.21 to Release 5.22

#3 Updated by Andreas Kohlbecker 6 months ago

  • Target version changed from Release 5.22 to Release 5.25

#4 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#6 Updated by Andreas Müller 5 months ago

  • Target version changed from Release 5.25 to Release 5.24

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)