Project

General

Profile

feature request #8867

media list services as iiif manifest service

Added by Andreas Kohlbecker about 1 month ago. Updated 18 days ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib-remote
Target version:
Start date:
02/28/2020
Due date:
% Done:

100%

Severity:
normal
Tags:

Description

for providing universalviewer with manifest files (see #5083) all services returning media lists like portal/taxon/{uuid}/media should offer to return iiif manifest files.

It makes sense to bundle all these new iiif manifest services under a new service root path:

/iiif/.../manifest

which of course will also be available as

/iiif/.../manifest.json

The service should enrich the manifest with metadata stored within the images. Metadata for images is provided by the REST service media/{uuid}/metadata which causes the media file to be downloaded. This service should first of all check the server hosting the media object for metadata. The new image server at the BGBM should be able to deliver this information.

Services TODO

  • /portal/taxon/{uuid}/media -> /iiif/taxon/{uuid}/manifest.json - DONE
  • /portal/taxon/{uuid}/subtree/media -> /iiif/taxon/{uuid}/subtree/manifest.json - DONE

Other services which will be implemented in #8883

  • /media/{uuid}/manifest -> /iiif/media/{uuid}/manifest.json
  • /media/findByTitle -> /iiif/media/findByTitle/manifest.json
  • /media/findByIdentifier -> /iiif/media/findByIdentifier/manifest.json
  • /media/findByMarker -> /iiif/media/findByMarker/manifest.json
  • /derivedUnitFacade/{uuid}/derivedUnitMedia -> /iiif/derivedUnitFacade/{uuid}/derivedUnitMedia/manifest.json
  • /derivedUnitFacade/{uuid}/fieldObjectMedia -> /iiif/derivedUnitFacade/{uuid}/fieldObjectMedia/manifest.json
  • /derivedUnitFacade/{uuid}/derivedUnitMedia -> /iiif/derivedUnitFacade/{uuid}/derivedUnitMedia/manifest.json
  • /typedesignation/{uuid}/media -> /iiif/typedesignation/{uuid}/manifest.json

Related issues

Related to Edit - task #5083: Alternative image viewer for dataportal Closed 07/13/2015
Related to Edit - bug #6970: MediaUtils.filterAndOrderMediaRepresentations perfers thumbnail MediaRepresentations over full sized Closed 09/22/2017
Copied to Edit - feature request #8883: additional media list services as iiif manifest service New 02/28/2020
Copied to Edit - feature request #8884: iiif manifest service: enrich metadata with information provided by other iiif image servers New 02/28/2020

Associated revisions

Revision cec7510d (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8868 & ref #5083 bumping jackson to 2.10.2

Revision 2340b64f (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8867 basic implementation of iiif REST service controller

Revision b61d8614 (diff)
Added by Andreas Kohlbecker about 1 month ago

ref #8867 iiif REST service controller correctly choosing thumbnail and fullsize resolutions

Revision 56873306 (diff)
Added by Andreas Kohlbecker 29 days ago

ref #8867 adding image amd cdm media metadata to the manifest

Revision 423442a0 (diff)
Added by Andreas Kohlbecker 29 days ago

ref #8867 dedicated handling of rights and credits

Revision 18049c0b (diff)
Added by Andreas Kohlbecker 28 days ago

ref #8867 copy image attributions & licenses to the manifest

Revision 49805fb2 (diff)
Added by Andreas Kohlbecker 27 days ago

ref #8867 showing licenses also in manifest attributions

Revision 86b41121 (diff)
Added by Andreas Kohlbecker 26 days ago

ref #8867 better presentation of licenses, copyright and access right

Revision b1c11ab3 (diff)
Added by Andreas Kohlbecker 26 days ago

ref #8867 extending taxon manifest by includeTaxonomicChildren parameter

Revision c0667822 (diff)
Added by Andreas Kohlbecker 18 days ago

ref #6970 fixing NPE

History

#1 Updated by Andreas Kohlbecker about 1 month ago

  • Related to task #5083: Alternative image viewer for dataportal added

#2 Updated by Andreas Kohlbecker about 1 month ago

  • Description updated (diff)

#3 Updated by Andreas Kohlbecker about 1 month ago

  • Description updated (diff)

#4 Updated by Andreas Kohlbecker about 1 month ago

  • Description updated (diff)

#5 Updated by Andreas Kohlbecker about 1 month ago

  • % Done changed from 0 to 10

Open issues:

  • Only thumbnail images in the manifest. This is caused by TaxonPortalController.getMediaForTaxon(..) which only returns one low quality representation when no height and width are set. The may be another older ticket related to this problem
  • Add metadata
  • proper setting of canvas height and width, see comment in the code
  • ...

#6 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from New to In Progress

#7 Updated by Andreas Kohlbecker about 1 month ago

  • Related to bug #6970: MediaUtils.filterAndOrderMediaRepresentations perfers thumbnail MediaRepresentations over full sized added

#8 Updated by Andreas Kohlbecker 26 days ago

#9 Updated by Andreas Kohlbecker 26 days ago

  • Description updated (diff)
  • % Done changed from 10 to 50

#10 Updated by Andreas Kohlbecker 26 days ago

  • Copied to feature request #8884: iiif manifest service: enrich metadata with information provided by other iiif image servers added

#11 Updated by Andreas Kohlbecker 18 days ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

above mentioned problems (comment 5) are solved.

Closing this issue.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)