Project

General

Profile

feature request #8475

Adapt applicable state detail view elements to FeatureState

Added by Patrick Plitzner about 1 month ago. Updated 20 days ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
08/16/2019
Due date:
% Done:

100%

Severity:
normal

Related issues

Related to Edit - feature request #8441: Add FeatureState class Resolved 08/02/2019

Associated revisions

Revision 593915d2 (diff)
Added by Patrick Plitzner about 1 month ago

ref #8475 First (unstable) implementation of FeatureState details

Revision cf3d9f76 (diff)
Added by Patrick Plitzner about 1 month ago

ref #8475 Create FeatureState in wizard dialog

Revision 719ac7ab (diff)
Added by Patrick Plitzner 29 days ago

ref #8475 Add applicability detail element to character details view

Revision e9af789c (diff)
Added by Patrick Plitzner 29 days ago

ref #8475 Filter available feature to only parent features

Revision aa312f10 (diff)
Added by Patrick Plitzner 25 days ago

ref #8475 Enhance FeatureStateWizard

  • Pre-select single parent feature if exists
  • filter out features without supported categorical states

Revision 570b874c (diff)
Added by Patrick Plitzner 25 days ago

ref #8475 Only enable details view for feature and character term nodes

Revision 11f52a90 (diff)
Added by Patrick Plitzner 25 days ago

ref #8475 Remove not needed super method

Revision 48a40f35 (diff)
Added by Patrick Plitzner 25 days ago

ref #8475 Use feature selection dialog in feature state wizard

Revision 5801fcdb (diff)
Added by Patrick Plitzner 20 days ago

ref #8475 Update Finish button after state selection

Revision e8617cf0 (diff)
Added by Patrick Plitzner 20 days ago

ref #8475 Remove empty element after first feature selection

Revision edf56664 (diff)
Added by Patrick Plitzner 20 days ago

ref #8475 Remove empty element when single parent is selected

History

#1 Updated by Patrick Plitzner about 1 month ago

#2 Updated by Patrick Plitzner 29 days ago

  • Status changed from New to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 0 to 50

#3 Updated by Patrick Plitzner 29 days ago

Added applicable detail elements to TermNode details view. Available features are filtered to only contain parent feature i.e. features of the parent nodes. After selecting a feature the state combo box is filled with its states. Not yet tested on nightly.

#4 Updated by Andreas Müller 25 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

In this case we do not need an "empty" choice for the dropdowns. A FeatureState always needs to have both, feature and state. If not it needs to be completely deleted, which can be done in Details view.

Also, if there is only 1 parent feature we could prefill the "Parent feature" field.

And we could filter out those features which do not support categorical data and/or which do not have supported states/state vocabularies.

All this is advanced handling so we can move it to new ticket if not straight forward to implement.

#5 Updated by Andreas Müller 25 days ago

I wonder if we could reduce the availability of "InapplicableIf" and "OnlyApplicableIF" to term nodes of term type "Feature" and subtypes (Character" only.
To me it looks like it does not make sence to have them elsewhere.
We could try to handle this on model level by having a sub type FeatureNode which inherits from TermNode, by maybe it is easier to handle this via UI and maybe also via strict validations (model level).

Is it possible to implement this check still for this release? Not 100% necessary but very nice to have because it prevents from having incorrect data afterwards. I also could write the validators but probably don't have time today anymore.

#6 Updated by Andreas Müller 25 days ago

  • % Done changed from 50 to 80

In general this ticket can be closed as it works as expected.

#7 Updated by Patrick Plitzner 25 days ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

Andreas Müller wrote:

In this case we do not need an "empty" choice for the dropdowns. A FeatureState always needs to have both, feature and state. If not it needs to be completely deleted, which can be done in Details view.

Fixed all the issues mentioned except the above, which I do not understand. @Andreas: Can you clarify what the problem is?

#8 Updated by Andreas Müller 25 days ago

  • Status changed from Closed to Feedback

Patrick Plitzner wrote:

Andreas Müller wrote:

In this case we do not need an "empty" choice for the dropdowns. A FeatureState always needs to have both, feature and state. If not it needs to be completely deleted, which can be done in Details view.

Fixed all the issues mentioned except the above, which I do not understand. @Andreas: Can you clarify what the problem is?

The dropdowns in the dialog do show the list of features/states + an empty entry. This empty entry is not necessary. We do not allow an empty entry for a FeatureState therefore the empty entry should be removed as it only creates problems when selecting the wanted feature/state.
Did you implement the other issues from note 4? If not please create a new ticket.

#9 Updated by Andreas Müller 25 days ago

  • % Done changed from 100 to 90

#10 Updated by Patrick Plitzner 20 days ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Patrick Plitzner to Andreas Müller

Removed empty element after first selection.

All issues should be fixed now.

#11 Updated by Andreas Müller 20 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Patrick Plitzner

For future a real freetext search might be preferable for the states in case there are >>10 states, but for now it is ok.

Please still adapt the feature search such that it does not show an empty record from the very beginning. Currently it does it only after a first selection took place.

You may close the ticket then.

#12 Updated by Patrick Plitzner 20 days ago

  • Status changed from Feedback to Closed
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)