Project

General

Profile

Actions

bug #824

closed

Rank labes and Rank names inconsitent

Added by Andreas Kohlbecker over 13 years ago. Updated 12 months ago.

Status:
Closed
Priority:
New
Category:
cdmlib
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

The rank labels and the names used in Rank.getRankByName() are inconsistent thus the following line of code fails:

Rank.getRankByName(subfamily.getRank().getLabel());
Actions #1

Updated by Andreas Müller over 13 years ago

  • Assignee changed from Andreas Müller to k.luther -
  • Target version changed from CDM lib Release 2.0 to CDM lib Release 2.3

Rank.getRankByName() is a preliminary implementation to meet the Berlin Model and other import requirements. That has been documented in the java doc.

Anyway we should think about dictionaries for rank names and other defined term vocabularies.

Maybe we should open a new ticket for this and close this one.

Actions #2

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
  • Status changed from New to Feedback
  • Assignee changed from Katja Luther to Andreas Kohlbecker
  • Target version changed from cdmlib - Old Next Major Release to Release 5.37

I guess we can close this ticket?

Actions #3

Updated by Andreas Kohlbecker about 1 year ago

  • Private changed from Yes to No
Actions #4

Updated by Andreas Kohlbecker about 1 year ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller

Yes, still open. I created a Test to reproduce this issue. However it is completely unclear what is being meant by "byName" in the method name ("Returns the rank identified through a name.") There is no way to find out the supported names without reading the code.

Another point the UnknownCdmTypeException that can be thrown by the getRankByName method. This should be EntityNotFoundException instead

Actions #5

Updated by Andreas Müller about 1 year ago

  • Assignee changed from Andreas Müller to Andreas Kohlbecker

This seems to be a misunderstanding. I did not mean that the issue is "fixed" but according to note-1 it is not an issue. All getRankByName methods do have a javadoc saying that they are preliminary implementation and that they serve only supporting the parser.
I did now additionally change the name of the method to getRankByLatinName() to make the semantics of these methods clearer as they actually only check for Latin labels. Checking for English labels is done by the method getRankByEnglishName or so.

Actions #6

Updated by Andreas Kohlbecker about 1 year ago

I agree with this solution. Please decide how to further proceed with this ticket.
Shall we delete the test method?

Actions #7

Updated by Andreas Müller about 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

I removed the test and close the ticket.

Actions #8

Updated by Andreas Müller 12 months ago

  • Target version changed from Release 5.37 to Release 5.29
Actions #9

Updated by Andreas Müller 12 months ago

  • Category changed from cdm to cdmlib
Actions

Also available in: Atom PDF