Project

General

Profile

bug #8184

SpecimenTypedesignationEditor: add new specimen broken Chrome browser

Added by Wolf-Henning Kusber 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
03/18/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

In Vaadin, type specimen editor a new line is created when a typ is selected.
This functions in FireFox. This does not work in the Chrome browser

Originally reported by Heba:
"Working with Win10+Croome no new line is created" (Heba)

Just an idea: like in other parts of Vaadin menues, it should be possible to add a new type by clicking on a PLUS symbol (this has low priority)


Related issues

Related to Edit - bug #8227: PhycoBank UI and Safari Worksforme 04/08/2019

Associated revisions

Revision 86f09e7b (diff)
Added by Andreas Kohlbecker 8 months ago

fix #8184 using NativeSelect instead of ListSelect to avoid circumvent a bug in the ListSelect which affects the Chrome browser

Revision 16ee34cb (diff)
Added by Andreas Kohlbecker 8 months ago

fix #8184 using NativeSelect instead of ListSelect to avoid circumvent a bug in the ListSelect which affects the Chrome browser

Revision 97c6b732 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #8184 reverting typedesignation status filter back to ListSelect

Revision 7ebcfd4b (diff)
Added by Andreas Kohlbecker 8 months ago

ref #8184 reverting typedesignation status filter back to ListSelect

History

#1 Updated by Andreas Kohlbecker 8 months ago

  • Subject changed from add new specimen to SpecimenTypedesignationEditor: add new specimen broken Chrome browser
  • Description updated (diff)
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.6

#2 Updated by Andreas Kohlbecker 8 months ago

Specimen Editor: auch der erste Typus lässt sich nicht speichern (kritisch)

#3 Updated by Andreas Kohlbecker 8 months ago

this seems to be a bug in the ListSelect which affects the Chrome browser

#4 Updated by Andreas Kohlbecker 8 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#5 Updated by Andreas Kohlbecker 8 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

please review with Heba if this still occurs

#6 Updated by Wolf-Henning Kusber 7 months ago

Testsystem 09 April 2019.

saving types not possible. See also problems with Safari/Mac.

#7 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Resolved to In Progress
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

#8 Updated by Andreas Kohlbecker 7 months ago

  • Target version changed from Release 5.6 to Release 5.7

#9 Updated by Andreas Kohlbecker 7 months ago

  • Related to bug #8227: PhycoBank UI and Safari added

#10 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

I tested with the the latest version of the Google Chrome Browser on Mac and on Windows 10 and had no problems.

Henning and Heba, please test again if you still can reproduce the problem.

#11 Updated by Wolf-Henning Kusber 7 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

No Problems in Chrome browser. Specimens can be saved, references can be selected. Ticket can be closed.

#12 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Resolved to Closed
  • Target version changed from Release 5.7 to Release 5.6

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)