Project

General

Profile

bug #7951

Reference Combobox option titles can be too long causing the select box to extend too much

Added by Andreas Kohlbecker 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
12/11/2018
Due date:
% Done:

100%

Severity:
major
Found in Version:
Tags:

Description

to reproduce go to the new registration view, enter "Kusber" in the combobox and use the mouse wheel to scroll the options.

picture470-1.png View (35.7 KB) Wolf-Henning Kusber, 12/13/2018 05:23 PM

picture065-1.png View (37.6 KB) Wolf-Henning Kusber, 12/13/2018 06:42 PM

picture191-1.png View (57.5 KB) Wolf-Henning Kusber, 12/14/2018 11:52 AM

picture701-1.png View (44.6 KB) Wolf-Henning Kusber, 12/17/2018 10:20 AM

picture998-1.png View (23.9 KB) Andreas Kohlbecker, 12/18/2018 08:51 AM

picture185-1.png View (30.6 KB) Andreas Kohlbecker, 12/18/2018 08:54 AM

picture294-1.png View (63 KB) Wolf-Henning Kusber, 12/18/2018 11:18 AM

picture630-1.png View (82 KB) Andreas Kohlbecker, 12/19/2018 04:22 PM


Related issues

Copied to Edit - bug #7959: LazyCombobox popup over sizing problem New 12/19/2018

Associated revisions

Revision bf643f22 (diff)
Added by Andreas Kohlbecker 5 months ago

fix #7951 ReferenceLabelProvider to ellipsis the reference labels

Revision 532d021f (diff)
Added by Andreas Kohlbecker 5 months ago

ref #7951 ReferenceLabelProvider: fixing wrong string replacement for more complete ellipsis

Revision 2192ca65 (diff)
Added by Andreas Kohlbecker 5 months ago

ref #7949 renaming ComboboxLabelProvider to EllypsisFormatter and other classes accordingly, abstract base class introduced

Revision 569b2942 (diff)
Added by Andreas Kohlbecker 5 months ago

ref #7951 moving EllypsisFormatter to cdmlib/model/eu.etaxonomy.cdm.format

Revision e8b9f0b2 (diff)
Added by Andreas Kohlbecker 5 months ago

ref #7951 more complete generic ReferenceEllypsisFormatter

History

#1 Updated by Andreas Kohlbecker 5 months ago

  • Subject changed from LayzyCombobox option titles can be too long causing the select box to extend too much to Reference Combobox option titles can be too long causing the select box to extend too much

#2 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker 5 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

please review

#4 Updated by Andreas Kohlbecker 5 months ago

[Henning:]

Überwiegenst hast Du die wichtigsten Keywords rausgefischt, was mir aufgefallen ist, dass das Kürzen bei Buchtiteln irgendwie nicht funktioniert.

Die Auswahl springt etwas pro Bildschirm und richtet sich nach dem längsten Eintrag, der (positiv) nicht mehr über die Gesamtbreite hinausgeht.

Schau Dir bitte die Suche nach Lange-Bertalot an, dann siehst Du, wo noch nicht gekürzt wird.

....

gerade mit Regine gesprochen, die nur inhaltlich schaut. Im Einzelfall fragte sich natürlich: warum steht da nicht, um welche Taxa es geht. Das sind Luxusfragen. Ich bin mit ihr einige Autorinnen und Autoren durchgegangen und in den allermeisten Fällen war Deine Kürzung eindeutig und aussagekräftig, schön!

#5 Updated by Andreas Kohlbecker 5 months ago

Ich habe nun noch einen Bug gefixt, es lang nicht an den BookSections sondern eine Stringersetzung hatte Probleme mit Klammern. Jetzt funktioniert die "Ellypse" für alle bis auf:

Kulikovskiy, M. & Lange-Bertalot, H. - Validation of some taxa. in Kulikovskiy, M., Lange-Bertalot, H., Metzeltin, D. & al., Lake Baikal: Hotspot of endemic diatoms I.Iconographia Diatomologica, 23: [1]-861. 2012

das ist ein absoluter Sonderfall:

Diese Referenz hat 2 In-Referenzen:

BookSection:
Kikovskiy, M. & Lange-Bertalot, H. - Validation of some taxa. in Kulikovskiy, M., Lange-Bertalot, H., Metzeltin, D. & al., Lake Baikal: Hotspot of endemic diatoms I.Iconographia Diatomologica, 23: [1]-861. 2012

in BookSection:
Kulikovskiy, M., Lange-Bertalot, H., Metzeltin, D. & al. - Lake Baikal: Hotspot of endemic diatoms I. in Taxonomy - biogeography - diversity. 23. 

in Book:
Taxonomy - biogeography - diversity. 23. 2012 

wobei aber die 2. In-Referenz (Book) durch den geschützten TitelCache in der ersten BookSection überschrieben wird: "Iconographia Diatomologica, 23" statt "Taxonomy - biogeography - diversity. 23" aus diesem Grund kann die Text-Ellypse nicht funktioniern.

Ein Datenfehler oder beabsichtig?

#6 Updated by Wolf-Henning Kusber 5 months ago

Mit der Referenz hatte ich Probleme. Die Wiedergabe des Buches ist ungenügend (siehe Screen shot).
Editor fehlt, "23" macht nur als Vol. der Book series "Iconographia Diatomologica" Sinn. Bis auf die Seitenzahlen ist das Buch vollständig erfasst.

#7 Updated by Wolf-Henning Kusber 5 months ago

Book title causes problems. Combobox longer than screen. Date not given AND title not shortened. See screen shot:

#8 Updated by Andreas Kohlbecker 5 months ago

The Book "Greuter, McNeill, Barrie, Burdet, Demoulin, Filg., Nicolson, P.C.Silva, J.E.Skog, Trehane, Turland, D.Hawksw. & al., International Code of Botanical Nomenclature (Saint Louis Code) adopted by the Sixteenth International Botanical Congress St Louis, Missouri, July-August 1999Regnum Vegetabile, 138. 2000" is not atomized. This is why it can not be truncated.

As far as i understand the problem pointed out it comment 6, it is a limitation of the ReferenceCacheStrategy and has noting to do with this issue here.

#9 Updated by Wolf-Henning Kusber 5 months ago

We should differentiate between atomized data and protected/unprotected caches and bibliographic/nomenclatural references. The respective reference looks like this (screen shot).
Data atomized.
Reference Cache (=bibliographic) = unprotected, i.e. the padlock is open to allow atomized data to update the cache.
Nomencl. Cache (=nomenclatural reference) = protected, i.e. the cache is saved "as is" in the field and is protected by a closed padlock.
It is not clear in Vaadin on which cache the reference is searched.

Bemerkung:Eine Änderung in den atomisierten Daten hat eine Änderung im Feld mit geschlossenem Schloss, aber keine Änderung im Cache mit geöffnetem Schloss bewirkt, das ist völlig absurd. Das Schließen des Schlosses beim Reference Cache hat ein Update des Feldes bewirkt, das ist eine Funktionalität, die weder in einem Mouseover erklärt wird, noch im NutzerInnen-Handbuch, noch irgendwie intuitiv nachvollziebar ist.

#10 Updated by Andreas Kohlbecker 5 months ago

I improved the label ReferenceEllypsisFormatter so that it can deal with any title cache protection. thus the above problems are eliminated by the new implementation.

Please review again.

#11 Updated by Wolf-Henning Kusber 5 months ago

  • File picture701-1.png View added
  • Status changed from Resolved to In Progress
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 60

2018-12-17 no changes visible for me.

Normally the formatter works well.
Problems with long book titles are not solved.
Search for "Greuter" same as shown in #7.
Search for "Lange-Bertalot", "Hofmann"

A new layout problem occurred: Even if a long title shortened, the dropdown menue is too long (see screen shot).

An old/new related layout problem occurs:
If there are two long dropdown boxes AND the user reaches the box with the mouse beginning below the box, the Vaadin screen is pushed to the left (see screen shot).

#12 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

The test server was not yet up to date. After the server was buidl freshly I could not reproduce any of the above named issues.
Please test again.

#13 Updated by Wolf-Henning Kusber 5 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 60 to 70

"Greuter" Ref. solved. Layout problems not, see #11

A new layout problem occurred: Even if a long title shortened, the dropdown menue is too long (see screen shot).

An old/new related layout problem occurs:
If there are two long dropdown boxes AND the user reaches the box with the mouse beginning below the box, the Vaadin screen is pushed to the left (see screen shot).
New Add: it also happens when the mouse is above the box.

#14 Updated by Andreas Kohlbecker 5 months ago

  • File picture998-1.png View added
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

For me it looks like this:

I think we should discuss these differences we see in a telco.

#16 Updated by Wolf-Henning Kusber 5 months ago

Die meisten Unstimmigkeiten kommen durch IAPT-Altdaten und Einträge aus dem ersten Jahr PhycoBank.
Dort wurden Serien wie Journals behandelt und es gab keine Sections. D.h. Grundsätzlich ist folgendermaßen verfahren worden.

Artikel: Algenname Nomenklatorisches Autorenteam in Jounal Volume: Ref. detail
(Das ist ein Verfahren, dass pragmatisch und nomenklatorisch korrekt ist, allerdings bibliographisch nicht regelgerecht und nicht CDM-konform). Das war auch einer der Hauptgründe, warum wir mit der AlgaTerra-Migration nicht richtig weiter kamen.

Tatsächlich müsste es in PhycoBank folgendermaßen hinterlegt sein:

Sektion: Algenname Nomenklatorisches Autorenteam in Booksection: bibligraphisches Autorenteam: Titel in: Book: Editorenteam: Titel des Buches, Seitenzahlen. Reihe Volume. Verlagsort, Verlag.

Bei letzten beiden ist immer die Frage der Reihenfolge.
Jedenfalls ist kein automatisiertes Verfahren möglich, da hunderte von Namen neu evaluiert werden müssen.

#17 Updated by Andreas Kohlbecker 5 months ago

  • File picture630-1.png View added
  • Status changed from Feedback to In Progress
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

The data problems pointed out in comment 16 are not really relevant for this issue.

But there is still one situation in which the combobox popup is exceeding the overall page width, even if there is no such long label in the popup:

This can be reproduced by scrolling the pages via the page down button or with the mouse wheel.

#18 Updated by Andreas Kohlbecker 5 months ago

This obviously comes from the vaadin combobox, the width of the div containing the table is set too wide:

<div class="v-filterselect-suggestmenu" style="overflow-y: auto; width: 1025px;">
    <table>
       <tbody>
          <tr>
             <td class="gwt-MenuItem gwt-MenuItem-selected" role="listitem">
                 <span>Krasske, G.Zur Diatomeenflora …

This bug only becomes apparent with specific browser window widths and is easier to reproduce on Version 71.0.3578.80 (Official Build) Built on Ubuntu , running on LinuxMint 18.2 (64-bit) (page size 1276.150 x 790) or with Firefox on Windows than with Firefox 64.0 (64-bit) on Linux

I think we should close this issue in favor of opening a lower priority issue for the vaadin combobox resize problem .... #7959

#19 Updated by Andreas Kohlbecker 5 months ago

  • Copied to bug #7959: LazyCombobox popup over sizing problem added

#20 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 70 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)